Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cannot connect data HDs after installing SSD and setting SATA to ACHI

19 Oct 2014   #1

Windows 7
Cannot connect data HDs after installing SSD and setting SATA to ACHI

I have set up a new rig with the following components:

Gigabyte Z97X-SLI
Intel Core i5-4690K
Samsung SSD 840 EVO 250GB Drive

Im running everything pretty vanilla, using onboard video, audio, network, etc.

I originally installed Win 7 with the BIOS SATA mode set for IDE as I have two data drives that I used on my older rig that I wanted to access and the system would not boot with the SATA mode set on ACHI. All worked fine until I reset SATA to ACHI and then I could not boot. I get through the BIOS boot and windows went into its "Launch Startup Repair" routine but then just kept looping back to that screen. Since I wasn't getting anywhere with swapping SATA ports and doing the regedit changes to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services|msachi start=0 and ...Pciiede Start=0 , I decided I would just disconnect the data drives and reinstall windows with the BIOS SATA mode already on ACHI. I was able to get that done with no problem and the system boots fine with just the SSD and my CDDVD drive plugged in. Whenever I add either of the two data drives or both simultaneously, I cannot boot, and windows goes into the "Launch Startup Repair" routine which will not complete and just says that I have added hardware that is not being recognized. I have tried the trick with the regedit entries and no luck.

My two drives are both Western Digitals. One is a WD20 EFRX 2 TB drive recent vintage. The other is an old WD 1600 160 GB drive. When I view the device manager screen, there is a warning shown under Other Devices - PCI Simple Communications Controller. When I try to update the driver for this device, windows cannot find it. Somehow, I think this must be the root of the problem but I don/t know how to fix it.

My System SpecsSystem Spec
20 Oct 2014   #2

Win7 SP1 + Ultimate 64 bit

Does the BIOS recognise the drives? is the WD1600 160gb drive sata ???. If it is the old style Sata 1 it might not work too well and AFAIK, older sata drives will slow your main drive down?
I just built myself a new machine using a GA Z97X Gaming 3 and have had no dramas, maybe I was lucky. BTW, the other two drives, do they have stuff on them? Maybe you need to format them both and then try to add.
I just noticed, why did you change the pciiede setting? It should be 3, not 0
My System SpecsSystem Spec
20 Oct 2014   #3

Windows 7

The BIOS sees the drives. I run into trouble when Win 7 starts to boot and it does the "Launch Startup Repair" routine, which it refuses to complete. I have tried removing the partition from the old 160GB drive using Gparted and then, since that made no difference, I formatted it with an NTFS partition. Still no success. The 2BG drive is fairly new and it has data on it that I want to access so formatting it is not an option. FWIW, I ran Gparted from an Ubuntu 14.4 live cd and it booted fine, saw all drives, and I could see the file structure, etc, so I think the drives are fine.

I changed the pciide start key from 3 to 0 as recommended elsewhere on SevenForums. Easy enough to change back as the system boots fine when neither hdd is connected. That's what really has me scratching my head. Why would windows boot fine with just the SSD and CDDVD plugged in and then go nowhere just because I add a hdd? This seemed like such a simple thing on my old system running Win 7 so long as the BIOS picked up on the change. What is it about ACHI that makes this not work? I wonder if I should not just go back to an IDE setting as this just does not seem to be worth the hassle, although I can't say that I want to reinstall Win 7 once again. I don't know enough about ACHI to know if I should be looking to Gigabyte, Samsung, or Intel for help.
My System SpecsSystem Spec

21 Oct 2014   #4

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Common issue with UEFI and old data disc.

The motherboard Gigabyte Z97X-SLI uses GIGABYTE UEFI DualBIOS™.

UEFI, when enabled, formats a disc to GPT partition table during windows installation. GPT + UEFI makes the system unbootable whenever a new disc of MBR partition table added to the system.

Without any other disc connected than the main OS dics, your system should boot perfectly.

Two options you have there to deal with this issue.

First, format all your old data discs to GPT ..... but that will erase the data from the disc. So you may need to back up the data before formatting.

Second, disable UEFI. Boot into your BIOS. Check it throughout. Wherever there is an option of UEFI, set it to "Legacy". Everywhere throughout the BIOS setup. I would suggest you to disable UEFI and perform another clean install, which will format your main disc back to MBR partition table.

Either of these two options will make your system bootable again.
My System SpecsSystem Spec
21 Oct 2014   #5

Windows 7

Thanks Arc,

I had some suspicions about this and I played around with the UEFI / Legacy settings last night and got the system to boot with the old 160 GB disk plugged in, but it was freshly formatted to NTFS. The newer one, a 2TB WD disk has my backup data on it so I just reinstalled it in my old machine for now as I don't want to reformat it and was nervous about playing around with it. I'm thinking I'll buy a new 1TB disk for data as I know a new disk will play well with the SATA 3 controller and will be faster. Will be interesting to see if it boots after installing the new disk but at least I have a path to follow now if it doesn't.

Thanks for your helpful information.
My System SpecsSystem Spec
21 Oct 2014   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

New discs are always good.

I faced this issue myself, after changing the motherboard. I still use the old HDDs, with UEFI off.
My System SpecsSystem Spec

 Cannot connect data HDs after installing SSD and setting SATA to ACHI

Thread Tools

Similar help and support threads
Thread Forum
need help with data transfer via SATA to USB
i'm going abroad for a while with my laptop. i can't take my desktop pc, but i can take the hard drive which has 1.5 TB of data on it. my laptop top hard drive is only 750GB big so i bought a USB 3.0 to SATA cable so that i can you my hard drive when i'm away i plug my hard drive into my laptop it...
Hardware & Devices
Intel(R)ICH9M/M-E Family 4 Port SATA ACHI Controller-2929?
I performed a driver scan using "Driver Agent" & "DriverEasy" Its telling me that Intel(R)ICH9M/M-E Family 4 Port SATA ACHI Controller-2929" has an available update but wont let me get the driver unless I pay :cry: 1.) what is this driver? 2.) is it worth updating? 3.) any idea how I can...
Switching BIOS SATA RAID/AHCI setting causes BSOD at Windows Start
I just changed my disk setup from: 1 SATA HDD Primary OS Disk 2x SATA HDD Backup Disks in RAID 1 TO: 1 SATA SSD Primary OS Disk 1 SATA HDD Backup Disk
Hardware & Devices
Setting up HDD for SSD temp and User data
Now I have looked through the tutorials for SSD related functions and I am not sure how I should set up a brand new 500GB HDD to transfer my User and temp files from the SSD to it.. I just want to get it right as I have just had some major issues with using th SSD - problem solved and I don't...
Hardware & Devices
Broken HDD sata data tip possible fix?
Is there a way I could possibly fix this hdd that i accidentally broke a month ago and had to replace with a 500gb. I really want to be able to use it as a back up drive and retrieve my files from my 1tb HDD.The pins are all still there just the plastic L broke off when I was removing the sata cord...
Hardware & Devices
How to configure a SATA to win 7 for data.
Hey There, is there anybody that has the expertise to configure a 320 gig Western digital SATA on a Win 7 Ultimate 32 bit as an Data Drive.I took out the 40 gig IDE that was on the Data end,and replaced it so my wife would have more,Gig space to download more movies and,handle extra information. I...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App