Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SATA driver issue w/ Win 7 and Gigabyte GA-MA785G-UD3H

04 Nov 2009   #1

Windows 7 Home Premium
SATA driver issue w/ Win 7 and Gigabyte GA-MA785G-UD3H

Using Win 7 64-bit with AMD SATA drivers with a strange issue.

When this board boots up it does an AHCI initialization which shows the attached sata drives. After that, Windows 7 loads and runs without a problem. However, when I reboot Windows it sounds like the hard drives spin speed is slowing down then speeding up again. It does this about 4 times then the computer shuts down. When the computer restarts and goes back to the AHCI init screen it now shows "S.M.A.R.T. Error", but Windows boots without a problem. If the computer is shut down (powered off) the next boot will not show the error.

I've had Windows 7RC 32-bit, and currently also have XP-64 and XP-32 partitions on this machine with no problems at all. If I set the machine to Native IDE instead of AHCI everything goes back to normal with no shutdown issues.

Any ideas?

My System SpecsSystem Spec
07 Nov 2009   #2

Window 7 64-bit

Have you Disabled the S.M.A.R.T. in your Bios.
My System SpecsSystem Spec
08 Nov 2009   #3

Windows 7 x64

I'm having almost the exact same problem with a Gigabyte MA790XT-UD4P using the AMD 9.10 AHCI driver.

The computer will start from a cold boot just fine. However, if I restart, it hangs at "AHCI Drive Init" and shows SMART errors on all HDDs except the boot HD. That's as far as it gets; I have to hit the reset button, and then it will boot normally.

I don't have this problem with the Microsoft driver, but it has the disadvantage of booting very slowly.
My System SpecsSystem Spec

09 Nov 2009   #4

Windows 7 Home Premium

I'm thinking there's a problem with the Windows 7 64-bit driver. I haven't had any issues with WinXP 32 or 64-bit or with Windows 7 RC 32-bit. It appears that the driver isn't shutting down the controller properly and it's setting some kind of flag in the drives S.M.A.R.T. tables. The flag seems to clear on a cold boot. My system boots normally even with the error.

I haven't found that the MS drivers loaded slowly, but it seems the POST takes longer to complete when the controller is set to Native IDE. Although, when it's set to AHCI you have to wait for the AHCI init to finish and then wait for the Press CTRL-A prompt to go to the AHCI controller screen (which is absolutely useless anyway). So it's 6 of one and half-dozen of the other.

I don't sense any performance hit from using the Native IDE setting.
My System SpecsSystem Spec
09 Nov 2009   #5

Windows 7 Home Premium 64-bit
Same here, same motherboard

I am also having a problem with a hard drive in AHCI mode hanging on boot, then giving a "S.M.A.R.T. Error". This is on a Gigabyte GA-MA785G-UD3H and the hard drive is a Western Digital 10EACS. I know it does this on reboot, I'm not certain if a cold boot does the same.

Western Digital's utility and SpeedFan analyze the drive and say the SMART data is OK.

I'm also experiencing a really long boot time that may be unrelated. When the "Starting Windows" text comes up, it takes about 45-60 seconds before the windows logo shows up and starts to pulse and I can hear the hard drive activity start up at that time.

I've updated my BIOS, tried different drivers, and even attempted a system restore but the problems won't go away. I built this system on Saturday and everything was fine. Both problems started on Sunday when I was fine-tuning this fresh system with updates, apps, etc. IDE mode does not have the SMART error, but the long boot time is still there. I need AHCI for eSATA hot plug anyways.

I think I will scap the whole thing and do a clean install tomorrow morning to see if the problems go away. If anyone figures out what the problem is, please post back here to help out the group.
My System SpecsSystem Spec
09 Nov 2009   #6

Windows 7 Ultimate x86-64

Why don't you use native IDE? Isn't AHCI used for hotplugging hard drives?
My System SpecsSystem Spec
10 Nov 2009   #7

Windows 7 Home Premium

Rwpritchett indicated he wanted to hot-plug his eSata drive.

There is some wacky stuff going on with this board, though. It seems like the drive (a WD Black 1TB) takes a long time to spin up when it's attached to this motherboard, and it does take a long time for the system to complete its POST and get to the Win7 boot manager screen. I've come to accept it though, because the system is fast, stable and responsive once it's booted. This board also took a long time to settle in - as ridiculous as it sounds. I've been building systems since the early nineties and have noticed that many components have to acclimate to their environment before they start working reliably.

My previous board, a MachSpeed MSNV-939, which only had SATA I, didn't show any of these peculiarities - it had its own bunch of issues (noisy chipset fan, no USB boot, etc.). I'm using the same power supply so I'm thinking the slow drive spin-up is related to the motherboard.
My System SpecsSystem Spec
10 Nov 2009   #8

Windows 7 Home Premium 64-bit
SATA controller....

I attempted to do a clean install this morning. I was unsuccessful installing Windows 7 with the controller set to AHCI. My optical drive would not boot to the disc unless I set the controller to native IDE so I installed Win7 in IDE mode. I'll have to jump through some hoops later to switch to AHCI mode. I ran out of time this morning so I don't know if the S.M.A.R.T. error is still there.

The long boot time is still a problem even with the clean install. I timed it... 65 seconds just sitting there doing nothing, which makes my total boot time around 2 1/2 minutes.

Tomorrow, I'm going to attempt a number of things:

#1 Boot to a SATA addon card with the GA-MA785G-UD3H SATA controller disabled.

#2 Clone my fresh install to my 1TB WD black drive and see if its my hard drive that is causing the problems.

jnorris- What BIOS are you using? I'm using F4, and I think my problems started after updating the BIOS. I might try to roll back to F3 and see if that solves the S.M.A.R.T. error and long boot problems. Maybe the GA-MA785G-UD3H has problems? I can't find anyone else having these issues though. I'd hate to RMA this board, it has everything I need.
My System SpecsSystem Spec
10 Nov 2009   #9

Windows 7 Home Premium

2.5 minutes is a long boot, but I don't think it's the BIOS. I'm using F4 too, and have noticed no longer boot times due to it. As a matter of fact I updated from F3 in order to see if boot times improved - they didn't (although next to yours, my boot time is relatively speedy).

A few things you might want to try...
Turn off Enable Legacy USB (I think that's what it's called) support - this will keep the motherboard from searching for and enabling USB drives during boot. This has the unfortunate side effect of disabling booting to USB drives. Also, if you've got a USB hard drive attached to the system disconnect the USB cable - even if it's turned off.

It sounds like the system board is booting OK, but something attached to the system is taking a long time to initialize. Disconnect or disable any extraneous hardware (sound, add-in cards, etc.) to see if you find a culprit.

Disable any unused ports in the BIOS like serial, parallel, or firewire.

See if any of it helps.
My System SpecsSystem Spec
10 Nov 2009   #10

Windows 7 x64

A couple of things that may help your boot times: If you are not using the PATA connection or a floppy drive, disable them in the BIOS.
My System SpecsSystem Spec

 SATA driver issue w/ Win 7 and Gigabyte GA-MA785G-UD3H

Thread Tools

Similar help and support threads
Thread Forum
Ga-Z87X-UD3H & Marvell SATA Driver
I have a Gigabyte GA-Z87X-UD3H motherboard and I am not using RAID, just a single drive in the Intel SATA port. Do I still need to install the Marvell Driver for the Marvell SATA ports if I am not using them. Thanks
Gigabyte GA-Z77X-UD3H drivers not loading
I am looking for drivers for Ethernet Controller, PCI Simple Communications Controller, SM Bus Controller, and 2 Universal Serial Bus (USB) Controllers. When I use update driver in the Device Manager, they will not load automatically. I do not find them on the Gigabyte or Intel websites.
Gigabyte Z77X-UD3H onboard Intel graphics - DVI issues
Hi all, I'm trying to run two monitors in Win7 using my Gigabyte z77x-ud3h. If I install NO drivers, I get a mirrored display; if I install either the Gigabyte Intel VGA driver or the native Intel driver, however, I get dual monitor performance... but only when the driver is freshly installed...
Graphic Cards
Can I Add Additional Display Card to Gigabyte h67a-ud3h-b3?
Wasn't exactly sure where to put this question. I have a machine with a h67a-ud3h-b3 MOBO abd an currently using both video outputs. Nice board. Does anyone know if I can add an addtional video card to the board without having to disable the on-board video. Yes, I'd like a 3 or 4 monitor system....
Hardware & Devices
x-fi xtreme audio or gigabyte 880GA-UD3H onboard
hi folks id just like to pick some brains on this 1 plz. i hav just upgraded my mobo to a gigabyte 880GA-UD3H but i had a friend do the fitting. he put my x-fi extrem music soundcard back in too and i was wondering if there is realy any point in using the sound card as its a brand new mobo and i...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:31.
Twitter Facebook