Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB 3.0-Computer does'nt meet requirement for installing the software.

10 Jan 2015   #31

Windows 7 Ultimate x64

renesas drivers..

My System SpecsSystem Spec
10 Jan 2015   #32

windows 7 home 64bit

That is not for your System as you have Intel USB ..
My System SpecsSystem Spec
11 Jan 2015   #33

Windows 7 Ultimate x64

why isn't it working then? Give me the links for the usb 3.0 that can be installed
My System SpecsSystem Spec

11 Jan 2015   #34

windows 7 home 64bit

Try the Link below see if that makes any changes to your System ...
My System SpecsSystem Spec
21 Jan 2016   #35

windows7 home premium

Hi, I finally figured this out, well what worked for me that is....Firstly remove both chipset controllers in device manager,,,then reboot the pc, windows will install a standard enhanced controller upon boot,,,,then only can you install your usb3.0 controller,,,then install the correct series of chipset family usb enhanced controller. gl
My System SpecsSystem Spec
30 Dec 2016   #36

Windows 8.1, x64

"This computer does not meet the minimum requirements for installing the software" for USB 3.0 Drivers

Download first: Driver

1. Extract contents of the downloaded zip file to the desktop.
2. Open Device Manager and search for 'Universal Serial Bus controllers' and expand dropdown.
3. Right click 'Standard Enhanced PCI to USB Host Controller' and choose "Update Driver".
4. Choose: "Let me pick from a list..."
5. Click on "Have Disk" on the bottom right and click on "Browse".
6. Search for the folder previously extracted to the desktop and navigate until you reach "/.../Drivers/Win7/x64 subdirectory".
7. "Select the driver you want to install..." to be "Intel(R) USB 3.0 eXtensible Host Controller" and click 'Next' then 'Yes'. Do not restart.
8. Select to install "Intel(R) USB 3.0 Root Hub" as well. The USB ports will now become nonfunctional, forcing you to do a hard shutdown. Reboot your system and go into your BIOS and change 'XCHI Mode' to "Smart Auto" or "Enabled".
My System SpecsSystem Spec

 USB 3.0-Computer does'nt meet requirement for installing the software.

Thread Tools

Similar help and support threads
Thread Forum
Driver Install Error "Computer doesn't meet requirements"
Hey guys, My dad recently bought a HP Windows 8 laptop but can't get used to the new OS. He asked me to install Windows 7 on it for him. I'm currently trying to get the drivers sorted for it and for the Windows drivers such as Chipset and Graphics, i'm getting the error "This computer does not...
Graphics drivers can't install, says computer doesn't meet requirement
Hello there!! I'm running a Fujitsu Lifebook T4125 with Windows 7 Professional x64 installed on it. I had been previously running windows 8, but upon facing graphics driver issues, the website told me that they were not supporting 8 and had no drivers for it. As such, i switched to 7, thinking my...
Graphic Cards
Driver Install Error - Computer doesn't meet the requirements
Dell Latitude E6430 I'm trying to install Intel HD 4000 graphics driver to my E6430 but Driver Install Error - Computer doesn't meet the requirements In device manager, Display adapter shows my currently shows NVIDIA NVS 5200M. No INTEL HD graphics Do I even need to download the HD...
Problems installing wireless adaptor software on new computer
Hello everyone, I just bought a new Alienware computer from Dell which comes with Windows 7 Home Premium pre-installed on it. I am trying to install the BT Voyager Wireless Adapter software from my old BT Voyager 1055 USB 2.0 Adapter, which worked fine with my previous computer, but whenever I...
Hardware & Devices
console and silent flag requirement for software installation
I am trying to install Uptodate, a medical software. The installer file stops installation with a message that the installer cannot run in graphic mode, try with -console or -silent flag. The same installation worked smoothly in my XP based system. I am currently using Windows 7 home basic (64...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App