Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: trouble loading 1st driver needed - Mass Storage Driver

07 Nov 2009   #1

Window 7 64-bit
Trouble loading 1st driver needed - Mass Storage Driver

This is what I written down for Gigabyte Tech Zone but I don't want to wait a month or 2 for the reply.

I used to have used Vista 64bit before with Hard Drives in Raid0 and I am trying to load Windows 7 64bit with just 1 hard drive. In the Bios I have disabled SATA RAID/AHCI Mode & changed Onboard SATA/IDE Device to enabled & changed Onboard SATA/IDE Ctrl Mode to IDE. On boot it finds the Hard Drive but when I install it gets to the Load Drivers section and when I scan or Browse for the drivers it doesn't find any drivers for it using all the Gigabyte drivers that are loaded on a USB thumb drive (latest Gigabyte Windows 7 drivers included). I imagaine it is probably looking for the Intel ICH9R/ICH10R Driver or Intel ICH9R/ICH10R SATA RAID Driver or the Mass Storage Drivers and as there were no Windows 7 available on Gigabyte I tried the Vista ones with no success. Could you advise what is needed to get it running again. Whether I missed something it the BIOS etc.... Thanks

Drivers are loaded on a USB Thumb Drive but I did try a floppy disk at one stage but may not have had the correct drivers on the floppy drive. The USB Thumb Drive had all Vista & Windows 7 Drivers available on Gigabyte Website on it.

Also if I use any of the Vista 64-bit drivers it comes up with the warning as follows:
To continue installation use the 'Load Driver' option to install 32-bit and signed 64-bit drivers. Device Driver is not supported and might result in an unusable Windows installation.

I am just not sure what driver it is looking for, as none of the new Windows 7 drivers from Gigabyte website are useful. Thanks

OK, I just found that it is looking for mass storage driver for installation and looking where i want to install it to. It could be that the system is still looking for a RAID ARRAY drivers as I think in boot up it still says there is no drives for the RAID ARRAY but I am not sure as it is so fast I cant even pause it in time.

I did redo the RAID setup in the BIOS and then went into the RAID ARRAY setup and deleted the RAID0 setup there. Then I tried to load the Mass storage Drivers again when installing Windows 7, but still no luck.

This is basically as far as I can get and there is no Hard Drive like there is shown in this picture, so this leads me to believe I need to still dispose of the RAID ARRAY setup from the previous Vista install in the BIOS possibly. But I am not sure what to do as I thought I would just Disable RAID in the BIOS.

(picture courtesy of Brink Administrator Windows SevenForum)

System Specs
OS : Window 7 64-bit
CPU : Intel LGA 775 2.83Ghz
Motherboard : Gigabyte GA-X48-DQ6
Memory : G Skill 1066Mhz DDR2 4Gb - 2 x 2Gb Dual Channel
Graphics Card : ATI 3870
Sound Card : Realtek ALC889A codec
Monitor Displays : Dell 24" LCD
Screen Resolution : 1920 x 1200 pixels
Hard Drives :Samsung 750Gb
PSU :Thermaltake 850w

Does anyone have any ideas on what to do. Thanks

My System SpecsSystem Spec
11 Jan 2011   #2

windows 7

Can you not use the restore BIOS to default settings options then use the windows setup options to delete any possible boot partitions holding information regards booting raid 0 from your drives. You should then be able to install windows 7 normally and install your drivers once windows is installed.
My System SpecsSystem Spec

 trouble loading 1st driver needed - Mass Storage Driver

Thread Tools

Similar help and support threads
Thread Forum
No Drivers Found. Click Load Driver to Provide Mass Storage Driver....
Hi all, I'm getting the above error when trying to do a clean install of Windows 7 from a USB drive using the Rufus program for the ISO. I've tried everything I have found online and nothing works: 1. normal boot from a W7 ISO formatted as NTFS using Rufus - same error :shock: 2. Shift +...
Installation & Setup
Driver for Mass storage controller
Hi, Recently I have completely re-installed Windows 7 prof 32 bit on my sony vaio (VGN-NR11Z/T) laptop. I had an in-built SD card adapter which didnt work anymore after re-installation. Also in device manager, I can see a yellow sign in Mass storage controller. Can anyone help me to install...
Mass Storage Driver Needed
Hello I need a Mass Storage Driver to copy my old computer to a new computer, via Acronis True Image. The new computer is made to order by Cyberpower. The drive is WD 1 TB CAVIAR BLUE SATA III 6.0 GB/7200 RPM. The board is ASUS P8Z77-V LK 277.
No drivers found. click load driver to provide a mass storage driver f
Okay so, my laptop's system is unable to boot, so I just tried to format it since I have to do that for a very long time, and when it asked me in which partition I want to install windows there was nothing, although when I clicked "Load Driver" I could access the hard disk's files, the hard disk IS...
Hardware & Devices
Mass Storage Controller - No driver for it
Hi all, I really hope someone can help me b/c I've been in computer hell for 4 days now. Long story short, my hard drive in my Dell Studio 1745 died. Finally got my data recovered from the drive. I reformatted that drive and reinstalled Win7, but it hung up alot. I did this several times...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:13.
Twitter Facebook