Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ASRock N68C-GS FX Network controller driver

27 Aug 2015   #11

Windows 7 Ultimate SP1 x32

When I run the Nvidia drivers installer (all in one package) downloaded from the ASRock site or Nvidia site I got no errors. When I say 'no errors' I mean that installation (display driver, sata, ethernet...) completes successfully. When I check Device Manager it still displays the Network controller as not working.

I'm running 32 bit version of Windows.

My System SpecsSystem Spec
27 Aug 2015   #12

Windows 7 Ultimate SP1 x32

Maybe the NIC is dead despite beeing detected by the OS.
My System SpecsSystem Spec
27 Aug 2015   #13

windows 7 home 64bit

Quote   Quote: Originally Posted by techsoul8 View Post
Maybe the NIC is dead despite beeing detected by the OS.

Well that is possible ... But let us check to see what is Installed ...

In the Device Manager expand System Devices and Post a Screenshot please ...
My System SpecsSystem Spec

27 Aug 2015   #14

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64

If I may assist, a Dxdiag report can also provide useful information in this case. First, list any Problem devices
  • Make sure devices are connected and powered on
  • Click the Start Orb, type msinfo32 in the search box. Hit Enter
  • Click the + sign next to Components to expand it
  • Click Problem Devices. Anything appear?
  • If yes, click on it, Ctrl-A to select all, Ctrl-C to copy it, Ctrl-V to paste into next post
  • On the other hand, if no devices are listed, tell me so
Generate and attach a DirectX report
  • Click Start, enter dxdiag in the search box
  • When DxDiag opens, look along the buttons at the bottom of the DxDiag window
    ===> If you’re running 64 bit Windows, you’ll see a 64-bit DxDiag button. Click it to run the 64-bit version of dxdiag
  • Notice progress in lower left window corner
  • When done, click Save Information button and save as a text file to your Desktop
  • Upload the file to your next post
My System SpecsSystem Spec
28 Aug 2015   #15

Windows 7 Ultimate SP1 x32

Sorry guys for late response I was busy. Unfortunately I dont't have the PC anymore. I've supposed to repair it and give it back to customer.

What I can tell you is that I tested it with KNOPPIX just to eliminate any Windows related issues and Network controller didn' work with Knoppix either. I decided to install new NIC and finish with it.

I've tried pretty much everything so I'm 99% sure that the NIC was dead. After replacing (installing new one) everything works as it should without problems.

Thanks for the help anyway :)
My System SpecsSystem Spec
28 Aug 2015   #16

windows 7 home 64bit

Yes the easy fix is some times the best way :)
My System SpecsSystem Spec

 ASRock N68C-GS FX Network controller driver

Thread Tools

Similar help and support threads
Thread Forum
ASROCK n68c-gsfx FX6300 overlock
HELLO to everyone! i tried to overclock FX6300 from 3.5Ghz to 4.0-4.4,but everytime i try to run Prime95 to stress,everything froze or WIn10 "BSOD" and restart,i only play around with multiplier,on this PC i have asrock n68c-gsfx(i know it's not very good for OC) i wrote everything i found on...
PC Custom Builds and Overclocking
Will an AMD FX-6300 work with an AsRock N68C-GS FX
Hi All, As the title says, will an AMD FX-6300 processor work with an ASRock > N68C-GS FX motherboard? I'm planning to upgrade my system due to FPS drops whilst playing DOTA 2. I've concluded that since the FPS drops happen after several minutes while playing and seem to have nothing to do...
Hardware & Devices
Missing some driver: SM Bus Controller, PCI Device, Network Controller
Hey I just recently switch my hard drive ( 320gb HDD 5400 rpm ) to a Samsung 840 EVO 250 Gb. I'm currently missing some files and I can't seem to find those drivers help? Btw it's a laptop here the model if you wanted to know : Asus X401A Network Controller ...
Restart issues with new motherboard Asrock N68C-S UCC
Hey guys, I am new to the forum, just signed up. To start things off I wanna ask if any of you have any experience with the Asrock N68C-S UCC motherboard or ever had to deal with a restart issue I'm facing with the Asrock N68C-S UCC. I just did a clean install after replacing my old ASUS...
Hardware & Devices
network controller driver accidently removed can't find driver
So the story goes like this I like updating drivers and i thought i found a new chipset. I was wrong I was uninstalling devices i didn't have. i restarted my computer and i couldn't get on the web network controller missing and unknown device which is under adapters. i have a m2n-e sli mobo with...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:11.
Twitter Facebook Google+