Revived my old DV7-7020us from Linux, can't get drivers to work  


  1. Posts : 2
    Windows 7 Professional 64 Bit
       #1

    Revived my old DV7-7020us from Linux, can't get drivers to work


    I have the above stated laptop, and have had it since it was new. I have a family of Macs, now, but I find it useful to still have a good Windows computer around, at least I do, now.

    The computer used to have Linux on it. I COMPLETELY wiped out Windows to do that. Now, this isn't the first time I've done that with this computer. I've gone back and forth on it, before. But, this time is different. I installed Windows 7 Pro, like I have done many times before, and went to HP's website to get the necessary drivers for the computer, just as I have done before.

    Only this time, it's not really TAKING the drivers. It's saying they aren't digitally signed. I (think) have tried to disable digital signing, but it still doesn't seem to take any driver I seem to NEED to install. (Wireless, for instance).

    Does anyone know what's going on?
      My Computer


  2. Posts : 2
    Windows 7 Professional 64 Bit
    Thread Starter
       #2

    Bump
      My Computer


  3. Posts : 7,115
    W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
       #3

    Drivers


    Hi Triple R,
    When you installed 7 Pro,
    There are loads of generic drivers within it.
    Suggest you select the individual device then go to update> select > browse my comp> UNCHECK show compatible devices and scroll down/across until you find the appopriate driver.

    Roy
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:18.
Find Us