Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Network Controller Driver–not Adapter Driver

14 Nov 2009   #1

Windows 7 Home Premium 64-bit
Network Controller Driver–not Adapter Driver

A few days ago I did a clean install of Windows 7. Now I have a problem. The computer is a wireless 'client'. It has a Realtek RTL8168D/8111D PCI-E Gigabit Ethernet NIC (NDIS 6.20).

When I bring up Device Manager and expand 'Network adapters' I see "Realtek PCIe GBE Family Controller".

When I expand 'Other devices' I see "! Network Controller" (Note the exclamation point.) Double click on that and I see "The driver for this device is not installed. (Code 28). When I click on Update driver I get a message Can't find a driver. I have tried many times with different source folders and files and nowhere is a driver found.

I have gone to MSIs driver web page and downloaded the Realtek PCI-E Ethernet Driver for Windows 7 32/64 bit "", extracted the files and still no joy. (M/B is MSI G41M with Intel E7400)

There is a wireless icon in the tray. I click 'Open network and sharing center". No matter what I choose Win7 ends up telling me to plug in an Ethernet cable. No, this is a client not the server. I have verified that the NIC can connect to the computer with the Ethernet cable by using the old XP hard disk.

Any suggestions?

My System SpecsSystem Spec
14 Nov 2009   #2

7600.20510 x86

Disable the onboard lan in the bios if you aren't using a wire to ever connect.
My System SpecsSystem Spec
15 Nov 2009   #3

Windows 7 Home Premium 64-bit

It turns out that Windows 7 or MSI tricked me.

After setup, Device Manager showed the Network adapter as being a Realtek PCI-e controller. This was not correct.

I decided to solve this problem by rounding up every related disk. Turns out I had a Rosewill disk. I put it in the DVD drive and ran Setup. It informed me that I in fact have a Ralink RT61 Turbo Wireless LAN card, not Realtek. When it completed setup, I was informed of several access points available to me, including my Home LAN.

Problem solved.

Now if I could just find out how to increase the width of my scollbars. (in XP, Control Panel, Display, Appearance tab, Advanced.).
My System SpecsSystem Spec


 Network Controller Driver–not Adapter Driver

Thread Tools

Similar help and support threads
Thread Forum
Missing some driver: SM Bus Controller, PCI Device, Network Controller
Hey I just recently switch my hard drive ( 320gb HDD 5400 rpm ) to a Samsung 840 EVO 250 Gb. I'm currently missing some files and I can't seem to find those drivers help? Btw it's a laptop here the model if you wanted to know : Asus X401A Network Controller ...
Can't find a network controller driver for my PC
Okay so about 2 weeks ago I had to reinstall my windows professional x64 and was able to get every driver to work but my network controller i am able to connect threw LAN but WLAN will not work. sorry for lack of explanation
Network & Sharing
Help installing a network controller driver
Hi all I have accidentally deleted some drivers from my computer and my internet no longer works. I've gone into Device Manager and into the ! device which was network controller and i clicked on properties --> details and i have the hardware ids PCI\VEN_168C&DEV_002B&SUBSYS_666111AD&REV_01...
Network Controller Driver Problem
Hi In device manager under other devices my network controller needs a driver but I can't find the correct one. Under the properties/hardware id I get: PCI\VEN_1814&DEV_0301&SUBSYS_25211814 I have done a google search and then it becomes complicated. PCI\VEN_1814&DEV_0301 hardware ID drivers,...
network controller driver accidently removed can't find driver
So the story goes like this I like updating drivers and i thought i found a new chipset. I was wrong I was uninstalling devices i didn't have. i restarted my computer and i couldn't get on the web network controller missing and unknown device which is under adapters. i have a m2n-e sli mobo with...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:20.
Twitter Facebook Google+