Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB controllers with a yellow exclamation mark after restart error 10

07 Jan 2016   #1
Serbaneski

Windows 7 Ultimate x64
 
 
USB controllers with a yellow exclamation mark after restart error 10

I have a problem with my usb ports for over a month. Only the ones in which the mouse and the keyboard work, for the rest I have to disable and enable the Intel(R) N10/ICH7 Family USB Universal Host Controller - 27C9, 27CA, 27CB, 27CC like in the picture below (before doing these steps). I have tried countless time to uninstall the driver and install it again for each port, and I also reinstalled my motherboard driver twice and I'm stuck with the same problem. I didn't have it before but I messed up my ports thanks to Oracle VM VirtualBox. I even tried that fix it thing from microsoft, and I still have the same problem. The only way to make the ports work is to disable and enable each of them, but I'd like them to stay enabled (So i wouldn't repeat these steps all over again after each restart). At Device status it says This device cannot start. (Code 10). My motherboard model is MSI g41m-p26. Thanks in advance for your help!



My System SpecsSystem Spec
.
08 Jan 2016   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Have you got a restore point prior to installation of Virtual Box.

Roy
My System SpecsSystem Spec
08 Jan 2016   #3
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

The drivers for those are on the motherboard cd, you have got to try again.

This time, Right click on each one and choose to update the driver and have it point to your motherboard cd, it should find the driver and install it.
My System SpecsSystem Spec
.

08 Jan 2016   #4
Serbaneski

Windows 7 Ultimate x64
 
 

I don't have any restore point before installing virtual box.

Tried to update from cd drivers but it says The best drivers for your device is already installed. After that I found a box that said delete driver files, and after that it installed Intel(R) 82801G (ICH7 Family) USB Universal Host Controller - 27C9, 27CA and so on, but I still get This device cannot start. (Code 10)error after restart and i have to disable and enable them again. Can it be fixed through task scheduler, Services or System Configuration?
My System SpecsSystem Spec
08 Jan 2016   #5
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Right click any one of the problem controllers->Properties->Details tab. Use the pull down menu and look carefully if Class Upper Filters or Class Lower Filters exist. If yes, select then copy/paste the information displayed about the filters


Attached Images
USB controllers with a yellow exclamation mark after restart error 10-filters.jpg 
My System SpecsSystem Spec
08 Jan 2016   #6
Serbaneski

Windows 7 Ultimate x64
 
 

It only has Class upper filters and the Value box is empty.
My System SpecsSystem Spec
08 Jan 2016   #7
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Create a system restore point.

Open an elevated command prompt enter regedit

Navigate to
Code:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}
If you're in the right spot you should see key Class with value USB (as in pic below). I'm guessing you'll also see another key named Upper Filters with a blank value? In any case, delete the Upper Filters key and restart your computer


Attached Thumbnails
USB controllers with a yellow exclamation mark after restart error 10-2016-01-08_172604.jpg  
My System SpecsSystem Spec
08 Jan 2016   #8
Serbaneski

Windows 7 Ultimate x64
 
 

Wow, it worked, problem solved. Thanks a lot!
My System SpecsSystem Spec
08 Jan 2016   #9
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

You're most welcome! Glad i was able to help :)
My System SpecsSystem Spec
08 Jan 2016   #10
Serbaneski

Windows 7 Ultimate x64
 
 

One more thing, I managed somehow to create another useless Removable Disk (the circled one), and anytime I add an USB device it shows another one. How can I get rid of the first one (without the Hide empty drives in the Computer folder from Folder option)?



Later edit: Solved by deleting from Disk Management.
My System SpecsSystem Spec
Reply

 USB controllers with a yellow exclamation mark after restart error 10




Thread Tools




Similar help and support threads
Thread Forum
Yellow triangular exclamation mark disappears when clicked
I'm having issues with my older computer - its always struggling. Frequently I see the triangular, yellow exclamation mark in the right side of the taskbar but when I click it to see what is wrong it vanishes displaying nothing. What can I do to find out what's wrong?
Performance & Maintenance
How can I get rid of the yellow exclamation mark against Com1
I've tried cleaning the registry, uninstalling and reinstalling the port then rebooting but it's still there. Looking around the net there appears to be software that claims to be able to fix it but none of it is from MS. So I'm scared to use it. Also tried the MS Mrfixit but it couldnt. Does...
Drivers
Yellow triangle with exclamation mark over network
Hello, First time posting here, but long time visitor. I have a bit of a problem with what i assume is a windows network issue. After I restart the pc, 9 times out of 10 i get a yellow triangle with an exclamation mark over my network icon. When i go over it, it says I'm connected to the...
Network & Sharing
Exclamation mark in yellow triangle
http://speccy.piriform.com/results/5OUPcYzXZDOcWOZsHOejYhH Gooday folks. I ran G Parted to check some thing about one of my hard drives and I noticed that the NTFS partition that has this windows7 installation on it has the above mentioned yellow triangle with exclamation mark in it. Could some...
General Discussion
Yellow triangle and exclamation mark.
The internet on my laptop has stopped working from time to time and a yellow triangle with an exclamation point goes on top of the internet icon on the bottom right. Now it has stopped working completely for about a week and hasnt come back like before. I use the same internet cord on my pc and...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App