Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Multiple USB Controllers

14 Apr 2016   #1

Windows 7 Pro x64
Multiple USB Controllers

- My computer's (*) startup got very slow.
- Windows Explorer is very slow. (sometimes "Not Responding)
- When I put it to sleep (or it when it goes to sleep from its own) I get the BSOD saying
- When I open the Device Manager I see ALOT of USB drivers (See pic)
my USB devices are : mouse, keyboard and 1 USB hub. An external eSata HD is connected to the eSata port of my Router, (Windows sees it as an USB drive and is working just fine

Can I just delete the doubles ? or what is the problem and how do I solve it ?

Thanks in advance !

Windows 7 Professional
Manufacturer Gigabyte Technology Co., Ltd.
Model GA-990FXA-UD3
Total amount of system memory 32,0 GB RAM
System type 64-bit operating system
Number of processor cores 8

Attached Thumbnails
Multiple USB Controllers-device-manager.jpg  
My System SpecsSystem Spec
14 Apr 2016   #2

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)

Those may be perfectly valid and you will find out if you uninstall one and then Scan for Hardware changes again--the driver will simply reinstall itself.

Is this a new problem with an existing PC, or a new build? If you've been merrily humming along to this point and just recently experienced these problems, maybe a System Restore is the easiest thing to try first.

You should consider to post instead in the BSOD subforum, which needs prerequisite scans.
My System SpecsSystem Spec
14 Apr 2016   #3

Windows 7 Pro x64

Thanks for your fast reply, Max7 !
This error happens on an existing PC. It worked for about 2 yrs without "major" problems. The problem started a couple of days ago after I manipulated large amounts of files (+20,000) several times from and to USB hub > Card reader. (PS : my mouse and keyboard are connected straight on the Mobo.) To speed things up, I used a program "Fastcopy", but this didn't speed up the copying and started to do weird stuff. So I uninstalled it with RevoUninstaller. Then I tried "Ultracopier". I think that this triggered the USB BUG CODE (not 100% sure...) So I also uninstalled it with Revo. But the USB BUG CODE did not stop.

I did a system restore to a previous point. Although the Restore operation changed a few things, it came up with the message that it could not restore. (???)

I was doubting where to post (BSOD or Drivers). But because I got a clear message that there's something wrong with the USB Drivers, I came here :).

Nevertheless, let me thank you again for your response. If you think that reposting in the BSOD section might give me more help, lemme know.

Tomorrow I'll try to uninstall the drivers one by one, and see what happens and let you know. I just hope that nothing happens with the drivers for my Netgear Router (R7500), because this Netgear is the worst router I ever encountered. It took 6 (SIX!!) months dealing with Netgear Support to get my eSata drive working properly and finally it works, but nobody seems to know why it works, and why it didn't work. For this reason I hope that you understand that I don't want to change anything in the router section because I'm affraid I'll have to go through the same hassle again...

Of course : any more info about this USB error will be a "feast" ... :)
My System SpecsSystem Spec

15 Apr 2016   #4

Windows 7 Pro x64

Well ... I think I found out what was wrong with my slow Windows Explorer.
I started the "What's Running" program, and there in the "Processes"-tab I saw that one of the sub processes of SearchIndexer was set to idle. After setting it to Normal, my explorer runs like a charm !...
I did not get the BSOD with the USB error anymore, because I couldn't get my computer to sleep, not automatic, not manual .... (Maybe some one knows a good lullaby ? :))
If some one has a sollution for this, please lemme know.
Thanks in advance !

PS : problem "half" solved ...
My System SpecsSystem Spec
15 Apr 2016   #5

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)

Quote   Quote: Originally Posted by PaulVdB View Post
I just hope that nothing happens with the drivers for my Netgear Router (R7500), because this Netgear is the worst router I ever encountered. It took 6 (SIX!!) months dealing with Netgear Support to get my eSata drive working properly and finally it works, but nobody seems to know why it works, and why it didn't work.
I have no idea what this is about i.e. I never heard of a router being installed as a Windows device!!!?!!!

In any case it seems completely unrelated to your issue, for which you might try first Uwe Sieber's DriveCleanup which you will find about halfway down this page:

Drive Tools for Windows

You open a cmd.exe as admin and first type drivecleanup -t to Test to see what it's gonna do, then do it again w/o the -t and it will clean.

If you do this, first make sure you use the 64-bit version of the executable if you have a x64 OS, and save a copy of your session (Select All then Enter which copies to Clipboard, then Paste into a text file). I have used this util for years and it has never caused me any problem.

In that web page paragraph is mentioned also DeviceCleanup which will ease your pain re: uninstalling any leftover drivers. But be careful with DeviceCleanup lest it clean-away the Netgear thing which again I think (hope) is not related to the USB error.

I suppose Fastcopy or Ultracopy is indeed the culprit, and if the above don't clear things up, I might suggest next Autoruns (SysinternalsSuite) then look for entries from either of those two companies/utilities and delete them.

Oh, I should add that you might also try a different System Restore point. Maybe it was only that one you tried that was corrupt in some way.
My System SpecsSystem Spec
15 Apr 2016   #6

Windows 7 Pro x64

Dear Max7,

Thank You again for your fast reply.
The router has an eSata port, so windows needs to know that there's an HD connected.
All my HD's seem to function normally now, but I wil (utmost carefully!) try the program that you mentionned and also will check out what's going on with the sleep function.
I'll post here when the insomnia problem is solved or not. :)

About the Restore point, I have another question : Is there a way to CHECK a restore point after it's made ? It's kinda silly that you make a restore point and weeks/months later (when you really NEED it) you have to find out that it is worthless ?
My System SpecsSystem Spec
15 Apr 2016   #7

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)

Another tool to explore the drivers that lurk in your system is Driver Store Explorer (RAPR).

FWIW I have a USB modem which, when plugged to my laptop, causes Sleep not to work. I can just unplug the modem and Sleep works ok, but I tell you only to confirm that yes a poorly written driver can cause Sleep problems.

I know of no way to verify SR points, and most here will tell you "Don't rely on them! They are flaky!" but I have had SR save my bacon numerous times. Ultimately though SR should not be relied upon IMO beyond a couple weeks. You should instead be making daily file backups and an Image backup of your entire computer on a weekly basis unless you never fiddle with programs or Windows at all.

But I have seen individual SR points fail to restore, and others work, so you might try another as I suggested...

P.S. Have you run a Disk Check? You should always do so after a BSOD/bad shutdown. Maybe a filesystem error from a bad shutdown has messedj-up your SR info. Worth a try, and if it finds/fixes errors then you might try the SR again.
My System SpecsSystem Spec
16 Apr 2016   #8

Windows 7 Pro x64

Again thanks again again, maxseven...:)
Haven't tried your last recommendations yet, but I found why my computer didn't want to go to sleep ! :)
Apparently my network card kept it awake... I checked the device manager, and saw that the network card was enabled to put the computer to sleep and to wake up. I assume that there's ALWAYS some traffic from and to the network ... so ...
Another part of the problem solved !!!
Now just the extremely slow startup... I don't want to try it now 'cause in 2 hrs I have to do my weekly radio show. OK, a startup doesn't take 2 hours, I guess the last time I booted up it took about 7 - 8 mins... Just suppose it doesn't want to start anymore. ...
Tomorrow I'll know more ...
My System SpecsSystem Spec

 Multiple USB Controllers

Thread Tools

Similar help and support threads
Thread Forum
Game Controllers
hey every one , please notice that I'm using Window7 RC 7100 , after clean installation and while connection my game controller i went to control panel but i couldn't find Game Controller Setting ? is it hidden if so how to make it visible and if not how can i get it , thanks A lot for the incoming...
SSD controllers
Now a simple query(s) from a simple me. I don't fully understand why the maker of an SSD does not make the controller chip. It seems a bit like sticking a Toyota steering system in a Ford car or am I missing something? I have Googled this query and have come up with some quite varying...
Hardware & Devices
Query fan controllers
I fitted a Lamptron FC5 V2 controller a couple of days ago partly because enhanced to the look of the machine and I have extra fans fitted that are not needed to run at full tilt just yet. Now for the dumb query just what motherboard items does one attach the sensors to and how. My obvious...
Hardware & Devices
Xbox 360 Controllers
I don't own a Xbox 360 or have used the controllers with a PC, my question is will any Xbox 360 controller work with windows or does it have to be a specific one?
IDE ATA/Atapi Controllers
Something that has bugged me long enough that I will now as the it normal to have 3 instances of 3 different controllers in the Device Manager? This doesn't include the controllers listed under Storage Controllers.
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:38.
Twitter Facebook Google+