Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: eMachines E525 no sound in 64bit version of 7

17 Nov 2009   #1
samspin

Windows 7 64-bit
 
 
eMachines E525 no sound in 64bit version of 7

This laptop (eMachines E525) came pre-installed with Vista Basic, and I wiped it and put 7 32-bit on, with no problems. After a month I decided to try 64-bit and found that the sound no longer works. Microsoft's default driver was "High Definition Audio Device" . I have tried the manufacturers download site for this laptop, and I wound up with a Realtek HD Audio Device driver, and it was listed as for Windows 7 x64 Professional, so I definately have the right driver. I installed the driver, restarted, and tried playing music. Still no sound. I even tried plugging headphones in. Nothing. On going to Control Panel and looking at the "Realtek HD Audio Manager" it seems to recognize when I plug the headphones in and take them out, but still no sound! I don't know what's wrong here! I do have a set of USB speakers and those of course work as they are a different Audio Device, but that isn't a long term solution as I need to take the laptop around alot and only have 2 USB ports! Anyone have any ideas? I'd rather not have to rewipe again and go back to 32 bit Windows...


My System SpecsSystem Spec
.
17 Nov 2009   #2
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Type audio into your start/search field and go to the Realtech HD Audio Manager. Check whether any of the settings are odd.
My System SpecsSystem Spec
17 Nov 2009   #3
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by samspin View Post
This laptop (eMachines E525) came pre-installed with Vista Basic, and I wiped it and put 7 32-bit on, with no problems. After a month I decided to try 64-bit and found that the sound no longer works. Microsoft's default driver was "High Definition Audio Device" . I have tried the manufacturers download site for this laptop, and I wound up with a Realtek HD Audio Device driver, and it was listed as for Windows 7 x64 Professional, so I definately have the right driver. I installed the driver, restarted, and tried playing music. Still no sound. I even tried plugging headphones in. Nothing. On going to Control Panel and looking at the "Realtek HD Audio Manager" it seems to recognize when I plug the headphones in and take them out, but still no sound! I don't know what's wrong here! I do have a set of USB speakers and those of course work as they are a different Audio Device, but that isn't a long term solution as I need to take the laptop around alot and only have 2 USB ports! Anyone have any ideas? I'd rather not have to rewipe again and go back to 32 bit Windows...
Hi and welcome SAm

Can we check out device manager to mkae sure it is instalaled and working correctly. (type device manager in search) Go to the sound tab and look for the device. Make sure its present and does not have a yellow triangle on it. Also look for any "unknown devices" with yellow on them.

Also while in device manager>sound>your device>right click>properties>details>hardware ids. Use the pull down to get these strings. Drop those strings in googe and it will ID the exact device

Hope this helps

Ken J+
My System SpecsSystem Spec
.

18 Nov 2009   #4
Weje

Windows 7 64 DK
 
 
Update??

Hi.

I have the exact same issue on a eMachines G525.

Vista Home Premium preinstalled works fine.

Windows 7 64bit - No sound. All devices seems to be fine. have the RealTek Audio, can even see the Soundbar moving when testing, but no sound in speakers, or headphone.

Did you resolve the issue?

Kind regards,

Brian A. Weje
MCT
My System SpecsSystem Spec
31 Dec 2009   #5
ms77

Windows 7
 
 

I also had this problem and solved it by upgrading the BIOS to the latest version.
http://global-download.acer.com/GDFi...hines&SC=PA_6E

// Martin
My System SpecsSystem Spec
08 Apr 2011   #6
calimaa

Windows 7 64-Bit
 
 

Comfirm that a BIOS upgrade works!

Thank you very much!!
My System SpecsSystem Spec
22 Dec 2012   #7
Fusseldieb

Windows 7 Home Premium x64
 
 
Thanks very much!!!

Hello comunity, this is my first post here.
Sorry for my bad english... I'm german :)
-------------------------------

After upgrading the BIOS of my eMachines G725, the sound finally works.
Thanks very much, ms77!!!
My System SpecsSystem Spec
18 Jun 2016   #8
torquin

Pyrénées-Orientales
 
 

Cheers, have had this problem for ages :) Didn't even know that a bios could be updated via a windows exe !
My System SpecsSystem Spec
12 Apr 2018   #9
lordrobo1

Windows 8
 
 

Thanks this helped too, for an emachines E525 windows 8.1.
My System SpecsSystem Spec
Reply

 eMachines E525 no sound in 64bit version of 7




Thread Tools




Similar help and support threads
Thread Forum
Upgrading OEM version from 32 to 64bit
Hi I would like to make a clean install of win7. Using the 32bit version(I have the cd), doesn´t make sense anymore to me so I need the 64bit iso, but how do I get it?? Microsoft stopped this download service for consumers and Dell, from where I bought the computer&OS, has also nothing to do with...
Installation & Setup
Emachines E525 Webcam driver won't work in windows 8 ??
Hi My Emachines E525 Laptop came with win 7 but i changed it to win 8 pro and it has a built in Camera and i wanted to use it to Recode video Please note: i am trying to recode a video using my laptop camera so i will save the video in my hard drive so first issue the driver...
Drivers
cannot install 64bit version
hi I installed win7 from a dvd that had both 32/64 bit versions.. By mistake i installed 32bit version and the day after i notice the mistake. On the same computer I used my other drive that is an Agility 3 SSD disk and install the win7. ( I removed the first drive so only only one disk on the...
Installation & Setup
Wireless Problem (acer eMachines e525)
Hello Everybody, I've uninstalled windows vista on my emachines e525 laptop and installed windows 7. I used to acces internet via wireless before uninstalling windows, but now as I installed windows 7, I can't find a compitable driver. Despite the fact that I tried almost all available wireless...
Network & Sharing
32 or 64bit - What Version will you be installing
It's nearly here, so what version will you be loading and why.
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:04.
Twitter Facebook Google+