Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: xHCI root hub

16 Jun 2016   #1

Windows 7 Professional 64bit
xHCI root hub

I purchased this small card to add 4 USB 3.0 to my system and it came with an useless CD (no driver). It figures on my device manager as "xHCI root hub 0".

After to browse online I only found a bunch of crap sites with no driver at all and that instead are sponsor traps that keep bouncing you around a lot of useless pages.

Does anyone know of a reliable source from where I can download it?

I am running Windows 7 Pro 64.

My System SpecsSystem Spec
16 Jun 2016   #2

Windows 7 Professional 64bit

Never mind. After a third attempt it worked (although it said it didn't). Stupid Windows.

My System SpecsSystem Spec

Thread Tools

Similar help and support threads
Thread Forum
What is ASMedia XHCI 1.0 Controller?
and how did it get into my PC and should I banish it? Many thanks.
Hardware & Devices
USB port not working Intel USB3 xhci Driver for Intel® 8/9 Series
Hi, Just wondering if anyone has been having the same issue. Windows 7 x64 series 8 motherboard. ASUS z87-expert. My USB3 and USB2 are not working right after I install the Intel USB3 xhci Driver for Intel® 8/9 Series version I have used the setup.exe to install the driver...
Intel USB 3.0 root hub and USB root hub registries missing/incomplete?
Ok, so I've run into a very tricky spot: Yesterday, I successfully resolved a windows update issue (thread can be found here: ). Basically, one problem led to another and I ended up...
USB Root Hub Issues in RTM
Hi there I've been running various Windows 7 Betas and RCs on virtual machines and spare PCs for a while with no issues, so when I got access to the RTM I was quite confident (probably overly so) to upgrade my laptop from Vista. Right after the install (ironically enough, from a USB),...
root directories
I need to edit the .ini file in a program I've loaded but Windows 7 does not show the root directory. I've used the Command Prompt to access the program file and the root file is not displayed. I've tried to search for the .ini file but the system says it can't find it. Can anyone help?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:08.
Twitter Facebook