Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: HDs connected via eSATA not detected; Storage Controllers absent

11 Aug 2016   #1

Windows 7 Home Premium 64-bit
HDs connected via eSATA not detected; Storage Controllers absent

Hi. This is a longish one. I will try to be as informative and clear as possible.

Brief summary of problem: Hard drives connected externally via eSATA are not "seen" by Windows. There are no storage controllers in the device manager. This is the result of trying to install a hard disk controller that would allow monitoring of HDs connected by eSATA.

Long version:

I have been using software to monitor HD performance, temperature, errors, etc. This has worked for USB connected drives. I use Vantec Nexstar 3 enclosures and a Thermaltake BlacX Duet dock. These are standard WD Black and Blue drives, and Seagate Barracudas.

However, recently I started using eSATA connections with my external drives, and noticed that the software could not monitor them (no temp, SMART data, etc.). I contacted the developer for assistance.

He informed me that the controller Marvell 61xx was the issue. The current version does not provide HD status information. He directed me to replace it with a driver that I could download from his site. I attempted to install the driver via the Device Manager. I located the Storage Controllers section, found the Marvell 61xx controller, and tried to update by browsing to the proper driver file. This did not work: a dialog box told me that the best driver software for my device was already installed and up-to-date.

At this point he told me the alternate method would be to go to the Storage Controllers section, choose update, browse, and then "let me pick from a list of device drivers", and then choose the "standard dual channel PCI controller" driver, which is a generic Windows driver. The idea here, I believe, was that this would allow the software to monitor the drive, and also might be a workaround to eventually get the desired "better" driver installed.

After doing this and rebooting, the drive was detected and also recognized by the monitoring software. However it reported the drive as having 100% performance and 0% health, because the threshold value for Reallocated Sectors was reported incorrectly as 207, with the current value being 200. I reinstalled the monitor, and it seemed to report the disk as 100% for both, but with some odd threshold values.

I then ejected the drive (via the Windows Safely Remove utility on taskbar), and reconnected. The PC no longer saw the drive through eSATA, but did when I connected via USB. I rebooted again, and the computer did not detect any drives connected by eSATA. This continues to be the case.

I looked in the Device Manager, and realized that there is no longer a section for Storage Controllers. This continues to be so, even after hard and soft reboots and even in Safe Mode.

I have also tried scanning for hardware changes -- no dice, and just straight installing the driver that the developer suggested in the first place. All that did was make a folder called "Marvell" in the Program Files (x86) folder, and I have no idea what to do with that.

I have not tried any System Repair nor System Restore, mainly because neither of them have ever worked for me. I do have Restore Points from earlier this week.

At this point, all I want is for my computer to be able to detect and use drives connected via eSATA. I don't really care if they can be monitored or not (though if there were a way to make that happen, that would be nice).

Any ideas or guidance would be greatly appreciated.


My System SpecsSystem Spec
11 Aug 2016   #2

Windows 10 Pro x64, Windows 8.1 Pro x64, Windows 7 Ultimate x64 SP1,

I would perform a system restore to a time before you replaced the driver.
My System SpecsSystem Spec
11 Aug 2016   #3

Win 10 Pro

I frequently find HDs connected via eSATA fail to auto-mount properly get a drive letter assigned and appear absent. When I load up the Disk Management tool within Computer Management I can see the drive without a drive letter. After assigning a drive letter the drive then appears properly with its correct drive label.

Some have suggested commands that will enable/repair auto-mounting of hard disks but I still see the problem popping up and simply assign a drive letter in Disk Management when it occurs.

This might or might not be relevant to the problem you're experiencing. But ya never know ....
My System SpecsSystem Spec

11 Aug 2016   #4

Windows 7 pro 64-bit sp 1

rpmtl how is the drive suppose to be mounted without a drive letter if the OP doesn't have drivers? I suggest that you download the chipset drivers for your computer from the manufacturer's website.
My System SpecsSystem Spec
12 Aug 2016   #5

Win 10 Pro

Perhaps the controller is there but hidden as it's no longer recognized a device to control?

Here are the instructions I keep on hand to display hidden devices in the Device Manager:

At a command prompt, type the following command , and then press ENTER:
set devmgr_show_nonpresent_devices=1

Type the following command a command prompt, and then press ENTER:
start devmgmt.msc

When the device Manager loads you can choose View -> Hidden Devices

If the controller then appears you could then choose to uninstall it (perhaps even remove the driver if that option is offered) or use the Update Driver option and install the appropriate Marvell 61xx driver for your system.

Just a thought ....
My System SpecsSystem Spec
13 Aug 2016   #6

Windows 7 Home Premium 64-bit

Hi, everyone

Thanks for the replies. Sorry I did not respond earlier, but having static IRL.

I was able to determine which one of my standard dual channel PCI controllers was the one I had changed to from the Marvell driver. I did an update and pointed it to an inf file in the drivers supplied by the developer. This successfully installed the older Marvell 61xx driver, the one that is supposed to enable SMART reading via eSATA.

Once I rebooted, the Storage Controllers reappeared in the Device Manager. I connected an HD via eSATA, it was detected, and I did get SMART and temp data.

However, any subsequent attempts to connect any drive through eSATA does not work. Windows does not see the drive, even after scanning for new hardware, and connecting seems to freeze up my system for several seconds.

I guess at this point, I will try to use the Update Driver option (as suggested by RPmtl). I don't know if I should let Windows search for the correct driver, or to download the one from the ASUS page for my motherboard. Which course of action is better?

If this fails, I will follow pbcopter's advice and try System Restore next.

I will update the thread probably tomorrow, once I have attempted the above. In the meantime, if anyone has any new ideas, I am eager and grateful to hear them.

My System SpecsSystem Spec
14 Aug 2016   #7

Win 10 Pro

Quote   Quote: Originally Posted by yanagawa View Post
I don't know if I should let Windows search for the correct driver, or to download the one from the ASUS page for my motherboard. Which course of action is better?
I would install the ASUS driver rather than let Windows install something generic. If, after the ASUS driver is installed, Windows suggests that there's a recommended update then I'd probably let it do that.

Good luck in setting things right!
My System SpecsSystem Spec
14 Aug 2016   #8

Windows 7 pro 64-bit sp 1

I don't use drivers suggested by Windows update.
My System SpecsSystem Spec
20 Aug 2016   #9

Windows 7 Home Premium 64-bit

Hi, everyone. Well, I installed the driver from ASUS, but the behaviour continued. So then I did a System Restore to a date several days before the first driver change, and now the drives are being detected by Windows.

However, I have been using my Thermaltake X Duet dock to transfer files between HDs. I have two drives in the dock, and transfers go fine, but twice I have come back from leaving them idle and found my system frozen, and I have to push the reset button on the desktop to get things moving again.

So I guess the original problem is fixed!

Thanks to pbcopter, PRmtl, and townsbg for your kind assistance.
My System SpecsSystem Spec

 HDs connected via eSATA not detected; Storage Controllers absent

Thread Tools

Similar help and support threads
Thread Forum
eSATA drive not detected--can CrystalDiskInfo damage an eSATA drive
I plugged in my eSATA drive while CrystalDiskInfo was running and the computer froze. There was no way to regain control of the computer so I restarted. So now this eSATA drive is not recognized by the computer. The eSATA drive works in another computer. What's really weird is that...
BSOD Help and Support
Vaio VGN-FS940 Mass storage, Video, Network Controllers Problems.
Okay, this is my first time posting anything on the internet so just bear with me :/. Anyway I recently installed Windows 7 on it and I need 3 drivers. Mass storage, Video, and Network Controllers. My laptop is a Vaio VGN-FS940. My specs are a 512 RAM, a 1.73 Ghz Intel Processor and a 100 gb...
Marvel not showing up in device man- storage controllers?
thanks for the help. I tried to delete this thread the site will not let me.
Hardware & Devices
Storage Controllers Problem
Hi All, I have a laptop toshiba portege m900-s337 PSU9RL-003002 32-bit running on Windows 7 Home Premium. My laptop crash often and long time without responding. Lately, when I checked the "Device Manager", I have a Storage controllers "AL7GLB3W IDE Controller & ATXPNG3V IDE Controller". This...
Compatability report re storage Controllers when updating
Hi im trying to upgrade my windows 7 but but get this message how can i fix it? Thanks in advance and if you want more info pls ask :) Windows needs to be restarted so necessary changes to system files can be made before continuing. Upgrading Windows will affect the following devices and/or...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:08.
Twitter Facebook