Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Ports Stop Working After USB Controller Install

23 Oct 2016   #1

Windows 7 Professional x64
USB Ports Stop Working After USB Controller Install

I have a custom built computer running Windows 7 Pro x64. The keyboard and mouse work currently, but nothing else works when plugged into the USB (have 3.1, 3.0, and 2.0) ports. Seems like a simple driver issue.

There are two different usb host controllers from what everything tells me. One is the ASMedia 3.1 controller, and the other is the Intel 3.0 controller. When I install the ASMedia one, it installs successfully, but the ports still don't recognize anything (these ones are two in the back). When I install the Intel one, all of the ports stop working and the mouse and keyboard also stop, with their lights turning off. Only way to do anything on the computer then is reboot, system repair tools, and then do a system restore to before the drivers were installed. I tried drivers from MSI's page for the motherboard (Z170a PC MATE), through Iobit's Driver Booster, and through Intel's driver program. The Intel program completely fails to install the driver at all.

Relevant specs:
I5 6600k CPU
MSI Z170a PC MATE motherboard

Troubleshooting steps (I've spent two entire days working on the computer, so I don't remember most of it)
BIOS update to the 10/18 version.
Updated all of the other drivers through Driver Booster (Windows Update never works for me in Windows 7 for whatever reason. Tried on at least a half a dozen computers. Never stops searching)
Countless device manager uninstalls and reinstalls. System restored to a point before all of that now.
Driver lookup through hardware ID (showed what I've already been trying to get)
Disabled driver signature enforcement
Safe mode (keyboard and mouse work before driver as usual. If driver is installed, they do not work in safe mode either).
Different USB peripherals.
May have done others.

Relevant info:
MSI motherboard page: Support For Z170A PC MATE | MSI USA | Motherboard - The world leader in motherboard design
(the page has the USB drivers. The Driver Booster ones were the same ones I believe)
Computer has an SD card slot. Haven't tried because I don't have a normal size SD card, and getting the USB drives working is important.
Computer does have PS/2 ports, but I don't have peripherals with that plug.
Computer worked perfectly in Windows 10, so that's always a fallback option.
Windows Update doesn't work. I've tried fixing that many times on other computers. Windows 10 Update version works fine every time I tried (also on multiple computers). I gave up on fixing that long ago.

Anything else I can provide, let me know! If there's a relevant spec that I deemed irrelevant, Perhaps it's on the profile page as I filled that out pretty much all of the way.

My System SpecsSystem Spec
23 Oct 2016   #2

Windows 10 64 bit

Have you reinstalled the Intel motherboard chipset drivers? One of the things the chipset drivers do is define (identify) all the devices on the motherboard.

I don't like the 3rd party driver sites. Many times they either have wrong drivers or show that drivers are needed and they are not. MSI (in your case) has everything needed (and correct drivers).

Install the chipset drivers, reboot and see if you can get the USB ports going.

Support For Z170A PC MATE | MSI Global | Motherboard - The world leader in motherboard design 64
My System SpecsSystem Spec
23 Oct 2016   #3

Windows 7 Professional x64

Yes. This is what I did:

Windows Update started working for whatever reason, so I downloaded ~2gb of updates over time and installed them with seemingly no problems.

I then downloaded the Chipset and Management Engine (couldn't install because of lack of a Windows Update file) drivers freshly, and ran the chipset driver. The first time, it completely froze the computer to where I had to hard reset it. However, when it booted back up, it started again and successfully installed it. I then installed the management engine driver with no issues. I rebooted after each for good measure.

I then downloaded the two USB drivers from the motherboard site again. The ASMedia one installed with zero issues, as normal, but doesn't really change anything. I installed the Intel driver successfully, but it killed the ports yet again. I restarted the computer, and again the mouse and keyboard lasted until the "starting Windows" screen before both turning off and not turning on. I did the typical "try other ports, try other devices" shlick, with no reaction from the devices or computer. I then turned it off, and system restored it again to the last restore point.

Also, the mouse scroll wheel hasn't worked this entire time I've been dealing with this. I figure that'll be fixed when the rest is, but I keep trying to use it.
My System SpecsSystem Spec

23 Oct 2016   #4

Windows 7 Professional x64

Finally got it. Woo!

So, basically, the driver installations for the Intel USB stopped working completely, with an error message like "one or more device drivers failed to install."

So then I manually installed the driver for the controller. The USB ports would then die (before, same thing would happen with the installs).

This time, however, I installed teamviewer to see exactly what was going on. What would happen is that another unknown device would take the place of the controller when I installed it. It would install the controller, but not the damn hub. So, I manually installed the driver for that through teamviewer, pointed to the exact same location as they were bunched together, and it installed the hub and then subsequently and automatically installed the drivers for everything else.

Got the teamviewer idea from a thread that was solved earlier today. Didn't think to use it to use the computer after the USB port fatalities. Would have been done so much sooner if I had or had a damn PS/2 mouse or keyboard.

Well, now I know!
My System SpecsSystem Spec

 USB Ports Stop Working After USB Controller Install

Thread Tools

Similar help and support threads
Thread Forum
USB ports not working on clean install of windows 7. How to fix?
asus rog g751jy-vs71(wx) "one drive, dual boot" windows 10 Home Premium 64bit, and 7 Pro 64bit In W7, When Booting the USB works fine and I have a mouse, but when it gets to the login screen the keyboard and mouse just go black and do not function at all in W7. W10 works fine all the time. I...
Hardware & Devices
USB 3.0 Ports stop working after installing Intel Driver
Hi, I have Windows 7 Home Premium, and whenever I install the Intel USB 3.0 eXtensible Host Controller, my USB 3.0 ports cease to function. I want to have them installed because my OCD tells me, because of the "Unknown Device" in device manager that I'm fairly certain goes away after installing it....
USB ports (3.0) no longer working after Windows 7 Re-Install.
Before I begin sorry if this is in the wrong part of the forum, please direct me if this is the case or there is a similar thread. I have been looking online and although people have had similar situations I feel a tailored answer would be ideal if possible. I purchased an Asus N56VM laptop...
Hardware & Devices
USB ports/devices stop Working when Windows 7 Boots
I have a HP Pavilion P6204Y Special Edition running Windows 7 Home Premium x64 that has been having issues with the USB ports for the last few weeks. I am using a USB keyboard and mouse, which both power up/light up as soon as the computer is turned on. They work fine when I enter the BIOS, but...
Hardware & Devices
USB ports stop working w/ too many devices
My setup: Acer Aspire with Windows 7 Ultimate w/ the latest Windows updates 4gb of Ram Intel Core 2 Duo Processor Don't think that much more is relevant. I use a usb wireless device on my computer and if only it and my keyboard are plugged into the usb ports it seems to work fine.
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:52.
Twitter Facebook Google+