Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Nvidia GeForce 8500 GT And WoW problem!!! plz help!!!

19 Nov 2009   #1
Blblr

WINDOWS 8.1 x64
 
 
Nvidia GeForce 8500 GT And WoW problem!!! plz help!!!

Yesterday i was playing World of Warcraft and the screen started flashing then turned black. I could hear the sound playing but no video and keyboard, i had to restart my pc. WTF? ok after restarting and booting widows 7 logo the screen turned off again, i couldn't do log in to my pc. I went to safe mode and uninstalled Nvidia drivers then started windows normally and there was no black screen and i could log in to my pc.
But i couldn't play World of Warcraft because i had no drivers installed F*CK!! I tryed updating my drivers but it kept doing the same, nothing helped. Its drivers problem!!
I was playing WoW for few weeks with windows 7 and everything was perfect not a single error, but now from no where appeared drivers problem ? O_o wtf ? can someone help me plz

I have Nvidia GeForce 8500 GT
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+ 2.70 GHz
4gb ram
32 bit operating system
I have windows 7 Professional RTM(7600) installed

Plz help

P.S. sorry for my bad english and im newbie first time posting in forum


My System SpecsSystem Spec
.
19 Nov 2009   #2
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

Please watch your language alright? No need for it. I can understand your frustration. First off what driver are you using? I'm also curious as to where you obtained your Win 7 Pro RTM ISO from? Thanks
My System SpecsSystem Spec
19 Nov 2009   #3
Blblr

WINDOWS 8.1 x64
 
 

Ok, im sorry for my language, but i don't know what do you mean what driver i have ? i downloaded the latest driver update from nvidia
GeForce/ION Release 191
Version: 191.07 WHQL


I tried downloading older drivers but that didn't help... Does it matter
from where i got Win 7 rtm ? i don't think it really matters.
My System SpecsSystem Spec
.

19 Nov 2009   #4
Blblr

WINDOWS 8.1 x64
 
 

So no one gonna help me ?
My System SpecsSystem Spec
19 Nov 2009   #5
torrentg

7600.20510 x86
 
 

Try running a room fan blowing inside the open computer case, to test, while playing a game.

Your problems could be caused by a heat issue.

As for what Thefabe is saying - if you downloaded Windows 7 from a torrent or anywhere else besides Microsoft's servers, you might have a malware or root issue.
My System SpecsSystem Spec
19 Nov 2009   #6
Blblr

WINDOWS 8.1 x64
 
 

Okay i'll try to do that, but i got another problem... i updated my driver from device manager and i got an error
"[IMG]file:///C:/Users/Dest/AppData/Local/Temp/moz-screenshot.png[/IMG][IMG]file:///C:/Users/Dest/AppData/Local/Temp/moz-screenshot-1.png[/IMG]Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)"

Nvidia GeForce 8500 GT And WoW problem!!! plz help!!!-error1.png

Nvidia GeForce 8500 GT And WoW problem!!! plz help!!!-error2.png

Help ? O_o


My System SpecsSystem Spec
19 Nov 2009   #7
Blblr

WINDOWS 8.1 x64
 
 

Ok, nevermind that i fixed the driver and its kinda working, i restarted my windows and after booting windows logo it turned black just like always, i had to go to safe mode to disable the driver to start windows normally. So whats wrong with the drivers ? =\ can anyone help me ?
My System SpecsSystem Spec
19 Nov 2009   #8
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by Blblr View Post
Ok, nevermind that i fixed the driver and its kinda working, i restarted my windows and after booting windows logo it turned black just like always, i had to go to safe mode to disable the driver to start windows normally. So whats wrong with the drivers ? =\ can anyone help me ?
Completely uninstall the driver from Device Manager -> Restart the computer -> Reinstall the driver

Also re download this one

NVIDIA DRIVERS 191.07 WHQL
My System SpecsSystem Spec
20 Nov 2009   #9
Blblr

WINDOWS 8.1 x64
 
 
O_o

That didn't help and now i installed winodws vista ultimate and its the same as with win7!(i never had this problem with vista before)

I'll need to buy a new video card or something ?
My System SpecsSystem Spec
20 Nov 2009   #10
Deca

Windows 7 Ultimate 64bit
 
 

Make sure you're fully uninstalling the drivers and everything that goes with the installation. Then reboot and re-install. Also try the beta drivers, I'm not promising they'll work but I'm running beta drivers at the moment and I had the same issue as you and it's working fine for me.

NVIDIA DRIVERS 195.55
My System SpecsSystem Spec
Reply

 Nvidia GeForce 8500 GT And WoW problem!!! plz help!!!




Thread Tools




Similar help and support threads
Thread Forum
nvidia geforce 8500 gt connect to tv win 7
okay so i have the above mentioned video card and vindows 7. i have the tv connected to my computer using the s-video 2 slot on the computer. but i cant figure out how to configure the computer to use tv display >.< i am very new to win 7:o can someone help me out?
Graphic Cards
Can't install drivers for nVidia GeForce 8500 GT
First, I apologize for the double-post. There is a duplicate thread in the "Graphics Cards" forum.. I have Windows 7 32bit installed on an ASUS P5RD1-VM mobo with an nVidia Geforce 8500 GT graphics card. I have tried numerous times to install the Windows 7 (32bit) Driver from manufacture...
Drivers
nVidia GeForce 8500 GT Dual Screen ?
Hi, I recently got a projector from a friend and im trying to setup dual screen. First of all im a bit confused by the Graphics Card itself. I looked for pictures of the card which my computer recognizes as a nVidia GeForce 8500 GT and none have a HDMI port but mine does. So i opened the case...
Graphic Cards
GeForce 8500 gt blank screen after windows 7 logo
I disabled the nforce on board drivers and installed the pny ones I have on cd still get blank screen
Graphic Cards
nVidia GeForce 8500 GT, drivers won't install
I have Windows 7 32bit installed on an ASUS P5RD1-VM mobo with an nVidia Geforce 8500 GT graphics card. I have tried numerous times to install the Windows 7 (32bit) Driver from manufacture site, but when it tries to install the drivers, I get an error message saying "No drivers were found that...
Graphic Cards
Nvidia GeForce 8600 M GT PROBLEM!
Hi guys, i installed Windows 7 few days ago on my notebook, ACER ASPIRE 5920 G Specs: Intel Core 2 Duo processor 2.0 Ghz 2 gb DDR2 Nvidia GeForce 8600 M GT 512 mgb (up to 1028 mgb) At first, I installed old drivers for Nvidia, they were working OK but they are for Vista, and I noticed in...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App