Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Driver issue USB Mass Storage Device

20 Feb 2017   #1
April Raine

win 7 home premium 64 bit
 
 
Driver issue USB Mass Storage Device

Win 7 64 bit Usb mass storage device says no drivers are installed. But there are drivers installed and they are up to date. A reboot helps but only for short time then the yellow exclamanation mark is back see screen record UsbMassStorage - vidme

I have USBSTOR.SYS at C:\Windows\System32\drivers\USBSTOR.SYS 89.5kb dated 9 3 2016

I followed
How to Repair Corrupt USB Mass Storage or CD/DVD Drivers - TechSpot Forums

If one or more of these files are missing

" Navigate to C:\Windows\System32\DriverStore\FileRepository
Scroll down. Find the folder name that starts with usbstor.inf_
You may see more then one folder with name starting usbstor.inf_. IF YOU DO: you want the folder with the most recent date
Open the folder. There's a copy of the 3 files you need. Copy each one to its correct location as shown above
Jump to the instructions below to delete the INFCACHE.1 file"

Copied UsbStorSys and pasted it to C:\Windows\System32\drivers overwriting the one that was there. Not sure if it work as i got 'you need permission' but it went ahead eventually

But I still have the exclamation mark inDevice Manager/UsB Mass Storage Devixce and camera or other USB will not be detected until i reboot and soon after the error returns. I also get messasges that a unknown USB has malfunctioned or similar wording


My System SpecsSystem Spec
.
20 Feb 2017   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello April now can you do this please
Now before we can help we do need to know what is in your machine so please do this System Info - See Your System Specs
or either enter the specs of your system in your forum profile the specs will appear when we click on that little box bottom left of the post screen it is for me the preferable option as it is easy. As you may appreciate it is very hard when you don’t know what one is working with for example a diesel or petrol engine.
*(pretyped to save time)

As you were asked for permission I am assuming you are logged in as the admin? Plus I am again assuming you have done a sfc and chkdsk if not worth a try in safe mode.
SFC /SCANNOW Command - System File Checker
Disk Check < if necessary include the /f switch and if this does not make any improvement then just run this switch instead /r in the command line as per Option2
Run these in safe mode and the sfc often best run for two to three runs – you can leave out the /r switch in ckdsk if you feel it not necessary

I also have to ask how old is this machine and if it is one you have had for a while what have you added or installed since those storage devices last worked?
My System SpecsSystem Spec
28 Feb 2017   #3
ComputerGeek

Desk 1: Win 7 Pro x32; Desk 2: Windows 10 x64
 
 

Per instructions in referenced post, did you check for usbstor.inf in C:\Windows\inf ? All cases like this i've seen to date turned out the usbstor.INF file that has gone missing
My System SpecsSystem Spec
.

02 Mar 2017   #4
rickchristine

Windows 7 Ultimate (64 bit)
 
 

Did not you try to uninstall the driver and use another free software to help you scan your computer, maybe it will help you. Because not every time, the Microsoft will recommend you the latest or the right driver for you. And obviously, it is the problem of usb mass storage device driver. So try to use another way to get drivers first. Wish it can help you.
My System SpecsSystem Spec
02 Mar 2017   #5
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

I agree but I would rather know what that machine has in it so we can link the manufacturers site and it has now been a week since I first answered the posted thread.
So until we hear back there is not much we can do
My System SpecsSystem Spec
23 Mar 2017   #6
April Raine

win 7 home premium 64 bit
 
 

Quote   Quote: Originally Posted by ComputerGeek View Post
Per instructions in referenced post, did you check for usbstor.inf in C:\Windows\inf ? All cases like this i've seen to date turned out the usbstor.INF file that has gone missing
Yes i did check and I have the usbstor.inf in C:\Windows\inf
My System SpecsSystem Spec
23 Mar 2017   #7
April Raine

win 7 home premium 64 bit
 
 

Quote   Quote: Originally Posted by ICIT2LOL View Post
Hello April now can you do this please
Now before we can help we do need to know what is in your machine so please do this System Info - See Your System Specs
or either enter the specs of your system in your forum profile the specs will appear when we click on that little box bottom left of the post screen it is for me the preferable option as it is easy. As you may appreciate it is very hard when you don’t know what one is working with for example a diesel or petrol engine.
*(pretyped to save time)

As you were asked for permission I am assuming you are logged in as the admin? Plus I am again assuming you have done a sfc and chkdsk if not worth a try in safe mode.
SFC /SCANNOW Command - System File Checker
Disk Check < if necessary include the /f switch and if this does not make any improvement then just run this switch instead /r in the command line as per Option2
Run these in safe mode and the sfc often best run for two to three runs – you can leave out the /r switch in ckdsk if you feel it not necessary

I also have to ask how old is this machine and if it is one you have had for a while what have you added or installed since those storage devices last worked?
MEDION(R) AKOYA(R) E4355 D (MD 8341) I hasve it 6 years. Not sure when the work properly. Did sfc scannow and disk check
My System SpecsSystem Spec
23 Mar 2017   #8
April Raine

win 7 home premium 64 bit
 
 

The problem is a bit different now I have an unknown usb device in my device manager which has been stopped because it cause problem. I uninstalled and then scanned for hardware changed but the drivers would not reinstall. The only thing that was connected today was my printer si I assumed it was the printer. I updated and installed the new printer drivers but I still have this issue. It fixes with a reboot for a short time then i get message something like and unknown device has been disabled

If this issue prevails i.e after it happens and before it is fixed with reboot any camera or USB reader plugged into USB will not be recognised. I have to reboot to fix the error and then the camera will be recognised.Rebooting is not convemient. i have a virtual windows running inside this so have to reboot two. How can i find what the unknown device is? It says consul with device manufacturer but i do not know the device


Attached Thumbnails
Driver issue USB Mass Storage Device-unknown.jpg  
My System SpecsSystem Spec
23 Mar 2017   #9
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok now I cannot find any driver support for this machine as the site is an Audi outlet and from memory the brand Medion is their own, and it would be anyone's guess where it was actually made or who made it, in nay case probably in China somewhere.

Also being six years old and it is throwing that code 43 error I am thinking it may be wear and tear on that particular USB port. One thing you can do is to get a very bright light example one of those small cheap LED torches (I find them perfect for this) and look into each port for signs of any damage or wear and tear.

Going on from my first comment the only way to find what the motherboard actually is is to run the HW Info program. You can do this if you want to it takes very little time to install this excellent program and find what components you actually have inside the machine because as I said the Medion site is hopeless.
The choice is yours of course.
Using HW Info
PART A:
You can test the volts on the PSU with HW Info HWiNFO - Download < download the right bit version and close the right hand window select Sensors and scroll down to the power section where you will see what the volts are doing see my pic. In my pic the section (Nuvoton) with VBATT as a dead give away you are in the section for the rail voltages. There are other section titles and one that pops up often is ITE (sometimes the usual one for Gigabyte boards)
Now the voltage on the different rails have to be within 5% =+/- of what is required or the machine will not work properly if at all.
Limits +/- (minimum - correct - maximum)
12v1 = 11.4 - 12 - 12.6v
12v2 = 11.4 - 12- 12.6v
5v = 4.75 – 5 - 5.25v
3.3v = 3.135 – 3 – 3.465v
-12v = -10.80 - -12 - -13.20v
+5VSB = 4.75 – 5 - 5.25v
The Power good signal voltage at pin 8 on the 24 pin plug (grey cable) should be the same as the 5v rail reading/s
See this for the rail voltage info
PSUs 101: A Detailed Look Into Power Supplies (Section 2.)
The original right hand window shows the machine running and is handy for that but for looking at the components in some detail close it and use the main left hand side panel
FOR OTHER COMPONENTS
PART B:
Open each small square with + in it on the section the components are in and then click on the individual component/s (it will highlight in blue) - in the right hand side will appear all sorts of details including brands speeds and other essential info that particular device. See pic for example.

Use PART B: and see my pic for where to look

Edit: I meant to add we can also find out info on what the USB ports are or type.


Attached Thumbnails
Driver issue USB Mass Storage Device-mb-1.png  
My System SpecsSystem Spec
28 Mar 2017   #10
April Raine

win 7 home premium 64 bit
 
 

An Audi outlet? MEDION® AKOYA® E4355 D (MD 8341) is the pc it has a picture of it. Anyway i fixed it. Can be marked solved . I know the motherboard - Medion MS-7616

Thanks all
My System SpecsSystem Spec
Reply

 Driver issue USB Mass Storage Device




Thread Tools




Similar help and support threads
Thread Forum
Mass storage device usb driver
Hello. I do have a problem with Mass storage device usb driver and precisely with an iPod Classic 80Go.I tried everything but I always have the problem only on my computer;It detects the iPod as an amovible disk but iTunes doesn't detect it and its content is unreachable.
Drivers
Missing USB Mass Storage Device driver
:( I recently bought a new ipod and my laptop was not finding it, so i searched for an anwer and was told to uninstall the apple usb driver and the usb mass storage device, then plug it in. It worked at first, but now both drivers are gone and two have some yellow triangles by them,and when i try...
Drivers
Missing Mass Storage Device Driver
Hello I'm new to this forum and could really use some help. I have just bought a new Blackberry Torch 9810 smartphone and when I connect it to my Toshiba C650 Laptop computer (operating Windows 7) (using the Blackberry Desktop software, the computer recognizes the phone is connected but I...
Drivers
*Mass storage device* driver cant be installed?
Recently i have bought a new brand new computer and installed windows 7 64bit on it. It works perfectly fine until recently when I wanted to use my old external HDD : AH052S but it seems it cant install something. A little note pops up saying that there is a new device detected and suggests...
Hardware & Devices
Problem installing USB mass storage device driver
I have an Acer R3610 (so everything is via USB). When I plug in an I/O Magic disk drive, I get an error "Device driver software was not successfully installed". I had earlier tried to fix this situation by going to Device Manager and deleting all drivers under USB controllers. When I rebooted...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:46.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App