Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: re: a problem with 1 of my USB ports

15 Mar 2017   #1
reble

windows 7 home 32 bit, I just changed back from 64 to 32bit
 
 
re: a problem with 1 of my USB ports

This is on a Dell Inspiron 3541 laptop OS Win7 Home 32bit. I have 3 USB ports on this laptop. 2 on the left side and 1 on the right. 1 of the 2 USB ports on the left side has stopped working. The other USB port on the left side still works as well as the USB port on the right side. I had the plugin for the wireless keyboard and mouse in the dead USB port. I moved the plugin for the keyboard and mouse to the powered USB hub plugged into the working left side USB port. That solved the immediate problem. The next problem is how to fix the dead USB port, if it can be fixed without swapping out the motherboard. Any thoughts on this?

Steve


My System SpecsSystem Spec
.
15 Mar 2017   #2
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Hello Steve now assuming you have already done the updates for the USB driver/s as in the attached YouTube can you please check in the Device Manager for any yellow triangles against the USB ports.

See pic and YouTube it also mentions about Dell support site.



Attached Thumbnails
re: a problem with 1 of my USB ports-steve.png  
My System SpecsSystem Spec
16 Mar 2017   #3
reble

windows 7 home 32 bit, I just changed back from 64 to 32bit
 
 
re: a problem with 1 of my USB ports

Here is a screen capture of my device manager. Yes I did the updates. I installed all the factory drivers off the cd that I have for this laptop execpt for the Ethernet Controller. I don't use the Ethernet port. I connect to the phone company DSL router via WhFi. Otherwise I would have to run around 65' of lan cable from the dinning room to my bedroom. The other yellow triangle has been there since I had this laptop and I can't find the driver for it. The dead USB port was working with the yellow triangle on the Universal Serial Bus (USB) Controller. So what's next?

Steve

Quote   Quote: Originally Posted by ICIT2LOL View Post
Hello Steve now assuming you have already done the updates for the USB driver/s as in the attached YouTube can you please check in the Device Manager for any yellow triangles against the USB ports.


Attached Images
re: a problem with 1 of my USB ports-device-manager.jpg 
My System SpecsSystem Spec
.

16 Mar 2017   #4
rickchristine

Windows 7 Ultimate (64 bit)
 
 

1. Try to uninstall the universal serial bus controller.
2. Click the Scan for hardware changes.
My System SpecsSystem Spec
16 Mar 2017   #5
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

Ok Steve now mate you need to update the drivers for the Ethernet and the chipset and I am wondering just what is that Security device can you open it and see just what it is - I am guessing it maybe some Dell bloatware but just see.

To update those drivers use these Support for Inspiron 3541 | Dell Australia as the Windows feature is in my mind practically useless.
My System SpecsSystem Spec
Reply

 re: a problem with 1 of my USB ports




Thread Tools




Similar help and support threads
Thread Forum
Problem with PCI Expansion Ports
I have run into a problem with my PCI Expansion Ports I have been using a 3 port USB PCI Card. The other day, any device plugged into the card quit working. Did some troubleshooting, and found out that the card is receiving power only, and is not transmitting any data. Some of the USB...
Hardware & Devices
Problem with USB Ports
I'm facing too slow internet speed say 3-5 KBPS. But my normal speed is 50-60 KBPS. Type of Connection :2.G Dial up connection with Nokia USB Modem(Cable Connection) with nokia mobile(Asha series). There is no problem with internet while surfing in mobile,but with dial up connection with...
General Discussion
Ports problem
Hello, I'm having a strange problem. I'm trying to install Sophos and there fore the following ports need to be open: 8192, 8193 and 8194. All firewalls are disabled. But when I do telnet ipaddress 8192 (where ipaddress is the ip address of the problem pc) from the server I'm getting the...
Network & Sharing
USB Ports Problem
Ok here's the situation, evrything I plug into a usb port on my machine gets put into the devices/printers section. I have a flash disk and a sata docking station but can't use them as they aren't showing as generic drives. Any ideas as to what's wrong.
Hardware & Devices
USB ports problem
A few days ago, my portable hard drive (USB) was not recognized. But it was OK on other computers in the office using Windows 7. I tried various ports, but the computer is new and in any case, this didn't help. I am wondering if it is safe to delete all the USB connections from the "Device...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:35.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App