Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No drivers found after a fresh USB install

01 Jun 2017   #1
viltsu

Windows 7 Home Premium 64-bit
 
 
No drivers found after a fresh USB install

Hi, first of all I'm new to the forum so I'm not sure if this is under the right category.

My old laptop's hard drive was filled with all kinds of files (not a virus, just an old computer) and deleting some of them didn't help at all, so I decided to do a clean install of Windows 7. I used Rufus. I had issues with the installation complaining about no drivers found, etc. Somehow I bypassed that, but now after installing it, there are no drivers. No way to access the internet, small screen resolution and so on. I did try to install the drivers by downloading them from ASUS' website and copying them to a flash drive and installing from there, but it didn't work. Some of the drivers say "Installation successful" or similar, and some cannot be installed at all. And those that say installation successful, actually do nothing. There's also a CD that came with the computer, apparently including all the drivers. But when I try to launch that it says "This disk isn't compatible with this machine". At this point I'm very frustrated. What can I do? Can I install Windows with all the essential drivers automatically?
The laptop is ASUS X54H.

Thanks


My System SpecsSystem Spec
.
01 Jun 2017   #2
samuria

win 8 32 bit
 
 

Welcome to the forum. Did you get the correct drivers for 64bit win7 from here ASUSTeK Computer Inc. -Support- Driver & Tools - X54H
My System SpecsSystem Spec
01 Jun 2017   #3
johnhoh

Win7 pro x64
 
 

on the page samuria linked, first run the chipset inf update driver, then the lan driver and then the utility called asus live update, and you should be good to go. If not, try running this

IntelĀ® Driver Update Utility
My System SpecsSystem Spec
.

02 Jun 2017   #4
viltsu

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by samuria View Post
Welcome to the forum. Did you get the correct drivers for 64bit win7 from here ASUSTeK Computer Inc. -Support- Driver & Tools - X54H
Yes. That's where I got them from.
My System SpecsSystem Spec
02 Jun 2017   #5
johnhoh

Win7 pro x64
 
 

If you followed the steps in post #3 and it did not help, please post the entire content of the right hand pane of start > run > msinfo32 > components > problem devices.
My System SpecsSystem Spec
04 Jun 2017   #6
viltsu

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by johnhoh View Post
If you followed the steps in post #3 and it did not help, please post the entire content of the right hand pane of start > run > msinfo32 > components > problem devices.
No luck.

Network Controller PCI\VEN_168C&DEV_0032&SUBSYS_2C971A3B&REV_01\4&EE8FC94&0&00E1
PCI Simple Communications Controller PCI\VEN_8086&DEV_1C3A&SUBSYS_13C71043&REV_04\3&11583659&0&B0
USB Controller PCI\VEN_1B21&DEV_1042&SUBSYS_10591043&REV_00\4&1F17E497&0&00E3

Error codes for all the devices are "The drivers for this device are not installed."

EDIT: ASUS Live Update failed to install, gave the error message "Live Update is only compatible with ASUS notebooks."
I installed the network drivers, but like last time it said it was successfully installed yet after rebooting it still doesn't work.
My System SpecsSystem Spec
04 Jun 2017   #7
johnhoh

Win7 pro x64
 
 

In order those are:

Intel(R) Management Engine Interface
Atheros AR9485 Wireless
Asus USB Controller Universal Serial Bus USB Controller

I would run asus live update - in the utilities section here

X54H | Laptops | ASUS Global


live update should install them automatically but if not, note that the intel mgt driver is listed within "other" on the asus link

its possible the network driver is not atheros since i do not see it listed on the asus link, but try this anyway. can't hurt

Download Qualcomm Atheros wireless driver for AR9485 and 64bit Windows 7
My System SpecsSystem Spec
05 Jun 2017   #8
viltsu

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by johnhoh View Post
In order those are:

Intel(R) Management Engine Interface
Atheros AR9485 Wireless
Asus USB Controller Universal Serial Bus USB Controller

I would run asus live update - in the utilities section here

X54H | Laptops | ASUS Global


live update should install them automatically but if not, note that the intel mgt driver is listed within "other" on the asus link

its possible the network driver is not atheros since i do not see it listed on the asus link, but try this anyway. can't hurt

Download Qualcomm Atheros wireless driver for AR9485 and 64bit Windows 7
It's still happening. I can't do anything.
My System SpecsSystem Spec
05 Jun 2017   #9
viltsu

Windows 7 Home Premium 64-bit
 
 

bump, I need my laptop working by tomorrow
My System SpecsSystem Spec
05 Jun 2017   #10
johnhoh

Win7 pro x64
 
 

Quote   Quote: Originally Posted by johnhoh View Post
the intel mgt driver is listed within "other" on the asus link
see above
My System SpecsSystem Spec
Reply

 No drivers found after a fresh USB install




Thread Tools




Similar help and support threads
Thread Forum
No signed drivers were found on fresh install new build.
Hello, I've read a few of the other posts but haven't been able to get it to work on mine yet. I'm getting the "no signed drivers were found" error when trying to install windows 7 64 bit on my new build. I don't have an old one to format the hard drive and partition it on. So my question is can...
Drivers
Drivers after fresh OS install
Hi all. Have owned PCs for a long time but never really learned a lot of the stuff that is necessary if you're a PC owner. I'm now in the process of doing a fresh install of Windows 7 but not sure what to do to get all the drivers up and running after the install. My main concern is not having...
Drivers
After fresh install, trying to install device drivers
I absolutely killed Windows 7 today. I don't know what I did, but nobody else uses the computer so.....:o I installed Windows 7 (dvd) and everything went smoothly. But there are no device drivers installed and I don't know where to get them or how to install them. I mean I am totally blank...
Installation & Setup
Fresh OS install, need help with drivers!
Hey guys, I have recently reinstalled my windows 7 64 bit OS. Now I am trying to install the drivers for my graphics card, which is a geforce gt 540m. When trying to install the driver, it says, "You must install an Intel driver first". What does this mean? My laptop is an Asus a53sv...
Drivers
windows 7 fresh install - no device driver found
hi all, currently I am trying to do a fresh install of windows 7 on an old notebook, Compaq Presario V3500 (v3752au) the problem: I can not get pass the hard drive detection process, it kept throwing error saying that 'no device driver found' what I have done so far: search for the...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App