Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: xps 8300 windows 7 ultimate 64-bit

02 Aug 2017   #1
sputterbug10

windows 7 ultimate x64
 
 
xps 8300 windows 7 ultimate 64-bit

When I go into device manager, under "other devices" the Ethernet controller has an exclamation point. The problem code is "0000001C" I cannot for the life of me, find the driver. the hardware id is: PCI\VEN_14E4&DEV_1691&SUBSYS_04AA1028&REV_01

I did a search with the dev numbers and the ven numbers but I got even more confused.

Does anyone know where I can find the driver?


My System SpecsSystem Spec
.
02 Aug 2017   #2
fireberd

Windows 10 64 bit
 
 

Here is the link to the Dell XPS 8300 downloads for Win u 64 bit. You can get whatever driver(s) you need (and update if needed).
Looks like it has a Broadcom Ethernet NIC according to downloads list.
Support for XPS 8300 | Drivers downloads | Dell US


You may want to reinstall the Intel motherboard chipset drivers first. the xxx01C error code is unknown device. One of the main things the chipset drivers do is identify all the devices on the motherboard.
My System SpecsSystem Spec
03 Aug 2017   #3
sputterbug10

windows 7 ultimate x64
 
 

Thank you. I did download from there but that didn't make the exclamation mark disappear. Hmmmm.
My System SpecsSystem Spec
.

03 Aug 2017   #4
sputterbug10

windows 7 ultimate x64
 
 

I noticed that once I downloaded the Broadcom Ethernet controller driver that there were two ".exe" files: One is "BrcmSetup.exe" and the other is "setup.exe". Which one of those do I use?
My System SpecsSystem Spec
03 Aug 2017   #5
fireberd

Windows 10 64 bit
 
 

The Dell instructions should detail what to do after downloading. Did you first install the chipset drivers as I noted?

From the Dell driver download:
Quote:
This file contains a compressed (or zipped) set of files. Download the file to a folder on your hard drive, and then run (double-click) it to unzip the set of files. Follow the instructions to complete the installation
I tried to download it to see what it has in it but it won't download for me.

If I can't get you going, post on the Dell Community Desktop hardware forum section for more help. Someone there should be able to get you going.
Desktop - Dell Community
My System SpecsSystem Spec
09 Aug 2017   #6
wizardwillow

windows 7 32 64
 
 

de best was, REFRESH INSTALL - WINDOWS OS .. and it should eliminated ur problems.

OR

ask or find de "RESOURCE CD", re-install ALL requires DRIVERS such as MOTHERBOARD DRIVERS, LAN drivers etc etc, this more or less SHOULD eliminate ur issues!
My System SpecsSystem Spec
10 Aug 2017   #7
mrjimphelps

Dual Boot Linux Mint 32-bit / Windows 7 Professional 64-bit
 
 

Here is the string you posted: PCI\VEN_14E4&DEV_1691&SUBSYS_04AA1028&REV_01
The VEN (Vendor) number is 14E4 and the DEV (Device) number is 1691.

Check this post to see how to find the driver using these numbers.

I went to the website, pcidatabase.com, and I did a search for DEV number 1691. It returned three results, two of which were Broadcom. One of them was for a Gigabit Ethernet driver, so I clicked on that hyperlink and found the following:

Chip number: BCM57788
Chip Description: Broadcom BCM57788 LOM
Notes: http://www.broadcom.com/support/ethe...etlink_k57.php

I went to that website and found 70 drivers listed. About 2/3 down the page, there is a 32-bit and a 64-bit driver listed. Further down, there are other drivers. I'm sure you can find one which will work.
My System SpecsSystem Spec
Reply

 xps 8300 windows 7 ultimate 64-bit




Thread Tools




Similar help and support threads
Thread Forum
Trouble with Brother MFC 8300 driver (installed with "Windows Update")
I need help getting my printer to work with a fresh install of Windows 7 Home Premium 64bit. I had to re-install due to a CMOS error which I think was due to a dead battery. It still could be something else seeing as I have had other problems with this install (explained below). Anyway, the...
Drivers
Dell XPS 8300 support say's to re-install windows
I purchased a Dell XPS 8300 almost 1 year ago. The last couple months I have had boot issues when I turn the pc on. All hardware tests (since I purchased the pc have passed with no problems). The boot issues are where all the icon's for the short cuts do not load and or the icon to show I am...
General Discussion
Multisytem Dell 8300 BSODs
Weird multi system BSOD Have a bunch of Dell Dimensioin 8300's we purchased (Win 7 Enterprise, 64 bit, Purchases 1/2011). Been putting the same image on them for past year. All of a sudden that image is throwing some BSOD. Throws them pretty quick, within 30 minutes. Ok, no big deal,...
BSOD Help and Support
Dell 8300 Windows Upgrade - Lost Sound
I've been reading through the forums trying to get the thing to work but it is not. I just installed Windows 7 and my soundcard no longer works. Here are the specs: PCI\VEN_1102&DEV_0006&SUBSYS_10031102&REV_00 PCI\VEN_1102&DEV_0006&SUBSYS_10031102 PCI\VEN_1102&DEV_0006&CC_040100...
Sound & Audio
NVIDIA 8300 on board and flickering
Hello, I recently installed Win 7 Enterprise 64 bit on new setup and I'm quite happy with performance. I noticed however slight but quite annoying screen flickering, especially when reproducing dark shaded colours. It looks more like some interference, but I think it's not supposed to happen. I...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:27.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App