Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Failed to initialize' driver error

18 Nov 2017   #1

Windows 7 Ultimate x64
'Failed to initialize' driver error


I own an external firewire soundcard (Yamaha n12 mixer) which connects to the PCI firewire card (SIIG with a Texas Instruments Chipset) on my CPU. and I am facing a similar problem I faced a couple of times before where I resorted to the ultimate cure - reinstalling windows just to get a driver working since nothing else worked. That nightmare is back.

So all was working fine till yesterday. But today when I got my computer and the soundcard powered, I got the dreaded 'Failed to Initialize' message for the soundcard's ASIO firewire driver that comes with the soundcard. This is all the manual had to say about this issue -

Error message: Failed to initialize.
Cause: Initialization of Yamaha Steinberg FW Driver has failed.
Solution: Restart the computer.

Just for you to better diagnose the problem, I had also installed the latest Yamaha USB drivers a few days ago, since I thought of also incorporating an old yamaha device in my setup. Both, the firewire driver and the USB driver seemed to work fine, but on the next boot the error started showing up for the firewire driver.

So I uninstalled the Yamaha USB driver but no matter how many times I re-install the FW driver now (latest or the previous version), restart my PC before installing this, after deleting that etc etc, or even delete registry entries for the yamaha FW and the USB midi drivers (assuming I deleted the right entries) and then reinstalling, the error message still remains, with the control panel of the FW driver greyed out.

There is absolutely no response from the manufacturer about this matter and I really don't know where to go from here. The FW driver installation goes fine. I tried the IEEE 1394 host controller(Legacy) , Texas instruments 1394 host controller in device manager, disabling other devices, uninstalled ASIO4ALL since i thought another ASIO driver might be causing problems. But got no results.
I can live without the device running on the USB driver but really need to get the FW driver up. Most of the forum posts about this issue end with 'It suddenly started working this morning', and thats what happened to me the last time too, but I haven't been that lucky this time.

All the latest drivers, firmware have been downloaded and installed from the yamaha website.

Can someone please tell me what should I do to get the driver working and how to deal with such traumatizing driver issues when they show absolutely no direction as to what is wrong? :'(

OS- Windows 7 Ultimate x64

Thank you!


My System SpecsSystem Spec
18 Nov 2017   #2
Sub Styler

Windows 7 Ultimate x64

Try uninstalling the Yamaha devices from device manager, restart the computer and allow them to re-install automatically.

I assume the 1394 Port is listed as A OK in the device manager, and that the 1394 Network Adaptor appears and is enabled in Network Connections
My System SpecsSystem Spec
18 Nov 2017   #3

Windows 7 Ultimate x64

Hi Sub Styler,

Thank you for your reply. I did try that but unfortunately this soundcard doesn't install its drivers like the other USB devices I have where the drivers got installed as soon as they are connected and powered. The automatic installation of drivers works well with them after uninstalling their drivers, rebooting while keeping them on.

But this soundcard came with a driver CD when I bought it five years ago, and the new versions have to be downloaded from the yamaha website and installed. Infact they strictly mention to keep the device off and disconnected while installing drivers.

About the 1394 adapter, it does show as OK in Device Manager, and actually has never shown up in Network Connections even when the soundcard used to working. Attached is a screenshot of Device Manager, Devices and Printer, Network Connections and the error if that help you narrow down what the issue might be. Things have always looked like this in all the three places.

Don't understand what am I doing wrong.

Attached Thumbnails
Failed to initialize' driver error-drivererror.jpg  
My System SpecsSystem Spec


 Failed to initialize' driver error

Thread Tools

Similar help and support threads
Thread Forum
The driver \Driver\WUDFRd failed to load for the device... error
Hi, Since the 11/18/2012 event viewer (Event ID 219, Task Category 212) has been posting a warning: The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN (followed by name of USB device) It only occurs on start up if I...
The driver \Driver\WUDFRd failed to load for the device error
Hi i have a couple of weeks ago installed windows and i just got bsod crash and this was the only error in the event viewer The driver \Driver\WUDFRd failed to load for the device WpdBusEnumRoot\UMB\2&37c186b&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_GENERIC&PROD_USB_CF_READER&REV_1. ...
BSOD Help and Support
Driver for MTP USB failed error 31
So i plugged in my Canon T3i to my computer and it said it failed to install the driver for the MTP. It works on my other computer though also windows 7 that is 32 bit but my computer is 64 bit.
Graphics System failed to Initialize. Please restart your client.
Hello, I have a new computer, Mobo: ASROCK Z68 EXTREME4 GEN3 Graphics card: AMD Radeon HD 6870 1GB I've installed the latest drivers for each. When I try to play a game I get the error stated in the thread title. I have also tried deleting and reinstalling the drivers. I've looked on...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:54.
Twitter Facebook Google+