Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: General question about missing drivers when computer works fine:

28 May 2018   #1
bluejudy

various
 
 
General question about missing drivers when computer works fine:

My netbook seems to be working fine. I would like to ask why these show up with yellow warning signs in device manager? Could it be that they got loaded with Win 7 but my computer does not need them?

Intel Gigabit Network Connection
PCI device.


I am just trying to understand things a bit more.

Thank you for any help you care to provice.


My System SpecsSystem Spec
.
29 May 2018   #2
oscer1

win 7 64 bit
 
 

please list the hardware id for the device that needs driver. but the driver should be at the manufacture support page.

Open the Device Manager
Right Click on the Device in question
Properties
Details Tab
Win7 the VEN_ #### and DEV_#### is located under Hardware ID
My System SpecsSystem Spec
30 May 2018   #3
bluejudy

various
 
 

For the Intel(r) 82567LF Gigabit \Network Connection, here is the info:

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

driver info: Windows\system32\drivers\e1y6032.sys

When I let the driver search function do its thing, I get a msg saying that the driver is up to date.

----------------------

For the PCI device, it says that no driver files are required or have been loaded for this device.


It says, "PCI bus 3, device 0, function 0.

When I do a driver search online using the built-in driver search function, I am told that no driver can be found.


-------------------

Everything seems to be working okay, and that is why I wonder whether these are just things that this netbook does not use.Just curious about this.
My System SpecsSystem Spec
.

30 May 2018   #4
oscer1

win 7 64 bit
 
 

since they are in device manager it knows their is a device in the laptop. have you installed all the drivers from the link in your other thread? if you do not want to install them and your netbook is working fine then leave it be until you have problems. but if it was me I would install the drivers for the device.
My System SpecsSystem Spec
31 May 2018   #5
bluejudy

various
 
 

Yes I did install every single driver. I guess if something malfunctions down the line, I shall have to come back here for advice.

Thank you for your reply.

Regards,
Judy
My System SpecsSystem Spec
31 May 2018   #6
F22 Simpilot

Windows 7 Ultimate x64
 
 

That driver is for the ethernet connection. Are you using WIFI and not a wired ethernet connection?
My System SpecsSystem Spec
31 May 2018   #7
bluejudy

various
 
 

Indeed I AM using WIFI. Thank you for clarifying that. Maybe with a little more reading I can figure out the PCI bit just for the sake of curiosity. I am so glad that I joined this forum. I am learning so much here.
My System SpecsSystem Spec
31 May 2018   #8
F22 Simpilot

Windows 7 Ultimate x64
 
 

PCI is just a bus standard for hardware. Not to be confused withn a yellow bus. LOL Conventional PCI - Wikipedia
My System SpecsSystem Spec
Reply

 General question about missing drivers when computer works fine:




Thread Tools




Similar help and support threads
Thread Forum
Windows 8 Missing App Icons, Corrupted, but Safe Mode works just fine?
Working on a client's PC. Has a Core i5, 120gb ssd, 4gb ram, nothing too fancy. His SSD has a windows 7 partition (works just fine) and a windows 8 partition (not so much). The windows 8.1 boots up and works just fine. However when you click the start button, literally all the app and program...
General Discussion
Computer works fine at the computer shop, but at home the FPS is low
This is for a friend by the way. So he got a new gaming computer, he set it up at home and started playing Skyrim, the FPS was shit so he brought it to the shop. The professionals tested it and the fame rate there was fine. But then he brought it home and the frame rate turned shit. I made sure...
Gaming
General Question - Windows Installed Drivers Vs OEM Website Drivers
Greetings, This is a general question for a fresh install of Windows on a computer. Let's say we just completed the installation and we open up Device Manager (we haven't used Windows Update yet). Device Manager shows us that there are - let's say "3" - devices that do not have drivers installed...
Drivers
My computer speakers do not work but headset works fine.
I get the following error. "The peripheral does not appear to be plugged in" I've updated the driver and it says the realtek device is working fine. Sound worked just fine on this computer but then stopped. I do not have external speakers. How can I plug in the speakers or fix the problem? :(
Sound & Audio
System Reserved partition is missing, but WIndows 7 Pro works fine
I have a Windows 7 Professional system that I went to take an image of using EASEUS TODO Workstation. When I went to do the backup, I noticed that there was no 100 MB System Reserved Partition. I made the image anyway. When I tested the image on a new machine, it prompted me to repair or...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:05.
Twitter Facebook Google+