Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: dotnetfx35.exe problems Windows 7

4 Weeks Ago   #1
trev133

Windows 7 Ultimate X86
 
 
dotnetfx35.exe problems Windows 7

Hi. Just purchased a CNC router which requires dotnetfx35 to be installed. Each time I try from supplied disc I get a message Extraction Failed "The system cannot find the path specified". When I check Control Panel Programmes and features, Turn features on/off the box is filled. Does this mean it exists and I don't need to download it?


My System SpecsSystem Spec
.
4 Weeks Ago   #2
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Hello trev133 and welcome to the forum,

yes you are quite right, .net 3.5 framework (dotnetfx35) is pre-installed on Windows 7, so you shall not need to use the supplied disc to install this again.

.net 3.5 framework, as you have already discovered, is enabled by turning the feature on.

Since the feature is turned on on your computer, you might want to now try and install the software that came with your CNC router.

Just a slight warning. The .net 3.5 framework is quite old and there are known comparability issues with Windows 7, so don't be too surprised if the software that you are trying to install either fails to install or fails to work correctly - I mention this as you are intending to use potentially quite dangerous equipment, and I don't wish you to come to any harm, if you do not know what you are doing.
My System SpecsSystem Spec
4 Weeks Ago   #3
trev133

Windows 7 Ultimate X86
 
 

Many thanks for the reply. Thats good news. I have went ahead and the CNC-USB software has loaded OK. Tomorrow I will have a go at running a test piece. Again many thanks.
My System SpecsSystem Spec
.

4 Weeks Ago   #4
trev133

Windows 7 Ultimate X86
 
 

iko22 one other point you can maybe confirm about the .net 3.5, with the feature turned on its a filled box and not a tick, is this status sufficient or does it need the box ticked. (the only option I have is a blank box or a filled box, no opportunity to tick like some of the other files). I am able to jog the machine manually which might suggest the installed .net 3.5 is sufficient. Do you know or can you confirm. Again really appreciate your input as I am in unfamiliar territory.
My System SpecsSystem Spec
4 Weeks Ago   #5
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Hello trev133, yes, the .net 3.5 feature does just have a filled in blue box when it is turned on, it does not have the tick. You may notice that there is also a "+" icon next to the filled in box. Clicking on the "+" icon, expands the sub-features that may be checked or un-checked. All features that have filled in boxes also have an associated "+" expansion icons. Features with the ticks have no associated "+" icons besides them - that is the difference between the two.
The .net framework has to be in place before the software can be installed. The software installer would check for the presence of the framework, before allowing the install to continue. So, the fact that the Software has installed would suggest that the installation of the .net framework is good.
I am unfamiliar with CNC-Routers, I do not understand "jog the machine manually". All I know is that a PC can send instructions to a CNC controlled device.
Does the CNC machine come with operating instructions? You might like to start the PC Software according to the instruction manual. If you have no manual, then you may like to start the Software with either the USB cable disconnected, or with router blade removed. Thats all I can think of, as a safety precaution.
My System SpecsSystem Spec
4 Weeks Ago   #6
trev133

Windows 7 Ultimate X86
 
 

Iko22. Thank you for that clarification. I will run a programme tomorrow to check the movement is being communicated to the machine. Instructions are fairly vague with the software but there are some good YouTube videos to follow. Agree that 1st runs will be without cutter. Will keep you posted how I get on. Meantime thanks again. Trev
My System SpecsSystem Spec
3 Weeks Ago   #7
trev133

Windows 7 Ultimate X86
 
 

Hi iko22. Just to let you know I ran a simple CNC programme tonight and the communication link seems fine. Really appreciate the advice you gave me, I had Googled for hours before I found this Forum, really glad I did. Again Many Thanks. Trev
My System SpecsSystem Spec
3 Weeks Ago   #8
iko22

Windows 7 x64, Vista x64, 8.1 smartphone
 
 

Pleased to hear that the installation on both the PC and the CNC side of things are working correctly.
My System SpecsSystem Spec
Reply

 dotnetfx35.exe problems Windows 7




Thread Tools




Similar help and support threads
Thread Forum
Ubuntu Windows 7 dual-boot, Windows 7 logo animation problems
Greetings, I have installed Ubuntu 14.04 LTS 64-bit alongside Windows 7 Professional 64-bit OS in dual-boot configuration with GRUB 2.02beta2. Both OSs are up to date; however, occasionally I do not get the animated Windows logo in the Windows 7 boot-up and a distorted screen is displayed...
General Discussion
Problems downgrading preinstalled Windows 8 to Windows 7 on ASUS Vivo
Hello. I think I'm losing my mind here and now I think I'm lost. Been googling and circling around for hours. So, I have an ASUS Vivobook laptop here, which has a preinstalled Windows 8. Now I'd like to downgrade to Windows 7, which I got thanks to my school having a deal with DreamSpark. So...
Installation & Setup
Windows 7 Shell Problems: Drag and drop, Windows Installer, etc...
There is probably one underlying problem that will solve all of this because it all started about the same time. 1. Drag and drop frequently stops working Upon releasing mouse: http://i.imgur.com/ydToW.jpg Releasing a favorite on the top bar of Chrome: http://i.imgur.com/QA5WP.png Dragging...
General Discussion
Windows live essentials 2011 installer problems on Windows 7 64 bit
Windows live essentials 2011 installer is stuck on 99%, and doesn't move. No error messages or anything. It just sits there and does nothing. I have to use task manager to force it to close as the cancel button is greyed out, and it won't let me run the visible windows live messenger that seems...
Software
Windows Index Problems a.k.a Windows Assesment Problems
Hi, I have had Windows 7 for a while now and have continually tried to run windows assesment tool for a while now, but each time I run it, it always ends up having a problem when it starts "Tuning Windows Media Decoding" and ends up closing. This is not terribly important but I was just wondering...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:03.
Twitter Facebook Google+