Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win 7 Ultimate not allowing installation citing Driver signature error

16 Nov 2019   #1

Windows 7 Ultimate x64
Win 7 Ultimate not allowing installation citing Driver signature error

Hi all,
I'm having a problem with driver signature enforcement on my clean install of Windows 7 Ultimate 64x on my Laptop. I had a black screen of death couple of days ago which led me to backing up all my data (by using hiren boot USB) and performing a clean Windows install via USB. Upon entering the desktop for the first time, I installed the drivers necessary for WLAN which was installed successfully and then I tried to install COMODO Free Firewall. Halfway through, warnings about no digital signatures being present popped up but the installation completed nonetheless. It required a restart which I allowed but another warning saying Comodo Firewall couldn't successfully start showed up and even Comodo's own diagnostic tool was unable to fix the program

Since I used Comodo Firewall for the longest time and I really needed a firewall before anything else, I decided to perform another reinstall of windows, this time with Home Premium 64x. Same problem as before. I decided to try Zonealarm firewall instead and that didn't work either I should also mention that I also used the bcdedit command lines in both OS's but no intended results.

I decided to use Windows 7 ultimate 64x OEM which was the version I was on when the Black-SOD happened and also assumed I would not have this problem since I was on this OS previously until the reinstall last week. Surprisingly, even this version which didn't throw up any signature errors in the last two years since I've used it suddenly brings the same error as the Ultimate and Home Premium. And now, I'm out of options to try.

A little about my hardware, I'm on a Acer 5750g, 8GB RAM( previously 4GB until I upgraded in early October). It intially came preinstalled with Home Premium 64x but a BSOD forced me to perform a clean install to the OEM version I mentioned above. If you're wondering why I didn't use the in-built function ACER provided to re-install or fix windows, it's because whenever I try to bring that function up (by pressing ALT + F10 during boot up), it shows this error which I assume means it's corrupted somehow which led me to downloading an OS image file online and using it instead.

I would appreciate any help in this matter. Scoured the internet and tried all the solutions I could. The issue isn't just about the firewall but I'm worried it could show up with any other software I try to install.
I'll be happy to provide any other details if required.

PS- I downloaded the installer files for both Comodo and ZoneAlarm from the official websites

My System SpecsSystem Spec
16 Nov 2019   #2
Paul Black

Win 7 HP SP1 64-bit Vista HB SP2 32-bit Linux Mint 18.3

Hi PJwarpM,

Welcome to SevenForums!

Quote   Quote: Originally Posted by PJwarpM View Post
. . . performing a clean Windows install via USB.
. . . I decided to perform another reinstall of windows, this time with Home Premium 64x.
. . . which led me to downloading an OS image file online and using it instead.
Where did all the installation media actually come from?
My System SpecsSystem Spec
16 Nov 2019   #3

Windows 7 Ultimate x64

I got it from
My System SpecsSystem Spec

17 Nov 2019   #4

Win 7 Ultimate 64-bit

IIRC two firewalls running at once will cause conflicts. Did you disable the built-in Windows FW before trying to install Comodo or Zone?

I used to use 3rd party FWs (comodo and zone alarm both at different times for years), then learned they typically collect personal data of everywhere you go online, and have ambiguous privacy policies. Also learned (in this very forum) that the built-in Windows FW is quite good and doesn't collect telemetry like 3rd parties. It's also very flexible and easy to use, to set up your own rules related to particular programs you want to block from the W/LAN.

So I uninstalled Comodo and began using the Windows FW many years back now, and it's great. Computer boots faster and the FW does a fantastic job.

My advice FWIW is, use the built-in FW and use Sandboxie for browsing, and uninstall all AVs. That's what I've been doing for many years now with great results and no infections or resource overhead.
My System SpecsSystem Spec

 Win 7 Ultimate not allowing installation citing Driver signature error

Thread Tools

Similar help and support threads
Thread Forum
First time ever Windows 7 Ultimate installation error
I got a new Corsair Force LS 120GB SSD. Had problems with CPU so replaced my old FX-8150 with a FX-8370 on a Sabertooth 990FX R2.0 board. Used Rufus to Create my Windows 7 bootable USB device. Installation and setup process loaded successful. Created partitions on SSD, did initial...
Installation & Setup
Driver Digital Signature error when using signed drivers (Code 52)
Hi, This is my first post on these forums, so please excuse me if anything is wrong. Details of the problem: I have a Sony VAIO laptop that runs Windows 7 Home Premium x64. I recently downloaded the same version from digital river that has SP1 included and installed it on my laptop. I...
General Discussion
Win 7 installation error: installation must be on a local driver
Hello, I am experiencing a installation error with my Win 7. The error: installation must be on a local driver. I did a SFC scan, and now attached log file for your reference. thank you in advance.
Installation & Setup
Singularity Installation Error @ Win7 Ultimate x86
everytime i try to install the game "Singularity" i get this error: i attached my Services if anyone wanna see if there is something wrong here, no matter if Windows Installer is Running or not i get the error...
XP installation not allowing Advance Options
I need to have a dual-boot. My laptop has Windows 7 installed and I need to install XP. I have partitioned the drive and inserted the XP CD. On switch on I get the message "NO EMULATION system type- 00". This also occurs with another XP installation CD. It then starts loading XP, rather than...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:21.
Twitter Facebook