Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB device not recognized - Help!

17 May 2010   #41


Blakjustice30, I tried your solution but had problems tabbing from one port to another when I unplugged my mouse. Can you tell me how to tab between USB ports in device manager using only my keyboard.


My System SpecsSystem Spec
18 May 2010   #42

windows 7

This thread seems to have gotten a little off track from the original subject header.

The issue has not been the identification of the USB ports themselves, per se, but in fact the identification of devices attached to USB ports ... the USB ports appear as "working" in Windows, however any device attached to the port is not recognised. This is a differnt issue from some of the above responses.

Seems to be a "trait" of 5xxx model ACER lap[tops. Althpoigh I posted my solutions above, it ahse happened to my ACER 5100 laptop again. This time, my previous solution failed miseably. The USB ports appears as funtioning in the Windows Device Manager - i.e. there is nothing wrong with the ports themselves. However, as soon as any device is attached (mouse/keyboard, w/less mouse/keyboard, USB stick, USB external HDD, et al), the error message appears that the device is not recognised.

Temp solution has been to use a USB port PCMCIA card - works sometimes, fails others.
My System SpecsSystem Spec
27 May 2010   #43


Can someone tell me how to find where the RC1 file is on my PC?
My System SpecsSystem Spec

28 May 2010   #44

windows 7

Quote   Quote: Originally Posted by weecosse View Post
Can someone tell me how to find where the RC1 file is on my PC?
Details please??

RC1 usually refers to the version of Windows 7 (Release Candidate 1) that was made available for public downloading and testing.

From March 1 2010, any computers running W7 RC1 would shut down every 2 hours. This version is due to expire completely from 1 June 2010.
My System SpecsSystem Spec
03 Jun 2010   #45

Windows 7 Pro 64-bit

This USB device thing is just about to send me over the event horizon. Not only USB but 1394 Firewire, too.

This is probably gonna be long, but I'm tryin to include a pertinent data. The basic configuration is in my sig.

Win 7 Pro, Build 7600, 64 bit.
16 Gig buffered Ram
60 GB SSD (OS only)
5.5 TB internal SATA, all internal and external drives are Western Digital.

I've got a lot of USB devices on my "Dreadnought"

2 printers
HP 5200
Epson P1400

Graphics tablet (Wacom Bamboo)

3 WD 1TB external drives

Saitek keyboard (thank God that works)

2 CF card readers
RocketFish CF & SD
Dynex CF SD and about every other kinda card

Epson V500 Scanner

The two biggest problems are getting the system to recognize the disk drives and CF card readers. I'm a photographer and I'm always pulling the CF card from one of my Canon DSLRs and popping it into one of the 2 readers (I usually keep one with my laptop for when I'm on the road.) so that I can transfer photos to an internal drive for storage and editing.

Up until yesterday, it was a 50/50 chance of getting the externals or card readers to be recognized by the OS. But then they just quit working altogether.

Before this leads anyone into jumping to conclusions, I'll mentioned that I've done some tweaking on the system to improve performance and it's helped. Some folks might jump to the conclusion that my "tweaking" (the system software type, not the other type) caused the problems but I don't think so. I figger 45 years in the computer business either makes me qualified to do this or labels me as a raving lunatic. Maybe both. But there was no correlation between the registry tweaks I'd made and the problems with the USB storage devices that I could identify.

So when I'd shot a few photos and wanted to prepare one of 'em for my
http://www.raythe Photoblog. So I pulled the CF card out, slid into one of the readers (RocketFish) and...nothing. I tried the other reader (one that had seemed flaky, even on XP) and nothing there.

Other USB devices, like printers and graphics tablet didn't seem to be a problem.

To make a long story short, after exhausting just about every other option, I ended up doing a Repair Install on the box before I could get it to recognize one of the card readers.

The Repair Install took about 8 hours. About 6 hours into it I finally got so frustrated with the time it was taking that I removed the power cables from the external drives. (The card readers weren't connected. I suppose I shouldn't have had the externals connected, either.) I got a nasty-gram stating that I'd lost one file which wasn't a big deal. It was a backup of a backup. Finally, after a whole lotta cussin and frettin, the install completed. But when the box came back to life, I realized that the external hard drives weren't recognized. I had to reboot with one of 'em connected, then reboot with 2, and so on. I rebooted so many times I lost track of exactly how this went, but the gist of it is that I had to bring one of the externals online at a time, then reboot with it and the next one connected and eventually I was able to see all of 'em.

Another thing I verified was if I had the card reader plugged into one of the USB connectors on the front of the case (it's a Cooler Master HAF 932) the boot process would take forever (and maybe longer than that) while attempting to recognize ANY USB storage device that was connected.

FINALLY the box is running with this configuration:
All 3 external drives are daisy-chained to 1 port on the Firewire controller.
RocketFish CF reader connected to one of the 4 front panel USB ports.
All other USB devices are connected to the USB ports on the mobo, with a 1:3 expander that only has the graphics tablet and Saitek keyboard. Those are working fine. I can also connect my Android phone to a USB port and charge it or use it as a USB device and transfer files back and forth.

I've tested both printers, the scanner and the graphics tablet. All are working.

It appears that I had 1 bad Firewire cable and apparently the Dynex card reader is junk.

I don't have too many conclusions except that once I daisy chained the Firewire drives instead of running 'em each on their own port at the controller card they seemed to work better. We'll see after the reboot.

Reboot complete. all storage devices and other USB devices functional. Firewire daisy chaining appears to be functional

The Dynex Card Reader is going just went into the trashcan. I'll get another one for my laptop as I head out of town to shoot a car show in a coupla hours.

I just plugged 4 USB thumb drives into the front-panel connectors and they all came up fairly quickly. I guess this is about the best I've ever had things working.

If you've hung in with this whole narrative, you're probably about as mentally exhausted as I am. The system is working...but will it remain stable? I don't know. I'll shut it down until I get back from 4 days of photo shoots on the road.

What I'd REALLY like to find is a comprehensive USB device manager. One that can see ALL devices connected to USB ports rather than just "mass storage" devices. Does such a thing exist? I haven't been able to find one.

I don't know if this can be helpful to anyone, but for me, it seems to demonstrate that you CAN get from here to there eventually (to quote the title of an old Steppenwolf song) if you take the time and fight one issue at a time...and don't rule out faulty hardware.

My System SpecsSystem Spec
03 Jun 2010   #46

Windows 7 64 bit

EDIT: Do not follow this method. See below

I am having a similar problem to the original poster. I have a USB thumb drive that I use at work. I have been using it for several months and have never had a problem. Today, I inserted it into my laptop and I got the "Unrecognized USB device" error. The drive has an access LED which did not light up. I went into Control Panel -> Device Manager -> USB controllers and disabled the "Unrecognized" device, and then enabled it. Did not work. I then disabled it and unplugged my flash drive, and then plugged it back in. The device manager now recognizes it and the access LED is on, but it does not appear in Windows Explorer.

I have an ASUS K61IC laptop with Windows 7 home Pro 64 bit with automatic updates on.

It does have a NVIDIA display adapter, but I don't know about the USB adapter.

The flash drive is recognized in a different XP laptop.

EDIT: Do not do this! I retested the drive in the XP computer, and it does come up in Windows Explorer, but when you click on it you get a message "Please insert a disk into drive F:". I think I just de-formatted my flash drive...
My System SpecsSystem Spec
03 Jun 2010   #47

Windows 7 Pro 64-bit

Ouch! I hope ya didn't. Matter of fact, I'm almost sure you didn't. This is the symptom I got every time things would start to go silly. Power off the laptop completely. Not just hibernate, but complete power down.

Then put the thumb drive in the USB port and fire it up again. Unless it hangs in the BIOS, it should come up and read it.

By the time you read this I'm sure you will have tried it in another machine and found it to be ok. (I got my fingers crossed for ya.)
My System SpecsSystem Spec
03 Jun 2010   #48

Windows 7 64 bit

Nope, powered down and up, still not working. And the other computer no longer recognizes the drive either. Luckily, there was nothing on it that wasn't backed up somewhere, but I can't seem to get it working again.

In Device Manager, it shows up under USB controllers as a USB Mass Storage Device, and it shows up under Disk Drives as a USB Device, but if I go to properties -> Volumes, nothing is listed.

In Control Panel -> Administrative Tools -> Computer Management -> Disk Management it shows up as a disk with no media and capacity of 0 MB.

Anyway, I can always get another USB drive, and all the data was backed up. I just hope Microsoft fixes whatever I did wrong so no one else goes through it.
My System SpecsSystem Spec
04 Jun 2010   #49


I managed to get my problem fixed by doing this: Go to Control Panel; then to System and Security - find and fix problems; Programs - run programs made for previous versions of Windows; Troubleshhot and help prevent computer problems and click on Next; Select your TomTom program then Next; then Test compatibility settings from the programs; click on next. When I did this is brought up previous versions os Windows. I chose Windows Vista and it worked.
My System SpecsSystem Spec
23 Jul 2010   #50

Windows 7

Hey guys, I have this USB problem too! I've built this new computer 2 days ago, all the old peripherals have worked fine (from my old computer, which was in the days of XP) but this morning nothing is working except the mouse and internet dongle... both my keyboard, PSP and USB stick say they are not recognised, and now the USB stick and Keyboard are no longer working on other computers! Any help would be great
My System SpecsSystem Spec

 USB device not recognized - Help!

Thread Tools

Similar help and support threads
Thread Forum
USB Device Not Recognized. Device Error 43/45
i don't know what is this problem. and it always appears on my system tray How to fix it? These are some pictures.
Hardware & Devices
USB Device Not Recognized
Hi, While working on my laptop yesterday evening, my mouse & external hdd stopped responding. On ejecting & re-inserting them both started getting this message 'USB Device Not Recognized'. Now none of my three USB ports are working. Though on cross checking, the devices are working on other...
Hardware & Devices
USB device not recognized.
I'm pretty sure that it isn't the first subject about it, but I didn't find any threads wich looked like mine, so I'm doing a new one. Yesterday, I was browsing the Internet like everyday of the week, and my mouse stopped working, for no reason. It just does the "tadam" (sound wich is done when we...
Hardware & Devices
USB device not recognized - but there is no usb device connected
It's recognized in device manager as "Unknown device". But I've not connected anything to pc. Also all of my usb ports are working at 1.1 speed. When I try to connect any device, I get the message "that it could work faster, if i connect it to hi-speed usb port". Any suggestions?
Hardware & Devices
USB Device Not Recognized
I've had an issue that has been driving me nuts for the past few hours. I have a Dell Inspiron 537s tower on which ive done a clean install of Windows 7 x64. Everytime I plug in a USB device it gives me a "usb device not recognized error". I've tried every solution ive found (uninstall all usb...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:42.
Twitter Facebook Google+