Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Prolific USB-to-Serial Driver

14 Jun 2011   #41

Win 7 32

I found the link to the Vista driver in this thread and it installed in Windows 7 32-bit.

thanks to whomever posted that link:
Windows Vista driver for prolific chip USB Serial Adapters
Windows Vista driver for prolific chip USB Serial Adapters

My System SpecsSystem Spec
22 Jul 2011   #42

Windows 7 Professional x64

Quote   Quote: Originally Posted by rc50won View Post
Yes I found the latest versiin on the Prolific web site but it does not install.
I've downloaded a similar driver, and have added the following readme to the Zip:

Running the CH341SER utility unzips the files into C:\WCH.CN\CH341SER, but the INSTALL button will fail. Use the Browse My Computer option in Update Driver to locate the folder and install manually.
My System SpecsSystem Spec
21 Aug 2011   #43

Windows 7 32-bit
usb to serial adapter

I have about 8 different usb - serial adapters that I have bought over the years, all of them are from different manufacturers. Some work with Windows 7 32/64 some don't. By looking inside the adapters I found out that they all contain one of these 3 processor chips: FTDI, Prolific and Silicon Labs. The FTDI chip USB to serial adapter works perfectly with all versions of Windows, the Silicon Labs works mostly fine too. No serious troubles, only sometimes Windows can't open the port in the first try and I have to restart. Prolific is the one that is most unreliable. Sometimes it works with Windows 7 sometimes not. I have never been able to find out why. It simply just don't respond sometimes.
I never had an adapter with the WCH processor mentioned earlier in this thread, but that will probably be the next I will buy and test.
My System SpecsSystem Spec

30 Aug 2011   #44

1.Windows7 32bit 2. Win7 64 bit
Prolific on acer win7 64 bit

I have an acer win7 64 bit laptop core2 duo. Just bought a usb-rs232 adapter to do some router jobs. I got the correct PL2303 prolific driver. It installed correctly but Hyperterminal and other program just giving error message"Unable to open com port". Uninstall / reinstall same issue. Any help appreciated...
My System SpecsSystem Spec
10 Sep 2011   #45

window 7 home premiun 64 bit
usb to rs232 on window 7 64 bit

you can get usb rs232 serial cable and disk software driver with for vista, window 7 from 64 bit from beagle software usb to Rs232 adapter it work
very well with window 7 64 bit cost 14.95 plus shipping
My System SpecsSystem Spec
11 Nov 2011   #46

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
This worked for me

Quote   Quote: Originally Posted by DrOrdi View Post
I did too, thank you, and it worked just fine selecting the Vista driver for my Win7x64 laptop.
My System SpecsSystem Spec
21 Nov 2011   #47

Windows 7 Ultimate x64,

I installed the driver for Windows 7 Ultimate x64 >> and my device is working. Thank SillyMan and friends!
My System SpecsSystem Spec
24 Nov 2011   #48


I installed prolific driver and a usb-serial dongle from china worked fine for about a week multiple install/uninstall/reinstall and no joy ...what else?
My System SpecsSystem Spec
25 Nov 2011   #49

1.Windows7 32bit 2. Win7 64 bit

My prolific works intermittently also. It may stop responding during a session.It is better on Ubuntu.
So i ordered a cheap FDTI adapter. Works on all machines...The chipset really matters.
My System SpecsSystem Spec
14 Dec 2011   #50

Windows 7
USB to Serial Adapter Nightmare

Okay, I have had a living nightmare trying to get a Prolific USB-RS232 Serial adapter working with my Labview program. I just solved the problem and thought I would share my experience in case it may help others.

The story begins when I bought a Trendnet TU-S9 USB adapter that uses the Prolific PL2303 driver. When I first installed the USB-Serial adapter, it showed up as COM3 an everything worked great. My labview program was able to communicate properly with a syringe pump I was controlling.

I made the silly mistake of unplugging the USB to serial adapter and plugging it back in. This is when everything went to hell. Everytime I would plug in the adapter the COM port number changed. My Labview program could no longer access the device, even when I programatically entered the correct COM number. I kept getting an error in labview indicating that the VISA resource is valid but the program cannot access the resource. I was not aware of any other programs utilizing the COM ports.

I tried connecting to the COM using hyperterminal and kept getting an error stating " Another program is using the selected telephony device. Try again after the program completes ". I was not able to open the COM port with Hyperterminal.

After some intense web searching, I came across a lot of posts about how these drivers are complete crap and they are very finicky about how they are installed. I tried every version of the driver I could find and still no luck.

Fustrated, I ended up buying a FTDI based USB-Serial adapter cable (Model USA-FTDI-A12). Still no luck. I got the same error in Hyperterminal. Clearly this was not a hardware or driver issue.

I even downloaded a different emulator program (Teraterm) which was unable connect to the COM ports (prolific or FTDI adapters). I downloaded another program called Portmon ( a serial port monitoring program). This program was not able to open the COM ports either, indicating they are in use. I started to suspect that there actually was another program that was disrupting the USB communications or hogging the COM port.

Next, I downloaded a program called Process Explorer to try and find out what was using my COM port. At first I could not find the specific virtual COM ports or Devices when searching handles in process explorer. Out of curiosity, i searched simply for "USB". Process explorer brought up a process called SacReminder.exe that seemed to be utilizing almost 10 of the USB ports. This process is for a Clickfree backup hard drive that I use. I killed the process and tried Portmon and Teraterm again.

Hazzaaah !! It finally worked and I can use my syringe pump. Everything is back to normal and I have a newfound hatred for Clickfree. Unfortunatley, i do not know enough about computers to understand why things suddenly went wrong, but this might give some idea to others about how to approach problems with these USB-serial adapters. Anyone else having problems with their USB-Serial, I would definetly figure out how to use Portman and Process explorer to determine what 3rd party programs might be interfering with your adapters. Thanks to many numerous people on the internet for their suggestions (too many to name).

My System SpecsSystem Spec

 Prolific USB-to-Serial Driver

Thread Tools

Similar help and support threads
Thread Forum
Prolific USB-To-Serial Driver
Hardware ID = USB\VID_067B&PID_2303 I have been all over the internet looking for a driver that works with this device. I am running Windows 7 Ultimate RTM 64-Bit. Every driver that I have found that will "work" absolutely does not work. Any ideas on a working driver?
Prolific USB-Serial (9/4/2015) from Win Update, error 52 (signature)
I have researched the Prolific USB-to-Serial driver issues. There's loads of information and mis-information regarding the Prolific chips, the counterfeit chips, and various driver versions. I've installed several different versions including (7/31/2007), (10/27/2008),
BSOD i think prolific usb to serial
Hello Some time ago I started to get BSOD. I am almost sure part of them related to Prolific USB to serial i start to use. But i am afraid latest 2 are of some other origin. I tried different Prolific drivers, some of them do not start to work at all. (840.4 KB) Any...
BSOD Help and Support
Cant get prolific usb to seriel driver to work
Hi there… I have 2 cables witch is ”usb to seriel” One of the cables installes fine with the “prolific” driver. The other cable does not work. According to the manufactor both of the cables should work on that prolific driver..
Infuriating Prolific driver puzzle
I have just finished a new build Intel i3 on a Gigabyte GA-H55M-UD2H mobo running Windows 7. Both the PCI slots are vacant and I have no need of them. However, I have a device identified as "Prolific USB to COMM port (COM 6)" which infuriatingly loads no driver. I tried downloading the Prolific...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:47.
Twitter Facebook Google+