Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: prob with Realtek 8111D (nic/lan driver)

06 Mar 2009   #1

win 7 ultimate 64-bit beta
prob with Realtek 8111D (nic/lan driver)

Hello, I am running win7 64 bit on:
GIGABYTE GA-EX58-UD3R LGA 1366 Intel X58 ATX Intel
using the onboard nic
LAN: Realtek 8111D
Here is my problem. I can get to the internet with limited (to almost none) connectivity. I can get onto world-of-warcraft and get 60 fps for hours on end with no lag at all, I can have bit-torrent running for hours with no issues, however when I try to browse internet pages it just doesn't connect, and quickly it can't resolve dns or something - not like it's waiting for a response from some site out there (the error message comes up immediatly. I tried this on firefox too and same thing. I disabled ipvx6 and to no avail. I tried using opendns, and that was no help. I am using a router but my other computers hooked up to it (xp) don't have any problems. On the other end of this, I can't find any drivers for win7 from realtek. The vista 64 won't install (says this driver is only for vista) and the xp64 won't install (says can't install this driver on vista)...LOL.
I don't know why it connects sometimes an not others but once it starts not working it just degrades to no website connections. I have tried the tool that's part of win7 to dianose the issue but it doesn't find one. I am confused because I'm getting wicked fast connections to Wow and with bittorrent, it's just the internet browsers that won't connect...I have to hit reload like a dozen times before it catches and then maybe it downloads the page, maybe not? Also, I have re-installed win7 and the default driver (i think it's xp 32bit) from realtek..because without that driver the nic card doesn't work at all.
Any ideas??
PS, I have ubuntu cd install to run from memory and I can get on and don't have any connection problems either so I'm assuming it is NOT a hardware issue.

Here is the specs for my motherboard:
Model GA-EX58-UD3R
Supported CPU
CPU Socket Type LGA 1366
CPU Type Core i7
North Bridge Intel X58
South Bridge Intel ICH10R
Number of Memory Slots 4240pin
Memory Standard DDR3 2000+/1333
Maximum Memory Supported 16GB
Channel Supported Triple Channel
Expansion Slots
PCI Express 2.0 x16 2
PCI Express x4 1
PCI Express x1 2
PCI Slots 2
Storage Devices
PATA 1 x ATA100 2 Dev. Max
SATA 3Gb/s 8
SATA RAID 0/1/5/10
Onboard Video
Onboard Video Chipset None
Onboard Audio
Audio Chipset Realtek ALC888
Audio Channels 8 Channels
Onboard LAN
LAN Chipset Realtek 8111D
Max LAN Speed 10/100/1000Mbps
Rear Panel Ports
PS/2 2
USB 8 x USB 2.0
IEEE 1394 2 x IEEE 1394a
S/PDIF Out 1 x Optical, 1 x Coaxial
Audio Ports 6 Ports
Onboard USB
Onboard USB 2 x USB 2.0/1.1 headers
Onboard 1394
Onboard 1394 1x 1394a
Physical Spec
Form Factor ATX
Dimensions 12.0" x 9.6"
Power Pin 24 Pin

My System SpecsSystem Spec
23 Jun 2009   #2

Windows 7 / Windows XP / Ubuntu

I had a similar problem. Check the driver in Device Manager. Windows used the 8111B driver for the 8111D network adapter. Solution was to force it to use the 8111D driver and remember not to update it in Windows Update.
My System SpecsSystem Spec
23 Jun 2009   #3

64-bit Windows 7 Ultimate Build 7100

Hey, I think I had the same problem as you. More info here.

What I think you did was use windows update to update your network adapter driver. The driver they recommend may cause problems with your internet connection. I would go in to the Device Manager and roll back that driver. I hope that solves your problem.
My System SpecsSystem Spec


 prob with Realtek 8111D (nic/lan driver)

Thread Tools

Similar help and support threads
Thread Forum
Unable to get online after reinstalling windows - possible driver prob
Hi, I recently reinstalled Windows and since doing so I have been unable to connect to the internet. I have been trying to resolve the problem but without much luck. I think the problem may be driver related because I can connect to the internet in safe mode but not in normal mode. So far I...
Network & Sharing
Oh dear, still a prob! wpd file system volume driver
I have upgraded from XP Home 32bit to Windows 7 64bit, clean install of Win 7. I have installed my Canon MP620 printer from the installation CD. In device manager under 'Portable Devices' there is an error (Triangle) shown as 'WPD Filesystem volume driver' The installed drivers are: ...
ASUS/Realtek, Latest Realtek versus default W7 Audio driver
I installed the Realtek HD audio driver from the ASUS download site (P8Z68-V Pro MB) and all was well until I installed an MSI 560TI video card and let it install the Nvidia HD Audio drivers. The problem I have been chasing ever since was the Realtek HD Audio Manager popping up after the system...
Sound & Audio
Flickering display and windows kernel mode driver prob
Hi. I've got some minor problems but still I find them quite annoying. First: When I'm running Win 7 my display is flickering. It just looks like bad reception on a TV station. When it gets too bad the display turns blak and after a second everything is fine and it starts all over again. ...
Graphic Cards
Realtek RTL8168D/8111D Family
Hi all I have the above NIC in my Windows 7 (7100) setup. It is running fine, But, If I go to windows update, there is a driver update for it. If I install it, the NIC refuses to work. Anyone have any info as to why this could be?, I did a search on here but could find no info. Cheers for...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:02.
Twitter Facebook Google+