Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Edimax Wireless Card EW-7718IN installation problems

11 Jan 2010   #1

Windows 7
Edimax Wireless Card EW-7718IN installation problems

I bought an Edimax WiFi card (EW-7728IN) which supports Win 7 to replace an earlier WiFi card unsupported by Win 7. In the initial installation I left Windows to find the necessary driver, which it did and reported a successful installation. However, no wireless signals were picked up and when I went into the Network Centre and looked at the adapters, the card was recognised but reported as Disabled. I tried to enable it and Win 7 went through Enabling to Enabled but the icon for the adapter continued to show Disabled and no wireless signal was detected. Looking in Device Manager showed the WiFi card was detected with no exclamation mark next to it and it was reported to be working normally. Win 7 wireless diagnostic procedure suggested there may be a driver problem but gave no solution.

I uninstalled the inbuilt MS driver and then went to install the Windows 7 driver provided by Edimax and written by Ralink. Essentially the same thing happened and installation was reported as successful but despite Device Manager reporting the card to be working normally it was shown to be Disabled in the Network and Sharing centre. To give as much information as possible, the following data summarises the situation:

I have used the Windows 7 driver (20091028) provided on the Edimax website.

Under Device Manager it reports that the card is given as working normally and the driver is given as Edimax 802.11n PCI card and the driver given as provided by Ralink Technology, Corp., driver version dated 4/8/2009.
The Win 7 diagnostics from within Device Manager gives the following information: Network adapter Wireless Network Connection driver information:

Description . . . . . . . . . . : Edimax 802.11n PCI Card
Manufacturer . . . . . . . . . : Ralink Technology, Corp.
Provider . . . . . . . . . . . : Ralink Technology, Corp.
Version . . . . . . . . . . . :
Inf File Name . . . . . . . . . : C:\Windows\INF\oem26.inf
Digital signer . . . . . . . :Microsoft Windows Hardware Compatibility Publisher
Inf File Date . . . . . . . . . : 26 June 2009 06:56:30
Section Name . . . . . . . . . : OS61_RT2800P.ndi
Hardware ID . . . . . . . . . . : pci\ven_1814&dev_0601
Instance Status Flags . . . . . : 0x180200a
Device Manager Status Code . . : 0
IfType . . . . . . . . . . . . : 71
Physical Media Type . . . . . . : 9

Running the Edimax utility Diagnostic test shows all the stages give a Pass until 08:58:52:806 Profile verification gives 0 Profiles - Warn! and 08:58:52:821 gives 0 Diagnostic Capable - Warn!
The Network diagnosis gives CCX Diagnostic test failed!!!

Is this likely to be a driver problem or are there some arcane settings within Win 7 that is preventing what is seen as a successful installation to be effective.

I would be grateful for any help you can give me.

My System SpecsSystem Spec
11 Jan 2010   #2

Windows 7

I have the same problem with my Ralink RT61 !

Installs succesfully, but doesnt detect my wireless network whilst the Vista machine i have does and the XP laptop does, the machine in which i installed Windows 7 on was working fine on XP.

Same results with the Ralink Diagnostic test,
My System SpecsSystem Spec
11 Jan 2010   #3

Windows 7 Ultimate 32 bit

don't let windows look for the driver if the adapter came with a cd put it in and go to device manager and choose update driver then choose to install driver manually and point to driver on cd and install that way if you did not get a cd use link to download driver file and extract that and point to it

Ralink corp.
My System SpecsSystem Spec

11 Jan 2010   #4

Windows 7
Tried installing directly from the latest Edimax driver

You can see from the top that I have tried both the automatically installed Windows driver, which didn't work. Then I uninstalled the Windows driver provided and set Win 7 up so that it didn't automatically provide the driver. Then using the Win 7 driver provided on the Edimax website went through the same installation but still it doesn't make any difference. I thought that maybe there were traces left of the previous installation so I deleted all Wireless Connection settings in the Registry and reinstalled the Ralink Driver from the Edimax website. No change. Exactly as before - the EW-7728IN driver was recognised by Win 7 but disabled. The continuous light on the wireless card switched on but no connection and no wireless signals were detected.

Could the card be defective? Is the driver buggy? Are there any Win 7 settings interfereing with the installation?

Thanks for your interest and help.
My System SpecsSystem Spec
11 Jan 2010   #5

Windows 7 Ultimate 32 bit

well there is always a chance the card is bad but other people have been having problems with the ralink adapters also so maybe it's not
My System SpecsSystem Spec
11 Jan 2010   #6

Windows 7 Ultimate 32 bit

do you have an adapter that is not a Ralink chipset they seem to have issues for some reason
My System SpecsSystem Spec
11 Jan 2010   #7

Windows 7 Ultimate 32 bit
try this

try removing some ram get below 4 gigs and see what happens i know this is weird but something to try people have been reporting this bug with all sorts of issues it has solved your issue for other people so maybe try it
My System SpecsSystem Spec
12 Jan 2010   #8

Windows 7
EW-7728IN card - RAM reduction and other suggestions

I have tried the following:

Reduced the RAM to 2Gb had no effect on the 'Disabled' status of the card.

I have tried another EW-7728IN card and that does not function either, so unless an entire batch was faulty it seems unlikely that the card is at fault.

I don't know for sure whether the entire chipset is non-Ralink but the main chip on the card has Ra RT2860T - GX30080E0 - 0810ST printed on it which seems to be a Ralink chip.

The RT2860T on the chip suggested that I try the Ralink driver for this chip. I was directed to their website and a driver called IS_AP_STA_RT2860_D-'. This was installed after uninstalling the previous driver. Unfortunately it had no effect and the 7728IN card remains visible, connected but disabled.

If the following will help anyone this is all the information I'm able to get about the network card using SIW:
Property Value
Device ID PCI\VEN_1814DEV_0601SUBSYS_77281432REV_00\4278CCF74000F0
Status 0x0180200a Started
Problem 0x00000000 (0)
Service netr28
Capabilities 0x00000000
Config Flags 0x00000000
Class Net
Manufacturer Edimax Technology Co., Ltd
Hardware IDs PCI\VEN_1814DEV_0601SUBSYS_77281432REV_00
Compatible IDs PCI\VEN_1814DEV_0601REV_00
Class GUID {4d36e972-e325-11ce-bfc1-08002be10318}
Location PCI bus 5, device 0, function 0
Bus number 0x00000005
Enumerator name PCI
Description Edimax 802.11n PCI Card
Driver {4d36e972-e325-11ce-bfc1-08002be10318}\0019
Physical Object Name \Device\NTPNP_PCI0023
Upper filters vwifibus
Bustype GUID {44203042-2046-4245-2043-382031302042}
Legacy bus type 0x00000005
Install State 0x00000000
Device Address 0x00000000

Device Configuration File oem35.inf
CoInstallers32 RaCoInst.dll,ClassCoInstaller
NewDeviceInstall 1
NetCfgInstanceId {691A6870-65F2-40B4-86A2-A726B86A7327}
*IfType 47
Characteristics 84
*MediaType 10
*PhysicalMediaType 9
NetLuidIndex 1
DeviceInstanceID PCI\VEN_1814DEV_0601SUBSYS_77281432REV_00\4278CCF74000F0
InstallTimeStamp DA 07 01 00 01 00 0B 00 15 00 38 00 17 00 F4 02
PortAuthSendControlState 2
PortAuthReceiveControlState 2
PortAuthSendAuthorizationState 1
PortAuthReceiveAuthorizationState 1
WirelessMode 5
Channel 1
Radio 0
WMMCapable 1
FrameAggregation 0
IEEE80211H 1
CarrierDetect 0
WPSDevName Ralink Client
OpMode 0
TXBurst 1
ShortSlot 1
BACapability b034040
TransmitSetting 2ba15
NetworkType 1
Adhoc5GDisable 0
SmartScan 0
PSMode 0
PSControl 0
ProhibitTKIPonHT 1
LinkSpeedStatus 0
AdhocN40MHzAllowed 0
CountryRegion 1
CountryRegionABand 1
AdhocNMode 1
BusType 5
ComponentId pci\ven_1814dev_0601subsys_77281432
InfPath oem35.inf
IncludedInfs netvwifibus.inf
InfSection OS61_RT2800P.ndi
InfSectionExt .NT
ProviderName Ralink Technology, Corp.
DriverDateData 00 40 89 94 CF 60 CA 01
DriverDate 11-9-2009
MatchingDeviceId pci\ven_1814dev_0601subsys_77281432
DriverDesc Edimax 802.11n PCI Card
PnPCapabilities 10
ControlFlag 1
CountryTxPwr 14
CountryTxPwr5G 17171e63
CountryWirelessMode 11101110
RunOnceInitConfigTool 1
RunOnceInitConfigTxBurst 1

Class Net
ClassDesc @NetCfgx.dll,-1502
Network adapters
IconPath %systemroot%\system32\setupapi.dll,-5
Installer32 NetCfgx.dll,NetClassInstaller
EnumPropPages32 NetCfgx.dll,NetPropPageProvider
LowerLogoVersion 6.0

It is infuriating but it looks like there are serious problems with this card and Windows 7.
My System SpecsSystem Spec
12 Jan 2010   #9

Windows 7 Ultimate 32 bit

the Ralink cards seem to have driver issues a lot of people are reporting this that the driver for 7 does not work, try to get something with a broadcom chipset
My System SpecsSystem Spec
12 Jan 2010   #10

Windows 7
Death knell for Edimax 7728IN

I guess that's it for the Edimax. On another PC that I set up for my son, the Netgear Rangemax worked fine with Windows 7. I guess I'll have to play safe.

Thanks for all the suggestions.
My System SpecsSystem Spec

 Edimax Wireless Card EW-7718IN installation problems

Thread Tools

Similar help and support threads
Thread Forum
Edimax EW-7612PIn Wireless PCI-Express Adapter disconnects randomly.
I have had this problem since earlier this week. For some reason my Wireless Adapter will disconnect and hardly wants to reconnect. I have tried the following solutions: 1. Turn Router off and on. 2. Diagnose Problem. 3. Disable adapter then enable it again. 4. Uninstall adapter and install...
Network & Sharing
wireless card problems messed with settings and in need of help!
hello, this is my first post on this forum. i am in need of some help regarding the windows 7 wireless settings. a couple of days ago i downloaded the microsoft virtual wifi miniport software to attempt to connect to both my 4g connection on my android via tethering and also my home wifi network,...
Network & Sharing
Edimax EW-7128G Wireless PCI Adapter
I just upgraded to Windows 7 (32-bit) and have installed the drivers for my Edimax EW-7128G Wireless PCI Adapter. It is recognising my wireless router but wont conncet to the internet. All my other wireless devices, including a laptop running Vista, are able to connect to the internet via the...
Need drivers for Edimax EW-7318Ug wireless usb adap.
Windows 7 doesn't recognise this device,are there any drivers that work with Windows 7 for this device..
Wireless card driver problems
I have a Marvell Libertas 802.11b/g wireless card. After about 2 hours of searching for 64bit drivers i turned up empty handed. so i downloaded drivermax to see if it could find the drivers it found the drivers and installed to my knowledge successfully but i am getting an error code 10 on the...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:29.
Twitter Facebook Google+