Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Device driver was not successfully installed

15 Jan 2010   #1

Windows 7 Home Premium 64-bit
Device driver was not successfully installed

This is what I get at every startup in the notification area: "Device driver was not successfully installed"
When I click on the message I get a window that says:
"Device driver was not successfully installed.
Microsoft WPD Enhanced Storage Password Driver ---- Failed"
All attempts by Windows 7 troubleshooting just try to fix it. I just want to get rid of it.
I have found the registry entries for this but have no idea what to alter to stop this driver from trying to run.

(Yes, while trying to fix a USB problem I mistakenly clicked to install this.)

Windows 7 Home Premium

My System SpecsSystem Spec
15 Jan 2010   #2
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Have you tried going into the device manager and looking for any yellow marked items? Something similar was seen with Vista as well with usb drives. USB Drive Problems with Vista

Either right clicking to uninstall followed by a full restart or to have Windows perform an automatic search won't always work. A manual search by selecting the device from the list of devices will often see Windows install the correct generic driver where you end up with "Windows has successfully installed your new hardware" type message.
My System SpecsSystem Spec
16 Jan 2010   #3

Windows 7 Home Premium 64-bit

@Night Hawk,

When I read your reply I was doubtful because I had looked at Device Manager and there were no exclamation marks. Just to be thorough I expanded every item and looked at each one carefully. I almost missed the tiny exclamation mark in a sub heading. I clicked on it and Deleted the driver. Rebooted and no more error message.

Thank you. Repped.
My System SpecsSystem Spec

16 Jan 2010   #4
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64

Glad to see that worked right away for you! Apparently Windows never fully detected something there. Once you removed the item and allowed Windows a second chance it corrected the first mistake.
My System SpecsSystem Spec
06 Jul 2011   #5

Windows 7 Ultimate

Same thing happened when I was installing Epson T13. I did the uninstall of the yellow marked icon and the printer worked fine. Night Hawk, you saved a lot of my time and the business'. All the best!!!
My System SpecsSystem Spec
13 Aug 2011   #6

Windows 7 64 bit
external hard drive doesnt read

I have a seagate external hard disk when i plug in to my laptop it shows device driver not installed correctly. When i try to update it, it says all drivers are up to date. i have a lot of data in it that i dont have back up for. I plugged in another laptop its the same. It just doesnt show the icon in my computer to launch it. This all happened after my anti virus deleted an infected autorun file destination was H: which usually is the hard disk...when i go to the properties it says device working properly what can i do ? please
My System SpecsSystem Spec
16 Jan 2012   #7

Windows 7 Home Premium x64

same here.. i got the exclamation mark.. i'd uninstalled the USB and restart but nothing done... help me please..
My System SpecsSystem Spec
10 Sep 2012   #8

Windows 7 Professional x64

I had this same issue. And after some research I found this:

The Windows 7 SP1 USB Driver Bug (what it is and how to fix it) [Archive] - My Digital Life Forums

Long story short, it seems SP1 disables USB2.0 support and causes this issue.
My System SpecsSystem Spec
07 Apr 2014   #9

Windows 7 Home Premium x64

1. plug kindle into pc
2. ignore unpleasant driver message
3. enter device manager and click the following:
* update driver software
* browse my computer for driver software
* let me pick from a list of device drivers on my computer
4. select 'portable device' from the list
5. select 'standard mtp device' from the list
6. select 'mtp usb device' from the list
7. click next
My System SpecsSystem Spec
17 Jun 2014   #10


1st check for any new updates at windows updates if you find any install them than if you have an anti virus delete it than go to - Download Free Software search for avira install it once you done run a full scan if it detect any problem remove the problem than go to device manager and right click on your device and click update driver software remember to plugin your usb when updating driver software

hope this works for you cause this helped me
My System SpecsSystem Spec

 Device driver was not successfully installed

Thread Tools

Similar help and support threads
Thread Forum
Device driver software not successfully installed.
So i've just took of windows 10 and put windows 7 on instead, im sure you know why. And since then none of my usb devices will connect and install their drivers. my usb mouse and keyboard essentially do not work. I've been at it for hours trying to update drivers and such but nothing is working. Im...
Device driver software not successfully installed--OK, but which?
Had a problem (user profile), so reverted to last usable configuration. Now I get a message that "device driver software was not successfully installed." That would be easier to fix if I knew which device was meant. Device Manager shows two USB devices with exclamation marks, each marked...
Device driver software was not successfully installed
My system just recently getting this error message from Windows 7. All my keyboard and mouse are disabled due to this error. I tried all usb ports and once I plug in the device, it displays this error message, then stuck. I can once use my ps2 keyboard to access the windows, but now the windows...
Hardware & Devices
Device driver software was not successfully installed.
Screenshot I installed windows 7 Ult on my Toshiba satellite l50 laptop (which had no operating systems installed at the time). No programs were installed and 7 drivers weren't recognised. I used the same installation CD to install Windows 7 on VMware (on my desktop) and the drivers were...
Device driver software was not successfully installed, Daemon T, more
Yesterday I upgraded hardware from: AMD Athlon X2 4600+ & Mobo to: Core i5 3570K and Asus P8H77-I mobo. I think it's since then, that I can't install some drivers. I first noticed when I was going to use Daemon Tools Lite, there weren't any drives so i clicked "Add device" in D-tools...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App