Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Issue with my friend's Network Adapter

13 Feb 2010   #1
ThatDuckGuy

Windows 7 Ultimate 64 Bit
 
 
Issue with my friend's Network Adapter

So my Friend recently upgraded his old Laptop (Dell Latitude C840) from Win XP to Windows 7 32bit. The only issue was that his network adapter was not being recognized. He couldn't connect to the Internet either wirelessly nor through Ethernet. I was perplexed and couldn't help him over the phone. I tried telling him to enable, disable the drivers in device manager but nothing seemed to work. I found the Dell driver download page for his laptop but am confused as to which one of the network drivers would fix his network adapter. Here is the link, could you give me some advice as to what to do next?


My System SpecsSystem Spec
.
13 Feb 2010   #2
tezlewis

Windows 7 Ultimate 64-Bit
 
 

Hi there, Try these drivers for the wireless.

Drivers and Downloads

And this for the ethernet

Drivers and Downloads

See if they help!
My System SpecsSystem Spec
13 Feb 2010   #3
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

And don't forget if they aren't windows Seven drivers to use compatibility mode to install. Fabe Compatibility Mode Also fromm\ the looks of the amount of different models avalible he may need to figure out which one he is actually using.http://support.dell.com/support/down...&catid=&impid=
My System SpecsSystem Spec
.

13 Feb 2010   #4
TaraSWinTeam

Windows 7
 
 

Here is more information about how to find drivers for your hardware that isn't working: Update a driver for hardware that isn't working properly. Here is additional troubleshooting information: Why can?t I connect to the Internet?.

Cheers,
Tara
Windows Outreach Team
My System SpecsSystem Spec
14 Feb 2010   #5
ThatDuckGuy

Windows 7 Ultimate 64 Bit
 
 

Thanks for the help guys, I downloaded a driver off of Download.com that people said was compatible. He then used that driver temporarily to get onto the internet and update again through windows update. Now he's got both his wireless and his Ethernet working. Thanks again.
My System SpecsSystem Spec
Reply

 Issue with my friend's Network Adapter




Thread Tools




Similar help and support threads
Thread Forum
Issue with changing Duplex Speed on Network adapter
Hey All, My question is.. My windows Network adapter settings only show Local Area Connection #2, and when I Click into settings I am unable to change the Duplex settings, not sure if I would be able to delete the settings and by creating a new one would fix my issue or not, but it seems like...
Network & Sharing
Issue with one (or both?) network adapter(s)?
Alrighty, so here's the required list of info from the sticky: 1. This may be a wired or wireless connection issue, I can't tell, because sometimes it works wired and sometimes it works wireless. 2. My ISP is TE-Data, in Cairo, Egypt. (Big help, huh? :P) 3. I believe I'm using a DSL...
Network & Sharing
Virtual PC Network Adapter Issue
So i recently covnerted my XP environment to a virtual environment with virtual PC. I am having an issue getting the nic to work properly. i set it to NAT, bridged, etc with no success. i notice in a clean installation (ie XP mode) there is a network adapter that is craeted. how do i go about...
Virtualization
Belkin Wireless N+ Network Adapter Issue
I recently bought a N+ Belkin adapter, as my old adapter did not support Windows 7 and our household is upgrading to an N router soon. The USB adapter (model number F5D8055) works fine on a vista desktop that is connected to the router, and will seemingly install on my Windows 7 rig, but it...
Hardware & Devices
Curious Network Adapter Issue
I loaded some software that I didn't want to 'activate online' and to insure that there wasn't any internet connection I manually disconnected the cable from the port. I plugged it back in and I'm reconnected, until, I reboot. Once the computer has rebooted I'm no longer connected. I either...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:40.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App