Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: no sound realtek hd

09 Mar 2010   #1
petlo99

windows 7
 
 
no sound realtek hd

hi,
i thank in advance anyone who can help.
i've been searching through the web for someone who had the same problem but with no luck. i must say that before i had vista os and updated to seven to solve the problem but it didn't work cause the situation is the same...
the problem is that with realtek hd installed i have no sound from the speakers of my notebook while headphones and mic through jacks works perfectly.
if i uninstall realtek and the system install automatically microsoft hd i have sound from my speakers but it doesn't recognize when i plug heaphones or mic...
please help...


My System SpecsSystem Spec
.
09 Mar 2010   #2
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Hi Petlo99 and welcome. Try this, click Start and in the search bos type Device manager. Click on the Device Manager at the top of the list that opens above. Scroll to Sound Video and game cotrollers. Double click and see if the the Realtec entry has a yellow triangle next to it. Double click the Realtec entry and see if the resulting window shows any problems.
Post back your findings.
BTW I'm sure you are aware that you can't have both the speakers and the headset working at the same time!
My System SpecsSystem Spec
09 Mar 2010   #3
petlo99

windows 7
 
 

thanks for the reply.
the device is working just fine, the os doesn't detect any problem...
i can add that on sound properties the sound shows up (the green lights) but doesn't come out from the speakers... and i right clicked to find any disabled device...
if the sound would come from speaker and headphones at the same time, i would think there is a problem...
My System SpecsSystem Spec
.

09 Mar 2010   #4
Desslok

Windows 7
 
 

Did you install teh regular drivers or teh High Definition drivers? I had this problem and it was drivers.
My System SpecsSystem Spec
11 Mar 2010   #5
petlo99

windows 7
 
 

Quote   Quote: Originally Posted by Desslok View Post
Did you install teh regular drivers or teh High Definition drivers? I had this problem and it was drivers.
i uninstalled the drivers several times but it doesn't allow me anymore to make any change. at restart it installs automatically realtek hd drivers. i don't know much about pcs but this problem i think is on the registry... i still have a slight hope to fix it
My System SpecsSystem Spec
08 Apr 2010   #6
Posideon

Windows Seven
 
 
Realtek No Sound Solution

I had the same problem with my Realtek sound card after my upgrade to windows 7.
For some unknown reason a clean windows 7 install resulted in the speaker output being disabled by default. The following was the solution I came up with after some trial and error

1) Go into the control panel
2) Select sound
3) In the playback tab right click and select show disabled devices and show disconnected devices
4) If (as was in my case) the speakers are not shown as the default playback device and are disabled. Right click on the speakers icon select enable, then select set as default device.
5) By this point you should be able to right click on the speakers icon and successfully execute the audio test (Make sure your speakers are on before running the test)

I hope this solution can help you or someone else with this particular problem.
My System SpecsSystem Spec
09 Apr 2010   #7
petlo99

windows 7
 
 

thanks but that didn't work for me, there are no disabled devices to show...
My System SpecsSystem Spec
09 Apr 2010   #8
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Pettlo99
Going back to your original post it looks as if this is a long standing problem? Have the speakers ever worked? I see they didn't work when you had Vista installed, can you remember when they last worked? I'm thinking that it is possible there is a dry joint somewhere between the sound card and the speakers especially as Device Manager seems to indicate that the individual components are working. It's a bit like the elctric kettle not working when the electricity supply is OK and the kettle is perfect - it has to be the connecting cable (lead in UK)
My System SpecsSystem Spec
09 Apr 2010   #9
baarod

El Capitan / Windows 10
 
 

Quote   Quote: Originally Posted by petlo99 View Post
thanks but that didn't work for me, there are no disabled devices to show...
For what it's worth, I've not been following this thread but I know for an absolute fact that many case mfrs have not adopted the hd wire pinout. So if your onboard audio is hd and the jack assy is ac97 you wont get sound. Get the latest realtek drivers from Realtek, install them and then look for this in the tray after the mandatory reboot:
Attachment 66086
My System SpecsSystem Spec
09 Apr 2010   #10
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by baarod View Post
Quote   Quote: Originally Posted by petlo99 View Post
thanks but that didn't work for me, there are no disabled devices to show...
For what it's worth, I've not been following this thread but I know for an absolute fact that many case mfrs have not adopted the hd wire pinout. So if your onboard audio is hd and the jack assy is ac97 you wont get sound. Get the latest realtek drivers from Realtek, install them and then look for this in the tray after the mandatory reboot:
Attachment 66086
Hi baarod
Interesting this but can you look at Attachment 66086 as the link appears broken.
My System SpecsSystem Spec
Reply

 no sound realtek hd




Thread Tools




Similar help and support threads
Thread Forum
Distortion sound using onboard realtek sound card on windows 7ultimate
Hello,i recently upgrade my system from xp to windows7,i use the same realtek driver and get distortions!I try severall drivers,disable all enhancements/levels on speakers properties with no result(2.1speakers-),i configure them in stereo mode,i reduce the default format to 44100 16bits(cd...
Sound & Audio
No sound.. Help! [Realtek HD]
I've tried to fix this problem all night, reading old posts but nothing works. Okej look, this is my motherboard: Gigabyte GA-Z87X-D3H http://cdn.imghack.se/images/ed00ba838fe2c60414ec25a5cbc09349.jpg Nothing is connected, i've tried to 'check' the front panel...jack in connector settings...
Sound & Audio
No sound, Realtek sound inputs assigned randomly
The realtek audio managers shows that the front two inputs, front mic and headphones, are always plugged in when there is nothing in them at all. When I plug in my speakers to the back green input for sound it inputs both the green one, front speakers out, and the blue input, line in. Now I get...
Sound & Audio
Realtek onboard sound. No sound
I don't know how to title this too well but yeah. I have been using a USB headset for quite some time but I recently purchased some Audio Technica ADH-700's. I've plugged them in and woolah!.. Just kidding.. No sound at all :( I have an Avermedia Live Gamer HD Capture Card and with getting it...
Sound & Audio
RealTek OnBoard Sound Issue - No Sound
Hello everyone, My audio has seem to quit on me. I updated to the newest drivers for my mobo (biostar A870U3) from their download page and now I get no sound whatsoever from my speakers. I have tried uninstalling all of the sound devices from the device manager and letting windows reinstall...
Sound & Audio
sound problems with Realtek ALC 882 sound card
I have a HP Media Center PC. the Model number is a1412n I am dual booting xp and windows 7, and in windows 7 I am not getting any sound. When I went to check it out, I realized that the computer was only recognizing the front audio jack. So i plug my speakers into the front jack but it still says...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App