Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Driver Error with On-Board Sound. HELP!

17 Mar 2010   #1
Foetoid

Windows 7 Ultimate 64-Bit
 
 
Driver Error with On-Board Sound. HELP!

Well i finally bit the bullet and decided to come ask for help. I have Windows 7 Ultimate 64-Bit. I also have an oldish MSI K9NNEO AM2 Motherboard. I managed to get all the drivers for my motherboard no worries from the MSI website, installed them all correctly except the Sound Drivers. With the standard drivers that come with 7, i get sound out of the normal green audio jack, but not the additional audio jacks underneath it (black, grey and brown i think they are). The reason i need these to work is i have my Zalman 6-Channel headphones plugged into those 3. I tried downloading both the 64bit and the combo 32/64bit drivers from both the MSI and Realtek websites and it doesnt matter how i download it or where from, i get the same error each time:

"An error (-5006 : 0x8000ffff) has occurred while running the setup.

Please make sure you have finished any previous setup and closed other applications. If the error still occurs, please contact your vendor: Realtek Semiconductor Corp.."

When i click on Detail, this is what i get:

Error Code: -5006 : 0x8000ffff
Error Information:
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\ObjectHolder.cpp (442)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kernel\ServiceProvider.cpp (87)
>Kernel\FileGroup.cpp (525)
>Kernel\ServiceProvider.cpp (120)
>Kerne>SetupDLL\SetupDLL.cpp (1299)
pAPP:Realtek High Definition Audio Driver
PVENDOR:Realtek Semiconductor Corp.
PGUID:f132af7f-7bca-4ede-8a7c-958108fe7dbc
$11.50.0.42618
@Windows XP (7600) BT_OTHER 15092.30673

Kinda strange how down the bottom it says Windows Xp even tho i know i am only downloading the windows 7 drivers. Help please!

EDIT: I will also add that i e-mailed MSI about it. After redirecting me to the Realtek Website, they tried to tell me to pay for a registry cleaner "Regcure" and then try. Of course i refused, simply opting to download CCleaner and go with that. Made no difference.


My System SpecsSystem Spec
.
18 Mar 2010   #2
Foetoid

Windows 7 Ultimate 64-Bit
 
 

Is anyone able to help? Its really irritating to have these nice headphones i cant use, and i cant play my games loudly as it annoys everyone. I guess i 'could' buy a soundcard, but i also shouldnt have to. If i did buy a soundcard, would i still be able to use the on-board for my standard speakers and my sound card for my headphone. Being a broke single father, i want to avoid spending any money.
My System SpecsSystem Spec
18 Mar 2010   #3
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Did you update/install the motherboard driver,

NVIDIA DRIVERS 15.53 WHQL

before trying to install the audio driver?
My System SpecsSystem Spec
.

18 Mar 2010   #4
Foetoid

Windows 7 Ultimate 64-Bit
 
 

Just downloaded and installed that. The driver package for the Realtek HD audio still has the same problem. Also while installing that Nvidia package, some Nvidia Networking Manager had an error too and wouldnt install.
My System SpecsSystem Spec
18 Mar 2010   #5
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

This is from someone trying to install a game but getting the same error message,

Solved: error code -5006 : 0x8000ffff - Tech Support Guy Forums

try his solution from post #15.
My System SpecsSystem Spec
18 Mar 2010   #6
Foetoid

Windows 7 Ultimate 64-Bit
 
 

Quote   Quote: Originally Posted by stormy13 View Post
This is from someone trying to install a game but getting the same error message,

Solved: error code -5006 : 0x8000ffff - Tech Support Guy Forums

try his solution from post #15.
Thats a great idea but the problem is his idea was for Vista. The Installshield folder for Windows 7 doesn't even HAVE a file called Installshield.
My System SpecsSystem Spec
18 Mar 2010   #7
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

I have a feeling he mis-typed that and it should be folder and not file.
My System SpecsSystem Spec
18 Mar 2010   #8
Foetoid

Windows 7 Ultimate 64-Bit
 
 

Problem Solved!. Someone gave me the idea to use Winrar to extract the driver installer package. Once he said that, i realised i could use device manager to manually update my drivers from that location (skipping Installshield), and bam, working well. I've even got the Realtek HD Audio symbol down the bottom right Thanks for the help guys :)
My System SpecsSystem Spec
Reply

 Driver Error with On-Board Sound. HELP!




Thread Tools




Similar help and support threads
Thread Forum
No sound coming out from on-board sound card.
Hi, I've encountered a problem lately where I couldn't get any audio from my on-board sound card. It just suddenly stopped after I booted it up the other day. I haven't installed any software or drivers that could conflict with the system before that. I have a Gigabyte GA-H81M-DS2 (Rev 3.0)...
Sound & Audio
Why would on-board speakers sound scratchy but headphones sound OK?
Why would speakers sound scratchy, but headphones and external cabled speakers sound OK? I have a Dell Studio 15 (1555) running windows 7 Professional. 236GB used, 214GB free space Intel P8700 2.53 GHz Processor 64 bit OS 4GB memory The built-in speakers used to sound good but now they are...
Sound & Audio
Sound Card replacment for on board audio
I just purchased a New Windows 7 HP Envy computer (#2 in "My System Specs") with on board "Beats" audio. This may work well for some but most of my music is from the 40's through the 70's and Beats audio does a terrible job. The volume constantly changes and the audio will shift from left right...
Sound & Audio
on board sound problem
im trying to install the drivers for my on board sound my mobo is a ASUS P6T Deluxe V2 and it came with a driver cd that has a driver wizard, when i run it the sound driver seems to install and the pc reboots after reboot it says finishing installation then it says not installed. ive tried...
Sound & Audio
built-in sound card in ASUS Mother board
I'm having a lot of problems configuring the built-in sound cards in ASUS Mother Board like P4P800 and other ones, Does any one have a list for every card and the realted mother board.
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App