Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: All USB ports stopped working

24 Mar 2010   #11

Windows 10 Education 64 bit

Try this: Power down your laptop, remove the battery,and unplug the power adapter. Now push the power button for a couple of seconds like you are going to turn it on. Plug everything back in and see if they work. The USB bus has a safety feature where if you overload it, it shuts down. I had it happen to my desktop PC. What actually happens is the +5V is turned off and the only way to reset it is to completely drain the power supply. I had to unplug the PC and try to turn it in to remove all the residual power in the power supply. Just rebooting wouldn't fix it.

If its a driver problem, as a result of windows update, try using the roll back driver option and reboot.

My System SpecsSystem Spec
24 Mar 2010   #12

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by Matto6 View Post
Immediately after the installation they were ok, but since then they've all stopped working.

What have you installed since then ?
My System SpecsSystem Spec
25 Mar 2010   #13

Windows 7

Quote   Quote: Originally Posted by alphanumeric View Post
If its a driver problem, as a result of windows update, try using the roll back driver option and reboot.
What's the roll back driver option? I'm pretty sure that the drivers haven't updated between when the ports were working and when they stopped.

Between the installation and the ports not working, the only thing that I've installed is MS security essentials. The ports have worked with the software installed at first, but have since stopped.
My System SpecsSystem Spec

25 Mar 2010   #14

Windows 7

I've just checked out the roll-back driver option on the internet. I'm currently at work but dont believe the roll back will be an option anyway, because i can't select the device in 'device manager'. This is because its not recognised.
My System SpecsSystem Spec
25 Mar 2010   #15

Windows 10 Education 64 bit

Try it for the actual USB Host Controller not the device plugged into it. It will be grayed out if only the one driver has ever been installed.
My System SpecsSystem Spec
25 Mar 2010   #16

Windows 7 Ultimate 32 Bit, Windows Developer Preview, Linux Mint 9 Gnome 32 Bit

Hey, you can try typing services.msc on Run, this would show your system services. Make sure that the Plug and Play service is enabled. Also make sure that there are no firewalls blocking Plug and Play.

Or you can try looking at your BIOS a little deeper.
My System SpecsSystem Spec
25 Mar 2010   #17

Windows 7

Cheers for the suggestions guys, but sadly nothing has helped. The powering down made no difference, and I wasn't able to use the roll back - simply wasn't able to click the button, so i presume there has only ever been one driver installed. I've also tried running the computer in safe mode, and have the same issues.

Anyone have any thoughts?
My System SpecsSystem Spec
25 Mar 2010   #18

Windows XP - Now Windows 7 Home Premium (64-bit).

Not talking about the devices u plug in but the actual usb controllers themselves: what if u uninstall the usb host controller and the root hub and let windows find them again?
My System SpecsSystem Spec
25 Mar 2010   #19

Win7 Home Premium 64x

The only thing I have not seen in this thread is to check you BIOS for an update. You might need to flash the BIOS since this happened during or after upgrading from Vista to 7, the motherboard might have an update. You can use this program:
Run CPU-Z to see what your motherboard is. Post here what the motherboard is. Also you can google the Mobo name and the Words BIOS to find the latest BIOS updates usually. If none can be found, and if it is from an OEM like HP or Dell etc, call the manufacturer as they probably have seen this issue already (a lot probably).


Caution: Flashing the BIOS is a technical process and if you do this process, please post back here for instructions or walkthrough with doing so. Each type of BIOS has its own process for flashing it.

This is where you should go for drivers. I don't know if they have one for the USB, but they should. an Update for the BIOS might also be in here.Just click on drivers and then select your model.

I would like you to fill in your computer specs so we all know what your system is.
My System SpecsSystem Spec
25 Mar 2010   #20

WIN7 Ultimate 64bit

Did you check to see if you have any driver conflicts?

Is USB turned off in Bios?
Find a USB driver and reinstall it?

Drastic, but try uninstalling "PCI Bus " in Device manager
Reboot, see if Win 7 reinstalls all the drivers in correct order and re_enables USB.
My System SpecsSystem Spec

 All USB ports stopped working

Thread Tools

Similar help and support threads
Thread Forum
Suddenly all USB ports stopped working on win 7
That day suddenly my PC's USB ports stopped working. I tried all USB ports with deferent kinds of drives(pendirve, mobile, modem) but computer is not responding. I tried reinstalling my windows 7 but remains same. I also tried Ubuntu, Mint, Hirens Boot CD etc but no OS finds my any kind of USB...
Hardware & Devices
USB ports stopped working
My computer crashed after doing a backup and the keyboard stopped working so I decided to remove all USBs and reinsert them then all my other USBs stopped working how do I fix this ? And I get error 28 for all my USB drivers
USB ports stopped working right...
Hello guys! This error happens suddenly... All the USB devices and the ports are working, they are activated on the bios, but they don't work when the Windows starts... In the Device Manager it shows an exclamation on USB controllers an says about code 10... If I remove all the devices and...
Hardware & Devices
usb ports have stopped working
usb ports were working fine for my headset and wireless mouse/keyboard receiver just two days ago. today first my headset wouldnt work when i plugged it into the one outlet, then i tried in the other outlet and got no luck, and my wireless reciever wouldnt work after i plugged it back in either....
Hardware & Devices
USB Ports Stopped Working
My ASUS X83VB has 5 USB ports. I have Windows 7 64 Bit, it was a clean install 3 weeks ago. It was working fine until today, I noticed that my Ipod Shuffle wasn't recognized when I plug it into a USB port (Device not successfully installed, Device manager shows a code 43). I tried another USB port,...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App