Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: IDE controller and VGA "unspecified"

12 Apr 2010   #1

windows 7
IDE controller and VGA "unspecified"

I need help whit finishing the driver installation for win7.
Just upgraded from win XP.

And all is good but.

2 devices are unspecified: IDE controller and VGA Compatible driver. Oo

My mother board is Asus p5vd2-x a Graphic Card is FORCE3D
Radeon HD 5670 1GB GDDR5.

Installed the drivers from AsusTek for win Vista but nothing happens.
Cant think of anything else.

I will post a screen shot when i get home from work.

But is there a solution to this? Or is my motherboard totally out of date?

Thanks for the help.

My System SpecsSystem Spec
12 Apr 2010   #2

Microsoft Community Contributor Award Recipient


My System SpecsSystem Spec
12 Apr 2010   #3

windows 7

Tried the AsusTek driver and didnt work.
The graphic card driver i didnt find and will try it out. Thank you.

Is there an other solution for the IDE driver? 4 in 1 Hyperion pro driver from the AsusTek support is not working and windows does not even allow to begin the install.
My System SpecsSystem Spec

12 Apr 2010   #4

win 7 ultimate32bit, Win8.1pro wmc 32bit

Compatibility Mode this link should give you the information to allow yuo to load the IDE driver in XP or Vista compatibility mode , if you have any probs post back :)
My System SpecsSystem Spec
12 Apr 2010   #5
Microsoft MVP

Win 7 Ultimate x64

Asus is notorious for not updating the drivers on their download pages for older products (and sometimes even current ones), even when there is a driver update from the chip manufacturer (motherboard, audio and video). Instead of trying what is available from Asus try the one directly from Via,

VIA Drivers Download - VIA Technologies, Inc.

Just pick your flavor of Windows and the select the VT8237 Integrated from step #4.
My System SpecsSystem Spec
14 Apr 2010   #6

windows 7

Thank you all! Tried it all you said, but they are still there... are they a problem?

these are the 2 items that are unspecified.

IDE controller and VGA "unspecified"-untitled.jpg

What to do?

My System SpecsSystem Spec
14 Apr 2010   #7

WIN7 Ultimate 64bit

Try deleting/uninstall the non-IDE driver in "Device Manager"
Reboot then go on windows update - see if it loads anything.
My System SpecsSystem Spec
15 Apr 2010   #8

Microsoft Community Contributor Award Recipient


Unknown device, have a look here.

Hardware Identification
My System SpecsSystem Spec
19 Mar 2012   #9

windows 7 32bit

i got the same problem,,,
any clue how to fix this???
My System SpecsSystem Spec

 IDE controller and VGA "unspecified"

Thread Tools

Similar help and support threads
Thread Forum
CHKDSK for multiple drives reports "An unspecified error occurred..."
CHKDSK, run either by scheduled during restart, or in Safe Mode Command Line, or from a separate USB boot disk, all show the exact same allegedly "fixed" errors over and over again. They never actually get fixed! Also, on 4 out of 7 different disk drives -- including two Samsung SSDs which "SSD...
Performance & Maintenance
chkdsk - "An unspecified error occurred <6672732e637878>"
I started a chkdsk on a Win7 64bit computer that got stuck at startup repair. Before that though, I was looking around, the damage seems to be the windows files got messed up after an update. My computer data was intact when I looked around booted through a recovery cd and I checked again via a...
Performance & Maintenance
Copying MPEG to new HDD: LENGTH attrib becomes "unspecified" the RHS of the navigation pane (Windows 7 / Windows Explorer) LENGTH is still an attribute of the copied file because DETAIL PANE (at bottom) shows the expected LENGTH value (hh:mm:ss). Could this be related to getting rid of thumbs.db on the 2nd drive (HGST 4TB)? I had thought that 7...
Music, Pictures & Video
"Unspecified Error" from Explorer.exe when I click Personalize
Hi When I right click on the desktop and click Personalize, I get an "Unspecified error" from explorer.exe. I think am having the same problem as I tried the sfc but it found no errors. And no,...
General Discussion
When I press personalize it will show "explorer.exe unspecified error"
Everyone when i press personalize when i right click on the desktop it will show explorer.exe unspecified error.. and in control panel/appearance and personalization the icon "Themes" is gone.HELP!!!:(
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App