Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB drivers not being read

09 May 2010   #1

windows 7
USB drivers not being read

Hi there,

I have a HP media center n7000 with an Intel motherboard. I recently installed windows 7 onto it when it had vista before. My usb ports on 7 can't read any of the devices that plugs into them that includes wireless mouse, keyboard, external HDD's, flash drives and etc etc... but it did in vista

The Intel(R) N10/ICH7 Family USB2 Enhanced Host Controller doesn't seem to be working correctly from what I've figured out.

Uninstalling driver(s) in Device Manager. Reinstalled driver(s)
Rebooting with devices plugged in.
Updated chipset for Motherboard.
Changing out power cords for different voltage effects.
Updated drivers/windows live update
Checked BIOS for usb enabled

I'm not sure what else I can do. So any suggestions would be obliged.

My System SpecsSystem Spec
09 May 2010   #2

Windows 7 Ultimate 64 bit

Hi Shinn,

I had a similar problem on a clients box after I installed a d-link wireless USB device. The problem would go away if I un-installed the device and removed the drivers.

The solution for me may sound a bit weird, but it worked.... On my motherboard there were three ports labelled USB (one of which was labelled front USB), The front usb on the cooler-master case had a few other bells and whistles on it and it turned out that it didn't play well with the official front usb plug on the mobo after I had installed the d-link usb device. So I put the front usb ports on on one of the other mobo ports and rebooted. All of my usb devices could be accessed perfectly after this and the d-link also worked.

Form this scenario I can say to you to try to remove any other usb devices that you have installed drivers for. Reboot and see if your usb ports work. If they do, install your other devices one at a time , maybe you'll find your culprit device that is locking up your usb ports. If all else fails, try to move the front usb to the back mobo port.

Your have probably already checked, but also download the latest drivers for your pc from the manufacturers website, not MSupdate (the manufacturers may have later drivers or the default MS driver may not work correctly).

good luck

My System SpecsSystem Spec
15 May 2010   #3

windows 7

Hmm well I would like to try that but those ports in the mobo don't work either since the back usb ports doesn't work. And your right I did try that. Thanks though Anymore suggestions?
My System SpecsSystem Spec

16 May 2010   #4

Windows 7 Ultimate 64 bit

Quote   Quote: Originally Posted by Shinn View Post
Hmm well I would like to try that but those ports in the mobo don't work either since the back usb ports doesn't work. And your right I did try that. Thanks though Anymore suggestions?
You may be missing my point, it's confusing so let me try again. :)
- Turn your PC off, unplug the power, wait for a minute.
- Unplug all the USB devices from the mobo except the back ports (i.e. just unplug the front chasis ones)
- Boot it
- Check that the drivers are installed are the correct ones from the manufacturers website (NOT MS Update)
- Now check if the back USB ports work. If they do, then we can find out what causes them to stop working when all ports are used. If they still don;t work, repeat the process with only the front ports plugged in. If still nothing than lets move to plan B.

PLAN B Info required:
- You wrote that your PC is an N7000 did you mean M7000? I can't find a link to the N version.
- Do you know what model your intel motherboard it is? (we can then check specific chip information and configurations and widen our troubleshooting search)
- Is it a 32bit or 64bit version of Windows 7 that you installed?

If it's the M7000, unfortunately HP has no Windows 7 drivers on it's website, however I believe that intel does here.

Can you confirm if you have the HP Vista drivers or the Intel Win 7 drivers installed?

Lastly is the Intel(R) N10/ICH7 Family USB2 Enhanced Host Controller controller showing an installation issue in device manager OR an event in event manager to make you think that this is the cause? Or did you select this because it is the most likely scenario... what i'm asking here is if there is any more information other that the obvious to make us think that the USB device is the issue and not some other device causing it to fail. On the support desk I've seen this happen too many times to discount it.

lol... sorry for the novel.
My System SpecsSystem Spec

 USB drivers not being read

Thread Tools

Similar help and support threads
Thread Forum
public tv folder read only? mythtv needs read write persmissions
I tried unchecking read only. When apply and look it is back to read only. How can I make this read and write permission?
Network & Sharing
HP Site can't read my drivers
HP has a link for automatically checking your computer and then updating your drivers. It says it should only take two minutes or so. I hve let it run 3 times and cannot get an answer even after 30 minutes. What can I do?
dvd drive wont read specific disk, will read on other vista computer
hey, my computer generally reads disks, music cd's, dvd's, and games (new like sims 3, and old like theme hospital and shogun total war) ive just got anno 2070 and put in the disk, but its not recognizing it at all, when i first put the disk in, it whirs, as it knows there is a disk there, and a...
Hardware & Devices
dvd drive can't read dvd movie, but can read data dvd or dvd games
hai everyone i've got some problem with my dvd drive, CDDVDW TS-T633P from HP touchsmart 600 1137D my dvd can't read or play dvd movie, i reinstall it few times but it can;t solve the problem ...
Hardware & Devices
Read-only files in My games?why can't I get read-write permission
I've installed fallout but can't get it to run,seemingly because my DOCUMENTS library won't turn off read-only status for My games (or anything else). I've run through ownerships+permissions as best I can but I can't get rid of read-only,which seems VERY odd for a documents folder ;Can anyone...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:43.
Twitter Facebook Google+