Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Razer Lachesis mouse

25 Jul 2009   #21


Quote   Quote: Originally Posted by Tyderion View Post
well ... for me that didn't really work, windows still tells me my driver is version 1.000 instead of 1.10 ...
and firmware update doesn't work ...
any fix for this?

razer-configuration app tells me I use driver v1.1 and firmware v1.00 and I would like to upgrade my firmware...
Both 7 and Vista report the driver version as in device manager and v1.10 in the razer software. it makes no difference whether you install it manually or let WU install it for you

Do you have the razer software installed on another OS ?

I've discovered that if you install and configure the razer software on one OS and then install the software on a second OS, it causes some issues on the original OS.

ie programmed macro buttons work at desktop, but not in games on the original OS installation.

My System SpecsSystem Spec
29 Aug 2009   #22

Windows 7
Fixed the driver issue


If you want your drivers to install you have to do it like this

Go to

C:\Program Files (x86)\Razer\Lachesis\driver64\

and run the DPInst.exe

Make sure the software is installed first

Start the software up and it should recognize it, if not restart it again.

You can also verify under the Device Manager>Human Interface Devices for Lachesis Mouse.

*Note, I always run my firmware upgrades on an XP laptop. I have never been able to update any Razer product on Windows 7 and most of the times Vista x64.
My System SpecsSystem Spec
29 Aug 2009   #23

My Problem

My problem is simple that the programmable keys of my RAZER LACHESIS are not working in any game. Although they do work fine in notepad, which is a way to check the keys or whatever.

I tried it in Warcraft III, garena and Call of Duty 4.

Please please I need assistance asap. And im using Vista 32-bit.
My System SpecsSystem Spec

29 Aug 2009   #24

win7 7100

I am also having problems with my cursor jumping. I haven't played any games with it yet. The cursor jumps to the top of the screen at odd times. It happened in Vista 32 as well.
My System SpecsSystem Spec
30 Aug 2009   #25

windows 7

I don't want to help microsoft but i want to help razer cause i'm impressed from her products.I have lachesis too.When i bought it i had windows 7 7100 and drivers installed almost 100% correct (I had/have some minor problems with windows & razer sensetivity working together) i accomlished the firmware update too.When i formated & installed newer build i had the same prob with u.If i remember right u have to unistall hid-compiliant mouse from device manager and install razer but you have to do it with keyboard -don't forget to uninstall previous razer drivers-.
Just to know how much time to wait:
Razer & Windows 7 | Razer - Windows 7 Updates
My System SpecsSystem Spec
26 Oct 2009   #26

Windows 7 Professional x64

Check that link up above in the post. That will probably solve the firmware/detection issue (When it releases)

But I have a different problem aswell as this (I posted it in another thread)
Razer Lycosa and Lachesis + Windows 7

(Sorry about the multi/diversion post, just I noticed I wasn't getting a reply any time soon)

Also, try blowing on the lense, sometimes that works, mine captures some dust sometimes; your mousemat also might be the problem too: that or acceleration in the firmware menu.
My System SpecsSystem Spec
30 Oct 2009   #27

yup the windows update lachesis driver works

i installed the driver and its 1.10 but the firmware is 1.0 i know my firmware is 1.91 but its not detected.. i was reading in another razer forum and sumone said to update it then bam the firmware is back to 1.91 and the macro keys are back woot!!!
My System SpecsSystem Spec
20 Mar 2010   #28

Win 7 x64


If you want your drivers to install you have to do it like this

Go to

C:\Program Files (x86)\Razer\Lachesis\driver64\

and run the DPInst.exe

Make sure the software is installed first

Start the software up and it should recognize it, if not restart it again.

You can also verify under the Device Manager>Human Interface Devices for Lachesis Mouse.

I just have to say YOU ARE GOD !!!!!

Thank you very much for help :-D I have been stuck in 6 month about "no mouse detected" when i was using razer software.
My System SpecsSystem Spec
30 Apr 2010   #29

Windows 7 x64
Windows Vista and 7 driver installation - not simple?

I had the same problem as others here. My mouse didn't jump to the top of the screen but it was clearly flaky. The mouse appears to work on computer restart/power recycle or if I unplug and plug in the lachesis. But the problem eventually manifests itself clearly showing symptoms of jumping.

Its as if the hardware interrupts that the mouse generated were deliberately given a delay of milliseconds. But enough to cause you to miss pointing exactly where you want to.

Anyway, I played with motherboard BIOS settings and then tried to update the firmware. Razor still does not have Windows 7 64bit support for firmware installation no matter what they say on the website. It simply does not work regardless of which OS compatibility mode you try (or the recommended one from Windows 7 which is XP SP2). Having read of some users having issues with updating the firmware on another machine and having problems when plugging in the mouse again on the Win7 x64 machine, I decided against doing this step. My firmware is still 1.91 even though there is a later version out.

So drivers stand at 1.10. I also had the drivers details report that it is version 1.00 regardless of what I do to them. Anyway, I had to do what some users here suggested. Go into device manager and uninstall anything that looked like it might be related to the Lachesis mice (including HID compliant devices indicating they were Lachesis related). I even uninstalled the PS/2 mice that my system thinks it had (although this re-installed itself on restart).

At the end of the day, the driver properly installed itself. I am not sure where it got the driver from although I did install Razorware initially. So it either found the Razorware drivers for Lachesis and properly installed it this time or used some Microsoft certified drivers (Windows 7 comes with a lot of ready certified drivers which Microsoft tests/certifies).

Now my mouse is no longer playing up. It is clearly a driver installation issue and Razor's device driver routine is making too many assumptions about how clean my machine is or is not doing checks to ensure all the registry keys, files, etc are properly registered.

I had a similar problem with Apple iTunes not too long ago in Windows Vista Ultimate (32bit) where it continually fails to recognise the Apple iPhone and I had to do a lot of things manually to get it to work. I could repeat the problem on another machine as well. Apple eventually fixed the problem in subsequent iTunes releases.

To the software developers creating Installshield/Wise software packages that install hardware device drivers - Vista and Win7 driver installation is not as straightforward as the books may lead you to believe. I think the real world has more than just cleanly built machines and you need to ensure your driver installation processes cleanup, check, install, check again and cleanup again where necessary to get the drivers to install.
My System SpecsSystem Spec
31 Jul 2010   #30

Windows 7 x64
3 months on...

3 months ago to the previous post, Lachesis drivers are installed and things are going smoothly. Then a month later, Microsoft update installs and bang, the whole deja vu thing happens. The mouse jumps and everything goes to chaos again.

Repeated the same steps and things are normal again. Until the following month's Microsoft patch Tuesday.

What I figured from all of this is that Lachesis drivers may not be 100% Microsoft Certified. Not only is the installation routine from Razor flawed, the drivers sometimes lose themselves from usually quality Microsoft patches these days.

Today, I went out and bought myself a Logitech Gaming Mouse G500. No drivers required. Plugged in and while I don't have the macro capability of the Lachesis (Logitech invites me to download and install their SetPoint software to accomplish the same), the mouse is a high DPI, highly accurate tracking device as soon as its plugged in.

Lesson for the day? Logitech (and probably Microsoft) has the right architecture when it comes to mice technology. Don't fiddle with the USB drivers provided by Microsoft but just build on top of the field tested drivers with macro software that doesn't break the basic functionality of the mouse.

I'm one happy convert. Goodbye Razor.
My System SpecsSystem Spec

 Razer Lachesis mouse

Thread Tools

Similar help and support threads
Thread Forum
Updated Razer Synapse, now Keyboard and Mouse will not function.
Hey, So I just updated Razer Synapse on my desktop PC once it was complete I lost the ability to use my Naga mouse and keyboard (not Razer). I pressed the power button and my PC immediately shut down, which I thought was a little odd since I did not hold the power button....Anyways I restarted the...
Hardware & Devices
Razer Lycosa and Lachesis + Windows 7
Greetings. Ive got a problem with my Razer mouse and keyboard. Ive just downloaded Windows 7 compatible driver but it doesnt work for me at all. If i tryed to change dpi on my mouse it wrote me that no usb mouse found. It seems that driver for USB doesnt support this configurators. It seems that...
Razer Lachesis Middle button problem
Hi, I have a Razer Lachesis 4000 that i bought one year ago. I started having a very, very annoying problem. The middle button sometimes won't work, the clicking at least, the scrolling works just fine. It's like, i press the link five times and it won't open, so i try again ten more times...
Hardware & Devices
Razer Lachesis 1.91 driver
I am having trouble upgrading my razer Lachesis mouse driver I have the latest driver (1.10) but I have the old firmware installed (1.64) and I downloaded the upgrade and try to install it but it keep failing I took off driver signature protection when i started up and try to install it again but...
Razer death adder + lachesis
I have both these mice and currently running windows 7 build 7600. anyways i can get both mice to work in windows although while in a game (warcraft 3) neither games let the side buttons work. the side buttons work to what i program them to in windows but when i start war3 the buttons dont work...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:05.
Twitter Facebook Google+