Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Marvell SATA-III 6Gb driver failure under Win7 64bit

09 Feb 2011   #11
soundlover

Windows 7 Ultimate x64
 
 
sata 3 and gigabyte

I have a GA-X58A-UD5 motherboard. Installed everything from the disc that came with it but after seeing this thread I checked and the sata 3 controller was not installed. I installed the new one from Asus. I have a crucial ssd sata 3 and now in device manager its shown as: SCSI Disc Device. Is this normal for a sata 3 disc?

Before I think it was ata instead. I used to have the eject option in the notification area, just like anything you insert that is usb.

Also how can I test its speed?

I contacted gigabyte but they were not helpful. Hope someone can help me and thank you for your patience.


My System SpecsSystem Spec
.
09 Feb 2011   #12
tw33k

Windows 7 Ultimate (x64) SP1
 
 

It is normal. Download and run ATTO and post a snip of your results
My System SpecsSystem Spec
09 Feb 2011   #13
GeneO

Windows 10 Pro. EFI boot partition, full EFI boot
 
 

Get the 1051 drivers from here if you want the latest WHQL (in use on my Ausus board):

Marvell drivers
My System SpecsSystem Spec
.

09 Feb 2011   #14
soundlover

Windows 7 Ultimate x64
 
 

Screenshot posted.


Attached Thumbnails
Marvell SATA-III 6Gb driver failure under Win7 64bit-atto_screenshot.jpg  
My System SpecsSystem Spec
09 Feb 2011   #15
tw33k

Windows 7 Ultimate (x64) SP1
 
 

Your drive is performing great! Is it a 128GB C300?
My System SpecsSystem Spec
09 Feb 2011   #16
soundlover

Windows 7 Ultimate x64
 
 

Thank you very much both. Spent a lot of money on the ssd and did not want it to be wasted.
Updated controller driver from 1042 to 1051 just now.
My System SpecsSystem Spec
09 Feb 2011   #17
soundlover

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by tw33k View Post
Your drive is performing great! Is it a 128GB C300?
Yes.
My System SpecsSystem Spec
13 Apr 2011   #18
kingmortz

Windows 7 Ultimate x64
 
 

I've read the entire thread and my problem lies very close to this. Therefore, I decided to continue on this thread.

I am having trouble installing Win 7 Ultimate x64 on my new Intel 510 SSD drive connected to the Marvell controller (on my Asus board) in AHCI mode.
Mind you, Windows installed fine on the 510 when Marvell was in IDE mode.
I am usually able to get to the HDD selection-screen, and here I see the Intel 510 drive just fine. Then, I load the Marvell 912x Controller Driver V1.0.0.1036 (downloaded from asus.com - where I made sure to select Win 7 64-bit). I also tried the 1.0.0.1051 version - downloaded from some other place.

During the subsequent installation, the setup crashes/hangs at various times. And nothing more happens.
One time I managed to get into Windows after the installation but after one more reboot, that was the last I saw of the Desktop.

I read a guide on how to switch to AHCI controller-mode after having done the installation in IDE mode.
The guide (How to enable AHCI in Windows 7 RC after installation | iThinkDifferent), along with several other guides, talks about modifying the "msahci" entry to value "0" under
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\

This results in the same hang-situation during boot-up - after the switch to AHCI has been done in the BIOS.

Side-notes: Have run Memtest on the RAM for over 12 hours with no errors (also, the system has run stable as heck the past six months on a regular HDD on the exact same Marvell port).

I sooo need your suggestions! I find it so frustrating that I cannot enjoy my new and blazing fast hardware with the optimal settings.
My System SpecsSystem Spec
16 Apr 2011   #19
soundlover

Windows 7 Ultimate x64
 
 

First change to AHCI mode from Bios, then install Windows 7. After installation install the marvell driver version 1.0.0.1051.
I am using Windows 7 64bit too but on Gigabyte motherboard.
My System SpecsSystem Spec
18 Apr 2011   #20
kingmortz

Windows 7 Ultimate x64
 
 

Thank you for the tip Soundlover. The problem is that I practically never make it through the entire installation of Windows before the setup hangs - this only being a problem when installing in AHCI mode.

In the attempt to adhere to proper forum conduct, I'd probably better refer all invested readers to this new thread on the subject here:
AHCI-mode on Marvell 9128 controller in Windows 7 Ultimate x64
My System SpecsSystem Spec
Reply

 Marvell SATA-III 6Gb driver failure under Win7 64bit




Thread Tools




Similar help and support threads
Thread Forum
Ga-Z87X-UD3H & Marvell SATA Driver
I have a Gigabyte GA-Z87X-UD3H motherboard and I am not using RAID, just a single drive in the Intel SATA port. Do I still need to install the Marvell Driver for the Marvell SATA ports if I am not using them. Thanks
Drivers
Marvell Rolls Out New SATA 6Gbps Controller for SSDs
Read more at: http://www.maximumpc.com/article/news/marvell_rolls_out_new_sata_6gbps_controller_ssds
News
Marvell 9128 Sata 3.0 [6Gb/s] manifesting as IDE
Good evening- I've been working these last few days on some recent upgrades to my GA-790FXTA-UD5 system, and I have found some puzzling issues. I did my original install of Win7-64 ultimate last year using the AHCI drivers from the beginning in order to get the extra speed at startup etc. ...
Hardware & Devices
Marvell Raid 0 Driver Problem on SATA III 6Gb on 64 bit install
I have recently bought 2 1Tb Western Digital SATA III 6 Gb HDDs. The idea being, that I would Install Windows 7 Ultimate 64 bit via the onboard Marvell controller in Raid 0. I have not even got past the Collecting Information part of install, because no matter what Driver I try to load, Windows...
Drivers
digital sign driver for Marvell 88SX6081 windows 7 64bit
hello, i have asus board with Marvell 88SX6081 chip.it is sata chip. i have w7 64bit. i contacted marvell for w7 64bit driver. they sent me to asus.asus sent me to marvell.finally nobody helped me. i bought code signing certificate from ascertia for 17usd. first i used inf2cat to make...
Drivers
Marvell 61XX 64bit sata driver don't work (Asus P5Q)
Just an FYI; Had to reinstall win 7 pro 64bit due to said Marvell sata 'DriveXpert' drivers not really working at all well. They *should* work according to Asus and they also *seem to work at first, but within hours of initial installation there were odd slowdowns, vanishing of drives in...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App