Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Marvell SATA-III 6Gb driver failure under Win7 64bit

21 Apr 2011   #21

Windows 7 Professional 64 bit

Quote   Quote: Originally Posted by PatMac View Post
On my Gigabyte Motherboard x58a ud3r v2 the Marvell 9128 6Gb/s needs to beenabled in BIOS prior to attempting to load an operating system. There is also a BIOS setting to go in and configure the raid configuration. Then once that is saved to BIOS the computer reboots and the Win 6 64 bit operating system detects the drive or drives depending on whether you have used Raid 0 or Raid 1. It is also possible to load the 64-bit marvell driver from a USB drive prior to installing win 7 but I'm not convinced that is absolutely necessary. But the first step of enabling the BIOS and configuring the raid configuration is definitely needed on my board. I don't know if that is any help. First post. Also on my motherboard you must plug the Sata connectors to Sata 6 and 7 as they are the only ones that support Sata3.
Yup I believe it's the same thing with the Asus board I'm running...was the the first thing came into my head after reading the thread heading and the 1st post..has he got it enabled in the Bios??

My System SpecsSystem Spec
11 Dec 2012   #22

Windows 7 Ultimate
Still not working

Hi Sanvean - hope you see this so much later! I tried to take your advice about using the Marvell driver software for Windows7 installation, however, I am trying to use it with 2 SSDs on the Marvel SATAIII ports configured in RAID0. On the Intel SATAII ports I have futher disks installed.

My Mobo is Asus Rampage III Black Edition, with the Marvell BIOS 1.0.0022.

When I have Marvell operating in RAID mode, I get a RAID configuration utility (ctrl/M) at Marvell's POST screen upon booting, but the POST screen for the Intel SATA II ports doesn't even show up. If I have Marvel operating in AHCI mode, I get Marvel's post screen AND the following SATA II POST screen at boot up but of course in this case I cannot configure any raid Volumes on the drives attached to the Marvell ports.

When I configure a RAID vol on the disks on Marvell's SATAIII ports and then try to install Win7, Win7 immediately says it is missing a driver (it's like it cannot even see that the disks on the SATAII ports are there - this is not necessarilly a problem for me bcs I don't want to install Win7 on the SATAII ports anyway). Win7 then lets me browse to the USB or floppy (I tried both) containing the files from the 'Floppy64' directory you mentioned before, but Win7 at first shows me no drivers at all. If I unclick 'Hide uncompatible drivers' it does show me all the drivers, but Win7 will not accept any of them - it says 'no new device found'.

When I wipe the RAID volume and boot up with Marvel's SATAII ports in AHCI mode, Win7 does in fact see ALL the disks at the start of installation (even the ones on SATAII ports). Also, it allows me to install the Marvell driver from the floppy. However, I don't understand the sense of this: firstly, it lets me install on non-Raid volumes on Marvell's SATA III ports even if I DO NOT install Marvell's drivers, so what is the use? I think the point of using the Marvell driver is to allow Win7 to see the RAID volume and it's useless if Win7 can only use the Marvell driver if Marvell is NOT using RAID...
My System SpecsSystem Spec

 Marvell SATA-III 6Gb driver failure under Win7 64bit

Thread Tools

Similar help and support threads
Thread Forum
Sata mode/Marvell ATA?.
Hi me again sorry. Any way been having problems with PC and been formatting in every way I can. My bios sata mode selection is in ahci and also marvell ata controller is in achi. Today I formatted in sata mode selection and Marvell in RAID. Then installed windows as normal. I didn't set anything...
Hardware & Devices
Ga-Z87X-UD3H & Marvell SATA Driver
I have a Gigabyte GA-Z87X-UD3H motherboard and I am not using RAID, just a single drive in the Intel SATA port. Do I still need to install the Marvell Driver for the Marvell SATA ports if I am not using them. Thanks
Marvell Raid 0 Driver Problem on SATA III 6Gb on 64 bit install
I have recently bought 2 1Tb Western Digital SATA III 6 Gb HDDs. The idea being, that I would Install Windows 7 Ultimate 64 bit via the onboard Marvell controller in Raid 0. I have not even got past the Collecting Information part of install, because no matter what Driver I try to load, Windows...
digital sign driver for Marvell 88SX6081 windows 7 64bit
hello, i have asus board with Marvell 88SX6081 is sata chip. i have w7 64bit. i contacted marvell for w7 64bit driver. they sent me to asus.asus sent me to marvell.finally nobody helped me. i bought code signing certificate from ascertia for 17usd. first i used inf2cat to make...
Marvell 61XX 64bit sata driver don't work (Asus P5Q)
Just an FYI; Had to reinstall win 7 pro 64bit due to said Marvell sata 'DriveXpert' drivers not really working at all well. They *should* work according to Asus and they also *seem to work at first, but within hours of initial installation there were odd slowdowns, vanishing of drives in...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:24.
Twitter Facebook Google+