Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: rtl8191su - Windows Update'd, now broken

14 Jun 2010   #1
kallsop

Windows 7
 
 
rtl8191su - Windows Update'd, now broken

Clean install of Windows 7 Home Premium 64 bit. Found and installed a driver for my rtl8191su USB-WiFi adapter at the Realtek site. Went to Windows Update and let it update everything over the WiFi connection. One of the updates was a rtl8191su driver. After that installed the WiFi lost connection and the driver wasn't loaded. Now it complains that there is no driver for the "rtl8191su Selective Suspend Enabler". Uninstalling the device in Control Panel and scanning hardware gets me right back to having no loaded driver. Manually trying to install the Realtek driver won't work, it says there is nothing that matches the hardware. What a complete crock!!!!!!!!!!!!!!! It was working fine before the Windows Update. In the Control Panel for this device, "Rollback driver" is grayed out. So as well as putting in a useless broken driver, Windows Update didn't save the previous working configuration. Nice.

Anyone got any ideas how to back out the updated driver and get this working again?


My System SpecsSystem Spec
.
15 Jun 2010   #2
jessef

Windows 7
 
 

I have the same problem. I have a Zonet ZEW2546 wireless N usb adapter and when I installed this update it stopped working. Doesn't show up as a network device. Tried the same steps as you and can't get it to work.
My System SpecsSystem Spec
21 Jun 2010   #3
wushigung

fedora and 7
 
 
fix for widows update - Selective Suspend Enabler

I too had this MS malfunction so realizing that the data/driver information keeps coming back, I used an ubuntu live cd to allow me to delete the files that are protected by windows. In windows you could icacls but that is too much hassle.

1st, look at your update history and try to find;
Realtek - Network - Realtek RTL8191SU Selective Suspend Enabler

Installation date: ‎6/‎11/‎2010 11:34 PM << remember this date >>

once booted in linux, the PLACEs to go is the drive with your win7, the the windows\system32\DriverStore\FileRepository

Once there change to list view and sort by date, delete the Folder(s) of this titled suspend enabler or go by date alone.

2nd place is C:\Windows\inf

Do the same as before. give linux the restart command and windows will restart. You may still need to reinstall awll6075 driver and utility but see what happens, then reinstall the driver/utility if necessary.

Enjoy now for 4 hours no problem!
My System SpecsSystem Spec
.

02 Jul 2010   #4
oneklema

Windows 7 64 bit
 
 

I have had the same problem with an airlink 101 wireless N adapter. I had some success by going into device manager and disabling the selective suspend enabler device the reboot. The, I re-installed the driver software that came with the airlink 101. Sometimes this seemed to work, others it did not. Not sure why. Once I got it to work, I did an windows update again (looks like disabling the device causes the update to appear again) and set the selective suspend update that caused the problem to be ignored by windows update.
My System SpecsSystem Spec
04 Jul 2010   #5
wushigung

fedora and 7
 
 
Get rid of bad drivers

The USB selective suspend will keep popping back in unless you rid yourself of the INF's associated. Editing the registry also will help prevent it. On windows update, change settings to notify and look at the updates. Find the BAD ones, right click to hide them. Also there are settings to not allow windows update to install drivers automatically. Recommend to set accordingly.

Two weeks and no failures since I did these steps. Using Linux boot disk to purge the driver stores is 100% insurance if also applied.
My System SpecsSystem Spec
Reply

 rtl8191su - Windows Update'd, now broken




Thread Tools




Similar help and support threads
Thread Forum
broken VM's after Windows update?
It seems that my VM's won't work anymore. Using Windows virtual pc and virtual box. Anyone else having the same problem?
Virtualization
Windows Update broken on my laptop
3 possibly related problems. I tried doing a Win10 upgrade on my laptop using the Media Creation tool. It hung during the "Checking for Updates" phase. I canceled the update and it hung in the cleanup phase. I eventually rebooted. Win7 seems to be ok ... except ... I noticed that we have...
Windows Updates & Activation
Windows Update broken after installing SP1
Hey guys So after preforming fresh OS install did the drivers and then went to Windows Updates,the updates came out fast installed the first wave very smoothly then when reaching SP1 and installing it the Windows Updates was stuck on "searching for updates",did another OS install but this time...
Windows Updates & Activation
Windows update broken, svchost at max CPU
My Windows 7 update is just broken somehow. Whenever I try to manually update, I always end up with a svchost with 50% cpu usage (i.e., one core maxed out) and nothing ever finishes. It just sits there saying "Checking for updates". I've tried a number of solutions on the web - manual...
Windows Updates & Activation
Failed Windows update + broken dll
Hello! I have noticed my windows update queue gets longer and longer each time a new update comes out. it seems like the new updates won't get installed even when I manually try to install one at the time. Each time after start up all the updates are there ready to be installed. I tried running...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App