Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Fujitsu ScanSnap S510 and Windows 7 RC 64bit

08 May 2009   #1

Windows 7RC
Fujitsu ScanSnap S510 and Windows 7 RC 64bit

Anyone have any luck with a Fujitsu Scansnap S510 under Windows 7 RC 64 bit? I have the Vista 64 bit drivers which worked just fine under Vista, but I can't get the Scan Manager package to install at all under Windows 7 RC 64. Any thoughts or comments appreciated!


My System SpecsSystem Spec
08 May 2009   #2

Windows 7 Ultmate 32 bit 6.1.7600 Build 7600

Hi jlehett,
So far i do not have an answer for your driver issue. However, worst case, feel free to call them and see if they have beta Windows 7 64 bit drivers you could test for them. Assuming they have decided to carry this product to Windows 7.
(800) 626-4686, option 2 for assistance between the hours of 5:00 a.m. - 5:00 p.m. PST Monday through Friday.

UPDATE: I just spoke with them via chat client. They said they do not have any and have no info on the development of these drivers. Sorry.
My System SpecsSystem Spec
23 May 2009   #3

Windows 7 RC

After some tinkering i was able to get my Scansnap S510 to work under the windows 7 RC x64 and thought it would be helpful to share some results.

First, as you point out, you need the ScanSnap Vista x64 drivers .... available with some pleading from Fujitsu tech support.

After installing Scansnap Manager, I looked at the device properties, and it seems the problem is linked to the fact that the Vista drivers are not authenticode signed (seriously Fujitsu, is it amateur hour over there?)

I took two approaches, some combination of which worked for me...
1) I used a tool called the Driver Signature Enforcement overrider, from a site called that puts Win7 into 'test mode'

2) In the C:\Program Files (x86)\PFU\ScanSnap\Driver\SsDrvRepair folder, there is a tool called SsDrvRepair-x64.exe, that I ran. It pops up a big red warning against installing unsigned drivers, i install anyway.

And it works!

Not sure if I had to do step 1 or not. but it seems to me that the Vista x64 drivers would have been fine if they were signed by Fujitsu.

Good luck
My System SpecsSystem Spec

01 Jun 2009   #4

Win7RC 64bit

can u please share the x64 driver - i dont get the scanner to run.

thx a lot.
My System SpecsSystem Spec
21 Jun 2009   #5

Windows 7 RC
Step 2 works

I only needed to do Step 2 to fix my same problem.

To get the Vista 64-bit Fujistsu S510 drivers, go to:

ScanSnap Driver Download : FUJITSU

I did a Windows 7 upgrade from Windows Vista. I had my S510 working before I did the upgrade, so I don't know if a new install would work.

BTW, you also need to do the new Sharepoint connect patch too since this crashes on startup.
My System SpecsSystem Spec
01 Jul 2009   #6


Thanks to everyone that posted helpful info to this thread. I am using Win7 RC x64 and have a Scansnap S510 that I was unable to get working. This being a fresh installation, I couldn't get the Vista 64 drivers to install (gave an error about the environment being incorrect) and I think that's because no version of Scan Manager I tried would install, so no version was available for the update package to update.

Searching the web, I found another site that has a link to Scan Manager x64 installation CD for the Scansnap S300, which was claimed to work perfectly for the S510. I was able to install this, but trying to use the scanner resulted in Win7 telling me that the device could not be installed. At that point, I used the driver repair tool pointed out by vud2001 above and now I'm up and running.

The site I found that has the S300 installation package is
and is definitely worth a read.
My System SpecsSystem Spec
21 Aug 2009   #7

Windows 7 Enterprise

Fresh Install of Windows 7 Enterprise
Fresh Install of ScanSnap S510 Manager 4.2
Double Click "SsDrvRepair-x64"
in the x:\Program Files (x86)\PFU\ScanSnap\Driver\SsDrvRepair Folder
Accept Warning about installing driver
ScanSnap now works

I believe all you need to do is run the "SsDrvRepair-x64" and that fixes everything.

My System SpecsSystem Spec
12 Sep 2009   #8

Windows 7

Thanks to all for your help here especially vud2001 and Woorldzulu. I spoke with Fujitsu Tech Support and they were clueless on this issue. I hope (but I doubt) they will read this post.
My System SpecsSystem Spec
29 Sep 2009   #9

Windows 7
Fujitsu ScanSnap S500 and Windows 7 - 64 bit

I recently moved from Vista Ultimate to Windows 7 Ultimate 64 bit. As a result my ScanSnap 500 was out of commission. Fujitsu was no help as usual. I went through similar hassles back when Vista was released.

My fix was two-fold but I'm up and running.

#1. I followed TechGuy's post to get the S300 64 bit installation software.

(After the software install, and plugging in the scanner, of course it didn't work.)

#2. After installing the software I also had to run the driver repair tool suggested in the previous post by vud2001. Here it is: In the C:\Program Files (x86)\PFU\ScanSnap\Driver\SsDrvRepair folder, there is a tool called SsDrvRepair-x64.exe, that I ran. It pops up a big red warning against installing unsigned drivers, i install anyway.

Shazaaam! It worked. The funny thing is, the S300 software interface is a little different than the S500 software. Personally, I like it better. Finally, I don't know why, but the scan quality seems much better. I might be imagining things but it sure looks cleaner. I'm just pleased to be up and running again.
Thanks to everyone for their posts.
My System SpecsSystem Spec
24 Oct 2009   #10

Windows 7


My fi-5110EOX2 has the same 64 bit issues. I just installed Windows 7 64 bit and couldn’t make it work. I followed the link to off of Cartoon Monkey’s website. After an install and a reboot, the software worked. I then had to go into “Devices and Printers” in Windows and then manually direct it to load a driver.

All I can say is OMG! Thank you so much for your help!!! The link referenced above by Cartoon Monkey and I found the site pretty good for dealing with this issue.
My System SpecsSystem Spec

 Fujitsu ScanSnap S510 and Windows 7 RC 64bit

Thread Tools

Similar help and support threads
Thread Forum
Lifebook from Fujitsu without Windows 7
Hello everybody, Where can I get a Windows 7 version for my Lifebook and what does it cost? greeting Tabarka
Installation & Setup
Can't update firmware on ADATA S510 SSD
I have an ADATA S510 120gig SSD, i tried downloading the Firmware upgrade tool seen on this page S510 SATA 6Gb/s Solid State Drive, Download, S510, 500 Series, Solid State Drive, Welcome to ADATA I opened the tool and it didnt find my SSD drive. I then downloaded the file itself to try and...
Hardware & Devices
Fujitsu s510
Has anyone had success downloading the Fujitsu s510 scanner software and actually loading it onto a new computer with 7 ? Don't think they could make it more complicated or I just don't get it. Would appreciate any imput
Fujitsu Scansnap S510M
I know it's a Mac scanner, but I'm wondering if anyone ever made a Windows driver for the S510M. Any help would be appreciated.
Any luck with ScanSnap s510?
Due to the "version checking" portion of the Vista drivers for the ScanSnap it will not allow an install of the software even running in Vista compatibility mode and I have been unable to find Win7 64 bit drivers for it. Customer support there is awful at best. So is there a way to trick the...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:22.
Twitter Facebook Google+