Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problems with my NIC

01 Jul 2010   #1
NoobtoWindows

WIN7
 
 
Problems with my NIC

Hey Guys,
I tried to search my problem all over the internet but still couldn't find a solution..
OS: Window 7 64bit home edition
NIC: Linksys Wireless-n PCI adapter WMP300N
NIC Driver Version : 4.176.75.21 ( When I try to do update driver, it will update to 5.30.21.0. After its done, the NIC doesnt work anymore)
Router: TP-Link TL-WR941ND

So, I've been having issues with my NIC since the day I got my computer..
Often My speed drops from 270mbps to 5.5mbps and ping spikes to 2000+ for a period of time..

is there really anything I can do since there is no updated driver for my NIC?


My System SpecsSystem Spec
.
01 Jul 2010   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by NoobtoWindows View Post
Hey Guys,
I tried to search my problem all over the internet but still couldn't find a solution..
OS: Window 7 64bit home edition
NIC: Linksys Wireless-n PCI adapter WMP300N
NIC Driver Version : 4.176.75.21 ( When I try to do update driver, it will update to 5.30.21.0. After its done, the NIC doesnt work anymore)
Router: TP-Link TL-WR941ND

So, I've been having issues with my NIC since the day I got my computer..
Often My speed drops from 270mbps to 5.5mbps and ping spikes to 2000+ for a period of time..

is there really anything I can do since there is no updated driver for my NIC?
Have you looked at the driver in device manager? Type device manager in search>go to the networking tab. Is you device there? does it have a yellow triangle on it? Is there any "unknown" devices?

You can use the vista driver (if exists) by installing in compatibility mode

ken
My System SpecsSystem Spec
02 Jul 2010   #3
NoobtoWindows

WIN7
 
 

Yea I looked..It says working fine, and power is set to on..
I cant find any compatible driver for it too =(

weird part to this situation is that my other two computers don't act like this one..

Does anyone know what can I check in netstat or something..
or some settings that screws it over?
could it be the other two computers sucking most ofthe bandwidth from it??
thanks
My System SpecsSystem Spec
.

Reply

 Problems with my NIC




Thread Tools




Similar help and support threads
Thread Forum
Many problems with video errors and somehow RAM problems
Okay so for a while now i have been having many problems. First off i had a PC with the video card i am using right now(Nvidia GTX 295), and it has been "losing signal" and just plain old crashing. So i bought a PC off my uncle. Its got reletivly good hardware, but i am still getting the same...
General Discussion
USB Problems, Errors and port problems!
I have a Dell Inspiron 1545 laptop, not to long ago I had to replace my hard drive. After that I reinstalled windows 7. Before this the usb devices would charge just not be recognized. Now only ONE port does everything (charge, sync, etc.) the other two just stopped working. I have no clue if its a...
Hardware & Devices
Can't start up my computer. (Driver problems, BSOD, other problems)
Hi I hope I'm placing this in the right section, if not, then could someone tell me where to put it and I'll post it again. I've got a Samsung RV510 laptop with Windows 7 HP 64 bit. About 2 weeks ago, I was watching a Youtube video, had Spotify and Facebook open too, and my computer...
BSOD Help and Support
extract problems, random BSOD errors all those problems
hi guys i dunno why i have many problems with win7 since installation and so far btw i wrote many topics before about my installation and eventually i didn't found any solution so i took my pc to computer shop and they solve the problem after that i installed win7 without any problems...
BSOD Help and Support
Windows Index Problems a.k.a Windows Assesment Problems
Hi, I have had Windows 7 for a while now and have continually tried to run windows assesment tool for a while now, but each time I run it, it always ends up having a problem when it starts "Tuning Windows Media Decoding" and ends up closing. This is not terribly important but I was just wondering...
Performance & Maintenance
Problems leading to problems...
Hello, I am new to the forum, and I am hoping someone can help me out. I am attempting to install Win 7RC 64 bit on my system and seem to run into another problem as soon as I solve one. I am now at a problem that has me at a loss. Bear with me as I outline what I have done so far. I had...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App