Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bluescreen with RAID

12 May 2009   #1

Windows 7 RC1
Bluescreen with RAID

Hello everyone,

Currently I'm running the RC1. I just got two additional hard-drives to throw into a raid configuration which I set up properly within the bios (worked in XP).

The trouble is when I boot it makes it out of the BIOS and into the Starting Windows Screen. Windows bluescreens at that point. It only bluescreens when I have the RAID option enabled in my bios. I imagine that there aren't drivers for the controller?

The motherboard is a

It uses the intel ich9 controller (which is showing up in my device manager)

When I go to intel's website to install their matrix controller drivers, I get this error: this computer does not meet the minimum requirements for installing this software.

Any help would be great!


My System SpecsSystem Spec
12 May 2009   #2


I presume that you didn't have this set up in a raid configuration before adding the 2 drives? I think the easiest way for you to resolve this would be to try a repair of Win 7 or even better a fresh install. Even if you try to add the raid drivers from within Win 7, they may not install due to the raid not being enabled in the bios......I could be wrong though.
My System SpecsSystem Spec
12 May 2009   #3

Windows 7 RC1

Unfortunately I didn't get the drives until after I had 7 so definitely post 7-install RAID.

I would really like to do a repair, but intel, as far as I can tell, doesn't have any drivers listed for Windows 7 concerning that chipset.
My System SpecsSystem Spec

12 May 2009   #4


Have you tried the sata raid drivers from Gigabyte's website:

GIGABYTE - Support&Download - Motherboard - Driver - GA-G33M-DS2R
My System SpecsSystem Spec
12 May 2009   #5

Windows 7 RC1

I loaded the gigabyte drivers on a usb drive, but I couldn't find a windows 7 version. I tried to make due with vista x64 but during the load driver phase in the repair option of windows 7 the installation fails (just basically says, installation failed). The drivers totally have the proper 'ich9R' data... but not for 7? Should vista x64 drivers work with 7?
My System SpecsSystem Spec
12 May 2009   #6


Vista drivers are not 100% guaranteed to work with Win 7, it's a case of try it and see. If you are unable to get them installed, I would suggest you try a clean install. Other than that contact Gigabyte and see if they have any beta drivers for Win 7.
My System SpecsSystem Spec

 Bluescreen with RAID

Thread Tools

Similar help and support threads
Thread Forum
RAID - deleted RAID array, Windows 7 ok but I have questions
Hi all, My RAID 1 (I think? I have two equal drives that are mirrored) array was causing me a lot of pain. It kept freezing up my system and having me to had to rebuild the RAID too often. After a number of tests and browsing info online, I've decided that the RAID was the culprit of the freezing...
Hardware & Devices
Converting to Raid 0 Windows 7, NOT Hardware Raid 0
I have tried to find the way to do this, but without success as I cannot see the wood for the trees. Any help or URL would be welcome. I have a mature W7 system, with so many applications loaded that rebuilding from scratch is just not an option. I have a 300MB Velociraptor wholly given over to...
Installation & Setup
Win 7 raid 0 setup / missing raid controller driver
Installed a new M4 ssd today and loaded windows on it. Previously i was using 2 raptors in raid 0 for the os and programs. I re raided the 2 raptors and connected them to the jmicron ports and set them up for raid in bios, then created the raid 0 array no prob. Windows doesnt see the array when...
RAID 5 switched from single storage to raid 5, lost drive letter
I am running 7 pro 64bit on a ASUS p8p67 deluxe mobo and I copied all data from my 1tb storage D: drive to a backup external and proceded to install raid 5 with 3 single 1tb drives and the raid is up an running. However using Intel Rapid Storage Technology to setup the raid inside windows I had to...
General Discussion
Windows 7 System Image - Restore Non-RAID to RAID 0+1
I created a windows system image with the backup and restore utility built into win7. This windows install is on a single hard drive. I built and onboard RAID 0+1 array and used the windows 7 install disk to restore the image on to the new RAID volume. Windows starts to boot up but the screen goes...
Backup and Restore
RAID Bluescreen on startup
hello, i'm new on this forum. last week i bought 3 Western digitals caviar blue hard disks, each of 250GB. one is specifically for an ARCH linux installation (done) the other 2 are for a RAID 0 (striping) setting well i tryed setting up a raid in Windows from computer gestions of HD, but the...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App