Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphics issue with Age of Empires II: The Conquerors

29 Oct 2009   #11
unwritten

7 and Mac
 
 

Quote   Quote: Originally Posted by aceivaswe View Post
Hello everybody!!!
I have ''Windows 7'' and i'm playing ''Age Of Empires 2 & The Conquerors Expansion''. I had the same graphic issue but i read some forums and i started to test it my own.

After a while i found a solution that is working fine for me!!

Go to your game folder and locate ''age2_x1''.
Right-click, Properties and choose ''Compatibility'' tab.
Then press on ''Choose settings for all users'' button.
Mark the ''Run this program in compatibility mode for:'' and choose
''Windows 98 / Windows me''
Then under settings mark ''Disable visual themes'', ''Disable desktop composition'', ''Disable display scaling on high DPI settings'' and ''Run this program as an administrator'' and click ''ok'' and again ''ok'' and you are done.

Please test if this works and post.
thank you very much...

I have windows 7 32bit running on Macbook by Bootcamp 3.0

it's work great now... thanks again


My System SpecsSystem Spec
.
29 Oct 2009   #12
Bond007

windows 7
 
 

I have same problem too...

Any one have better solution..?
My System SpecsSystem Spec
29 Oct 2009   #13
SJMX

Windows 7 Professional x64
 
 

A solution i found was:

1) Open the task manager up (right-click on taskbar, and start task manager)
2) Disable "explorer.exe" (yes this will make everything disappear but you can get it back from starting "explorer.exe" again)
3) Start the game by using the task manager (File, New Task (Run))

That seemed to work for me 100% of the time.

Hope you get the same results i did.

Scott
My System SpecsSystem Spec
.

29 Oct 2009   #14
Lord Jon

Windows 7 x64 (build 7100)
 
 

You don't have to run in window mode. Explorer is the main problem. You can create a bat script that fixes everything for you. You have to make a txt file into the dir of the exe, which is properly "C:\Program Files (x86)\Microsoft Games\Age of Empires II\age2_x1". Or on 32 bit systems: "C:\Program Files\Microsoft Games\Age of Empires II\age2_x1".

Open the txt file and copy/past the following:
Quote:
taskkill /F /IM Explorer.exe
age2_x1.exe
Start explorer.exe
Now save and close the txt file and rename the text file to "The Conquerors.bat", make sure that it doesn't end with '.txt' but with '.bat'. All without the quotes.

The only thing you have to do now is making a short cut to the bat file to launch the game. And now you are done! Run the bat file as admin and the game should run without any lag or mistaken colours. Have fun!

EDIT: Aah, I see that you were first SJMX! Good to see that more people found this solution!
My System SpecsSystem Spec
29 Oct 2009   #15
SJMX

Windows 7 Professional x64
 
 

Heh. I may have been first but you did that with style!

Have fun on Age of Empires 2 which is still number one on my favourite games ever list!
My System SpecsSystem Spec
30 Oct 2009   #16
Lord Jon

Windows 7 x64 (build 7100)
 
 

Age of Empires II is together with Stronghold Crusader on my number one games list ever!
I'm still playing lan party's with friends on Age of Empires II.
Also a recommend site for you guys: Age of Kings Heaven.
My System SpecsSystem Spec
30 Oct 2009   #17
ocadsm

Windows 7 x86
 
 

Searching in the forum I found this simple solution, is for starcraft but worked for me.
StarCraft fix holy cow!
My System SpecsSystem Spec
31 Oct 2009   #18
Lord Jon

Windows 7 x64 (build 7100)
 
 

Quote   Quote: Originally Posted by ocadsm View Post
Searching in the forum I found this simple solution, is for starcraft but worked for me.
StarCraft fix holy cow!
Mmm, it sounds very simple. Too bad it doesn't work for me. So I stay with the close explorer method.
My System SpecsSystem Spec
01 Nov 2009   #19
walt13

Win Pro 7 32 bit
 
 

Heavy sigh - I tried all the compatibility items with no luck. I tried the solution posted by SJMX and when I try to run the game file it says to insert the correct disc even though it is in the drive. I tried the batch file posted by Lord Jon - It starts up OK but I end up getting the same disc message and explorer starts back up. The only thing I could not do was run the .bat file as admin - I could not check the box. Any help here is appreciated-thanks.
My System SpecsSystem Spec
01 Nov 2009   #20
walt13

Win Pro 7 32 bit
 
 

More info - I uninstalled Conquerors and reinstalled it. The batch file worked fine and the colors were great. Then I applied the "c" patch and I am now where I was before - the disc is not recognized. Very strange - hopefully a solution?????
My System SpecsSystem Spec
Reply

 Graphics issue with Age of Empires II: The Conquerors




Thread Tools




Similar help and support threads
Thread Forum
Age of Empires 2 Conquerors - Problems with the usual Color Fix
OK, so I've been at this for 6 hours straight now (so please forgive me for any mistakes here, grammatical or otherwise) and I'm flat out of ideas, so I thought it might be a good idea to post my problem online and at least get some second opinions. So the story goes like this; I just recently...
Gaming
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
Gaming
Age of Empires 2: The Conquerors freezing.
Hi, I'm using win 7 x64 ultimate. dx updated. most win updates installed (omitted malicious software tool & etc.) Versions: Age of Kings: 2.0b (failed with 2.0a too), The Conquerors: 1.0e (fails with 1.0c too) AoE: Forgotten Empires installed, runs ok. AoE: Age of Kings runs ok. Tried killing...
Gaming
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
Gaming
Age of Empires II The Conquerors-High Resolution+Music Fix on Win7 64
Hi all I just got a huge itch to play the Age of Empires series again. I played Age of Mythology last week and worked without a hitch on Windows 7. But when trying to install my all time favorite Age of Empires 2 yesterday, ran into a lot of problems - after hours of googling, I have managed to...
Gaming
age of empires II conquerors
salut , am si eu o problema si de fapt nu doar eu cam toata lumea pe care o cunosc si joaca age of empires II conquerors , la win 7 nu merge bine in joc se vede foarte nasol culoarea , am vazut aici la voi ca spuneti ca nu are nici e problema, dar nu e asa , nu e compatibil jocu sau daca voi chiar...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App