Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: windows 7 and age of empires III compatibility issue

18 May 2009   #1

Windows 7 Ultimate
windows 7 and age of empires III compatibility issue

I have installed Age of Empires III and it runs with my windows 7 ultimate, but in the homescreen and game there are severe graphic distortions and I can't play the game.
I have tried changing the compatibility to run the game for windows vista, xp, etc. but nothing works.
I have also uninstalled and reinstalled the game.. help please!

Attached Thumbnails
windows 7 and age of empires III compatibility issue-age-empires.jpg  
My System SpecsSystem Spec
18 May 2009   #2

Win 7 64 bit, 7127

Would need to know more about your system first. I run Age of Empires 3 under Win 7 64 bit, 7127 with no problems. I also had no problems with previous Win 7 Builds, both 32 and 64 bit.

My System:
Intel C2D 6420 2.13 Ghz
nVidia 8600 GTS 256 MB
Win 7 Ult. Build 7127 64 bit

I didn't have to run AoE3 in any compatibility mode. I bet you are having a problem with your vid card. Probably a driver issue. But, like I said, need more info. AoE3 is still a great game.
My System SpecsSystem Spec
27 May 2009   #3

Win7 7100 / WinXP SP2

Go fishing around and see if your Card has a Beta Driver for Win7
I know the ATI one solved my GFX oddities on Win7
My System SpecsSystem Spec

13 Nov 2009   #4

Windows 7 Ulimate
Please help me with the same problem with same game

I also have this same problem I'm running Intel Centrino Duo, 1.73Ghz Windows 7 Ultimate Mobile intel (R) 945 Express chipset Family 2Gb RAM on my Toshiba A100 laptop, worked fine while I had vista, now doesn't even work in compatibility mode If anyone has any ideas on how to get this awesome as game to run please reply Thanks
My System SpecsSystem Spec
13 Nov 2009   #5

Win7 7100 / WinXP SP2

Keywords in your problem
"Intel Mobile 945 Express Chipset"
Bout 90% of all games made with DX 9.0c (AoEIII included) HATE the chip and it doesn't even remotely function in 50% of those.
So if "I" were you I'd search the net for anyone else having this issue with the chipset.
My System SpecsSystem Spec
15 Nov 2009   #6

Windows 7 Ulimate
Aeon Gamer Reply

Yeah I understand that it may not play with most but I've already had it working on my computer before I upgraded to win 7 from vista on Age of empires III. So I'm not sure what's wrong
My System SpecsSystem Spec
14 Dec 2009   #7

windows 7
Age of empires 3

Hello everyone. I installed AOE3 and working. It wouldn´t work but I chosed to play under win xp sp 3 compatibility. All of the *.exe files. It worked but when I tried to go to the hometown, It stop working. Everytime. Can someone please tell me what to do? Thank you.
My System SpecsSystem Spec
15 Dec 2009   #8

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)

My System SpecsSystem Spec
15 Dec 2009   #9

Windows 7 Home Premium x64(desktop), Windows 7 Professional x86(laptop)

It works fine for me in 7 Professional 32 bit on my laptop, with an Intel GMA 965 chipset, and 7 Home Premium 64bit on my desktop.
I think the best thing to do is check all your drivers are up to date, or if that doesn't work, resinstall the game.
My System SpecsSystem Spec
17 Feb 2010   #10

Windows Seven Ultimate 64bits

The game apparently works fine here... but when I put more than 2 teams (for example, 2 vs. 2) the game expose lags (that are so troubling). I have already tried to put the graphic settings in low, but it don't resolve the problem. I think that my pc would support the game perfectly, (Its a core i7 920 3.4Ghz OC, 6GB DDR3, 2x ATI HD5850, MB Asus P6T), because I play Crysis in "Very High settings" with 8X AA and works fine...

Sorry my bad english..

ah, I'm using Win 7 ultimate 64bits
My System SpecsSystem Spec

 windows 7 and age of empires III compatibility issue

Thread Tools

Similar help and support threads
Thread Forum
Windows 10 GPU compatibility issue
Hello, I upgraded my GPU to a GeForce GT 710 about a month ago. Soon after I realized that the rest of my computer needed to be upgraded. Got a new MB, MEM, and CPU to compensate, details listed on profile. Well after all of that, I found out about the offer for a free upgrade to Windows 10, did a...
Graphic Cards
Graphics issue with Age of Empires II: The Conquerors
I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main...
Age of Empires Compatability Issue - Graphics system
Hey, i've come across Age of Empires 2 and AoC expansion and want to play them, however get a grahpics system error. "Could not initialize graphics system. Make sure that your video card and driver are compatible with DirectDraw" My specs are: Dell Inspiron 545 Operating System: Windows 7...
Age of Empires II: TC Graphics Issue
Whenever I play AOE II: The Conquerors Expansion, the colors get distorted. When I emulate it in Windows XP in Sun VirtualBox, its fine. Problem with that is it takes longer for it to load and it cannot be played on my network like that. Is there anything I can do? I've tried disabling themes and...
Age of Empires III compatibility issue
Hello, I've upgraded my Windows Vista to Windows Seven (32-bit), but I'm having trouble running Age of Empires III. It used to work fine prior to Seven's installation. I have reinstalled the game, but when I try to run the game I get the following message (in French): "Le programme...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:00.
Twitter Facebook Google+