Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Older DirectX heavy game has studdering problems.

22 Aug 2010   #1
The Wicked One

Win 7 x64 Ultimate
DirectX heavy game has stuttering problems. x64 DX11

I have a top of the line system and am running Win7Ux64 after a fresh format and an update to all windows files and hardware drivers.

An older game that I used to play on XP was a game called Space Empires V. It was released in 2006. I've been having mouse lag issues when opening windows in the game. I.e. Ship design, Colony statistics, Empire News, Starbase Design, Intelligence reports etc.

After sifting through the forums for that particular game, I was informed that the issue lies with the game utilizing DirectX, but it would seem that the game is reliant on an older version, so DX11 is emulating for the game, which is causing the frame slowdown with in-game windows open.

Since I am on W7Ux64 and with DX11, and I've tried the XP mode, virtualization, and Compatibility changes to no avail, my question is, can I manually adjust settings to D11 for that specific application? I am not terribly familiar with manually ajusting DirectX, nor have I really had a reason to in the past.

Should I download old DX drivers from a driver database and see if it helps? I don't want to put old drivers on my system and have a potential conflict. If I can have the old drivers on my system without screwing up my DX11 games that would be perfect.

Any ideas would help with the problem.

Thanks for your time.

My System SpecsSystem Spec
22 Aug 2010   #2
Microsoft MVP

Win 7 Ultimate x64

The Wicked One, welcome to the forums.

Yes you need to install/update DirectX for older games to work properly. See #5 here,

Tips on Troubleshooting Game Issues

for the download links.
My System SpecsSystem Spec
22 Aug 2010   #3
The Wicked One

Win 7 x64 Ultimate

No I already did. I said that I updated all hardware and windows programs after the format.

I've had the latest version of DX for a while now. Doesn't help anything. Should I try to install DX9c? See if that works?
My System SpecsSystem Spec

22 Aug 2010   #4
Microsoft MVP

Win 7 Ultimate x64

If you installed the latest DirectX Redistributable (now re-neamed DirectX End User Runtimes), then you already have 9.0c.

Looked up that game and it isn't DirectX 9 that you need but DX 8.1,

Space Empires V

and DX 8/8.1 isn't included in the update. No idea what would happen if you tried one of the earlier DX updates that still contains it. It should just install/add the DX 8.1 files and ignore all the others as they will be newer, but you never know. One thing you can try is check the game disk and see if the is a DirectX folder, and if there is either run the installer (if present) or if it is just the DX files add them to the game's installation folder.

One more thing, while looking around at their site, you have the latest patch installed?

Space Empires V: Patch

No idea if it will help, but it came out in mid 2009.
My System SpecsSystem Spec
23 Aug 2010   #5

Windows 10 Pro

Being that Space Empires V is a DirectX 8 game (which speaks of it's age), don't expect too much success in running it on Windows 7. Sorry.

I would suggest you Google the game to see if others have had any luck getting it to run, and what they did to make it so.

In the mean time you should still try the DX 9 updates which this download includes.... Download details: DirectX End-User Runtime

BTW - Windows 7 is fully compatible with games and hardware that use older versions of DirectX

Also checkout step #6 for a better understanding of how DX11 works in relation to older games/hardware - Tips on Troubleshooting Game Issues

Good luck.
My System SpecsSystem Spec

 Older DirectX heavy game has studdering problems.

Thread Tools

Similar help and support threads
Thread Forum
Older pc game on win 7
Game installs fine will not load up and start.Read somewhere there is a work around. Came is MEDAL OF HONOR ALLIED ASSAULT,thanks for any input.
BSOD when quitting a heavy load game / Driver Verifier
Hi there. I'm struggeling with an issue on my machine and hopefully someone can help me. I get sometimes a BSOD after I quitted a game, mostly when it is high end (e.g. Bioshock infinite). I activated then Driver Verifier to search for the source of the problem, got a bluescreen after 1 minute...
BSOD Help and Support
I can't uninstall an older game.
I installed Everquest and and was having problems. I wanted to reinstall. It does not show up in Control Panel>Programs>Uninstall. The game was in my user account folder. I manually deleted every file. Windows Search doesn't come up with any files. The game still runs perfectly. I learn...
DirectX, or game?
Hello Radomly, everytime I'm running World of Warcraft it says "Not Responding" and blinking. Blinking mouse. All this only happends when i'm in-game. Not on logon-screen. I have GTX 260 again, running DX11. I heard that in DX11, it converts to 9, 10, and the 11 depending on the game. Is...
Can I run an older game with xp mode?
Can I run an older game with xp mode in virtual PC mode? I installed and game states "can't start hardware accelerated Direct3d 6" I tried using both integration and disabling integration I did install direct3d battlezone II Any thoughts? I am running windows 7 Professional 64bit host os

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App