Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Game" has stopped working

05 Sep 2010   #1

Windows 7 Ultimate x64
"Game" has stopped working

Hey guys, I just got my RMA'd card back from xfx which was a 250GTS and they returned a 4850 in it's place. I got it all set up again and installed the latest drivers for it and went to play Mafia II and within 15 minutes usually the game will freeze and I ctrl, alt, del only to find the it says "Mafia has stopped working". I googled the issue and people have suggested running the directX program again to update DX which I did.. also I reinstalled PhysX which is needed to run the game, I know that's a Nvidia program but it's needed to play even with ATI cards.

Anyways I tried quite a few things with no success, recently I noticed Mafia II isn't the only game which does this but Mafia II is the only game which consistently freezes within a 15 minute basis. Other games which have done this are Left 4 Dead and Star Wars Galaxies so far, so I am not thinking it is just a certain game problem.

Now I was using a 4890 not to long ago and I never had a issue at all like this, but I had to RMA the 4890 as well because of a different issue (Screen flashing black occasionally).

So the only thing I can think of is the video card is somehow causing the games to crash, does anyone know if there is a way I can narrow it down to being the video card exactly or if somehow there is another issue?. Come to to think of it just now I have not tried to reinstall my video card drivers again which I will give it another shot in a bit here, but for right now if it does not work is there a way to narrow it down to see if it is my video card which is causing the problem?.

My System SpecsSystem Spec
05 Sep 2010   #2

Windows 8 Professional x64

maybe try a "clean install" of the drivers with the steps outlined here (follow the same steps for Windows 7)

the problem could be caused by some remnants of older drivers left behind conflicting with the latest ATI drivers
My System SpecsSystem Spec
05 Sep 2010   #3

Windows 7 Ultimate x64

I always clean the driver properly but thanks for the heads up :), unfortunately this changed nothing. The game still freezes and then it comes up with the "Mafia II has stopped working", I tried uninstalling & reinstalled PhysX multiple times along with running the DX update with it and it doesn't seem to do any good either, neither does tweaking the graphic settings.

I got nothing left to try I can think of, if anyone else has something please let me know.
My System SpecsSystem Spec


 "Game" has stopped working

Thread Tools

Similar help and support threads
Thread Forum
"Realtek HD Audio Manager has stopped working" at Windows Startup
Hello, this is my first post here on this forum. About a week or two, I Downgraded my Computer (Dell l502x) from Windows 8 to Windows 7 Ultimate 64 Bits, installed the drivers from the Dell Page, and everything worked good, except for the Realtek HD Audio Driver Version (Recommended for...
Sound & Audio
"Windows Module Installer has stopped working" message constantly
Hi there, I am getting a repeated "Windows Module Installer has stopped working" message which says that the file that describes the problem is: C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_TrustedInstaller_5480538538f23ac44dfcd994b3e5d340663098_cab_670b9c43\WER9B8A.tmp.hdmp. ...
Windows Updates & Activation
"Windows Control Panel has stopped working" on My Computer Properties
Hi I am running Windows 7 Pro 64-bit on a Lenovo T510. Every single time I do a Properties on My Computer, I get this pop up message that "Windows Control Panel has stopped working". Oddly, I just cancel that window and everything otherwise seems to work normally. But it happens every time...
General Discussion
"has stopped working" on starting apps ;can't install SF Diagnost Tool
Since yesterday when I try to launch several applications they don't work and show "... has stopped working" error message. They had been working perfectly before. I didn't change or install anything. They just stopped working. So far I found these apps not working: DS3_Tool.exe...
BSOD Help and Support
Search Index "Windows explorer has stopped working" error
Hello, I problem I have been geting in the past 2 days is that whenever I use the search index, like for example look in my librarys, program files, or look for anything on my computer, a box pops up saying "Windows explorer has stopped working", and whatever im searching for will automaticaly...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App