Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age of Empires II APPCRASH

10 Oct 2010   #1
dragonslayer75

Windows 7 Home Premium 64bit
 
 
Age of Empires II APPCRASH

Hopefully you all can help me out. I recently rebuilt my PC and upgraded from XP 32bit to 7 64bit. I used a new SATA HD with the install to avoid data corruption from the old one. I have tried various compatability settings and currently it's set for XP Service Pack 2. I've also tried running in Admin Mode.

Here's my error I get:

Problem signature:
Problem Event Name: APPCRASH
Application Name: EMPIRES2.ICD
Application Version: 0.14.22.712
Application Timestamp: 3981d1df
Fault Module Name: dplayerx.DLL
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 396602f5
Exception Code: c0000005
Exception Offset: 00003a12
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 1033
Additional Information 1: 989a
Additional Information 2: 989a2eece94c88e43d080999500de321
Additional Information 3: 4e7c
Additional Information 4: 4e7c87bbc1587161b2639bdf69eae17a






My System SpecsSystem Spec
.
16 Oct 2010   #2
dragonslayer75

Windows 7 Home Premium 64bit
 
 

Ok, so I've been searching the forums for fixes and have tried several with no success. I even bought and new game that also has Age of Empires I on it and it runs just fine. It only seems to be AOE II that has the issue which is odd.

Any ideas??
My System SpecsSystem Spec
17 Oct 2010   #3
Jacobe

Windows 7 64-Bit
 
 

try setting win 7 to classic mode and open up the sreen resolution screen. That fixes the color for me and may fix the crash for you
My System SpecsSystem Spec
.

14 Nov 2010   #4
dragonslayer75

Windows 7 Home Premium 64bit
 
 

Anyone else have any ideas? The above idea didn't work.
My System SpecsSystem Spec
22 Jan 2012   #5
Diex2005

Windows 7 64
 
 

I've all-of-a-sudden got this same problem, but atleast I have a solution.

Buy Windows 7 (or whatever OS your using) Disc, and reinstall windows. Yeah, I know it sucks... but if you wanna PLAY, you gotta PAY.

That usually fixes whatever problem i'm experiencing.

Make sure you back-up all your stuff though.

Then, and ONLY THEN, should it instal and play with no problem.

I havent done it yet, but in the next couple months, i'll try, and let you know if it worked for me.
My System SpecsSystem Spec
17 Feb 2012   #6
Diex2005

Windows 7 64
 
 

Mid-February Update*

IT WORKS. I re-installed windows, and it not only fixed my Game Problem, but it also fixed a problem with some of my other programs.

So just go out, and purchase a copy of Windows 7, or 8... whichever OS you want, re-install Windows, enter your CD Key, and your problems should be solved.

I think the issue I was having, was I modified a .DLL, and it somehow infected other DLLs, and caused a massive problem. Or, it could've been a virus, or hell... mabey it was a Virus that I created by MODIFYING the DLL... i dunno, but it's all Fixed Now.

Good Luck.
My System SpecsSystem Spec
28 Feb 2013   #7
lebanen

Windows 7 Home Premiun 64-Bit
 
 

Try this. I had the same problem and it worked for me:

1. In the start menu search box type "msconfig" and press enter.
2. Click "Selective Startup" in the General tab.
3. Click the Services tab.
4. Click "Hide all Microsoft services"
5. Locate "Browser Manager" manufactured by unknown.
6. Click the checkbox for browser manager to disable the service.
7. Press ok. When prompted for a reboot, reboot.
8. Try the game out. See if it works.
My System SpecsSystem Spec
Reply

 Age of Empires II APPCRASH




Thread Tools




Similar help and support threads
Thread Forum
Age of Empires 2: AoC expansion
Hi guys, I installed W7 and so far it's been working fine. However, I ran into a problem. When I try to play my AoE 2: the Conquerors expansion, everything works. When I start a game, some of the graphics (trees, grass and water) seem highly corrupted (mostly they're much to 'red'). When I put...
Gaming
Age Empires 3 on Windows 7
Hi When I try to run Age of Empires it starts and sort runs, but it closes and I get this message "DisplayInfo.RB_GetScreenIndex - did not find monitor 0, 0, 1920, 1080 Can anyone help. Best regards Rob
Gaming
Age of empires
Can some please tell me if age of empires, will play using windows 7? Thanks, Sarah.
Gaming
Age of Empires II
Hi, I have a problem with Windows 7. I can play Age of Empires II, because the whole picture is green! The video is up to date,knows someone who is wrong? Thx
Gaming
Age of Empires II Problems
I would like to be able to play Age of Empires II (age of kings and conquerors expansion) on my computer (macbook pro) which is running windows 7 through parallels. I am 99% sure this is a windows 7 problem, and not a parallels problem. So I installed AoK and AoC and they load fine, but when I...
Gaming
Age of Empires III! [ALL]
Hello, sorry. I have searched around the forum and I've found out that Age of Empires III does work on Windows 7 BUT I'm too newbie to understand. Can someone please tell me how to make it work? Actually, I'm just having some small issues rather than those extreme ones like whenever I play the...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App