Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Warcraft 3 issues

15 Oct 2010   #1
Hiechamatoa

windows 7 ultimate x64
 
 
Warcraft 3 issues

Hello there... I just installed win7 ultimate x64... Everything works perfect expect for wc3... Im playing wow and hon also got no problem with those games... But to what the issue is about... My screen aint full.. i got 2 black bars on each of the sides... That i can live with... but to the real problem... it laggs like crap... i can get any harmony in my gaming totally delays whole game long...
And its not my internet beacuse my brother plays wc3 on the same time and no lagg for him... same computer but he got vista on his computer... any of you got any ideas?
Ive readed the freakygaming guide... and change the resolution still no help maybe i did something wrong idunno...

Best regards hiecha


My System SpecsSystem Spec
.
15 Oct 2010   #2
sygnus21

Windows 10 Pro
 
 

We need system specs.

Also have a look at this... Tips on Troubleshooting Game Issues

Thanks.
My System SpecsSystem Spec
15 Oct 2010   #3
Hiechamatoa

windows 7 ultimate x64
 
 

My systems
CPU: Pentium(R) Dual-Core CPU T4300 @ 2.10GHz
CPU SPEED: 2.09 GHz Performance Rated at: 3.135 GHz
RAM: 4gb
OS: win7 ultimate 64
VIDEO CARD: You Have: GeForce GTX 280M
My System SpecsSystem Spec
.

15 Oct 2010   #4
sygnus21

Windows 10 Pro
 
 

OK.

Did you look through the link I provided?
Did you try any of them?
Did you check to see if your system meets the minimum system requirements?

All of these and more are in that link.

Let me know.
My System SpecsSystem Spec
15 Oct 2010   #5
Hiechamatoa

windows 7 ultimate x64
 
 

I Downloaded the xdirect file... and checked with my graphic card all was ok there... My system is high over the minimum system requirements for this game... thats the thing thats really bottering me.. it worked really good with vista...
My System SpecsSystem Spec
15 Oct 2010   #6
sygnus21

Windows 10 Pro
 
 

Well maybe the DirectX update will help.

Keep us informed.
My System SpecsSystem Spec
Reply

 Warcraft 3 issues




Thread Tools




Similar help and support threads
Thread Forum
World of Warcraft Addon Issues After Upgrading from Vista to 7
I recently upgraded from Windows Vista x64 to Windows 7 Ultimate x64. EVERYTHING went on about its business just fine except for my WoW addons. I've tried to delete, change, move, and/or update my WoW addons in the location folder and/or via Curse Client. When i'm in the WoW folder all the...
Gaming
Warcraft 3 Issues
Hi, I have search and tried fixes on this site and elsewhere but still I am unable to make Warcraft III LAN game on GArena work. I am able to access a room in GArena, but when joining a game, I am unable to. And when creating a game (from LAN) it shows Game in not found. Although I am able to...
Gaming
Warcraft III RoC + Warcraft III TFT Problem
Hai! For days I've been trying to install Warcraft III RoC and Warcraft III TFT. The first few times I attempted to install RoC it just stopped halfway through and the installation window couldn't be closed. After those few times, I managed to install it. With a boost of hope, I placed the TFT...
Gaming
Warcraft 3
Hello Guys! Today i installed Windows 7 Enterprise Edition on my PC and wanted to install Warcraft 3! So i installed Warcraft 3 ROC and everything went fine. But when i tired to install Warcraft 3 TFT the system told me that i have to install Warcraft 3 ROC before. But the ROC is already...
Gaming
Warcraft III
So I've had Win7 running for about a week now, and I can't get Warcraft III:TFT to work. I've got the French version on CD. I ran the install.exe files as admin and in XP SP2 compatibility mode while installing, and didn't get any problems. I installed the 1.22 full patch too, again running in XP...
Gaming
Warcraft
ok strange problem, i used to be able to run 2 copy of wow at once on my hardware running vista 64, now on windows 7 its not possible, it just grind to a halt my hardware is Intel Q9650 (quad core 3 ghz) 6 Gigs PC800 DDR2 ATI 4850 Graphics.
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:21.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App