Team Fortress 2

Page 6 of 7 FirstFirst ... 4567 LastLast

  1. Posts : 9
    Windows 7 Professional x64 Build 7600
       #51

    Hello again, Seven Forums.

    This time, TF2 (And L4D) seem to be getting very low FPS, 12ish when there's a lot of action going on. No settings change seems to affect it, and it doesn't appear to be the network. I was thinking driver issues, but I could be wrong.

    Specs are in the profile.

    Thanks for any help you can give me!
      My Computer


  2. Posts : 4,925
    Windows 7 Professional 64-bit
       #52

    Make sure you have vsync off and AA and AF set to low values.
      My Computer


  3. Posts : 1
    XP - Vista - 7 - OS X
       #53

    Drivers?


    I find it kind of funny that everyone with a Nvidia card said that the game plays great. But everyone with an ATI card says it is choppy, including myself. That is because ATI's 7 drivers are not totally unbugged yet. Or at least this is the conclusion I have com up with, I have use both my ATI x1650 pro which works fine with vista and TF2 and my friends Nvidia card...not sure of the model. But they are similar cards. With the ATI it was sort of choppy. With the Nvidia card it was clear and better than XP or Vista. So the only thing I could think of is the ATI drivers aren't working the greatest yet.
      My Computer


  4. Posts : 46
    Windows 7 RC 7100 x64
       #54

    Girguy17 said:
    I find it kind of funny that everyone with a Nvidia card said that the game plays great. But everyone with an ATI card says it is choppy, including myself. That is because ATI's 7 drivers are not totally unbugged yet. Or at least this is the conclusion I have com up with, I have use both my ATI x1650 pro which works fine with vista and TF2 and my friends Nvidia card...not sure of the model. But they are similar cards. With the ATI it was sort of choppy. With the Nvidia card it was clear and better than XP or Vista. So the only thing I could think of is the ATI drivers aren't working the greatest yet.
    Im running an ATi card and I play alot of TF2, I have no problems at all. All settings maxed out, rarely go below 50fps. Look at My System Specs if you want hardware details.
      My Computer


  5. Posts : 158
    Windows 7 7600RTM X64
       #55

    I like the Name and avatar Otacon. A fan of MGS, myself. Sorry to go off topic lol
      My Computer


  6. Posts : 1
    Windows 7 64bit
       #56

    Just got done running a benchmark and my score was really low. I've never really understood any of the numbers and such and was wondering if someone could maybe point out something that may be wrong that im doing.

    Edit: Forgot the important figures:
    FPS:9.1
    Scores:229


    Binary:Windows 32bit Visual C++ 1500 Release Oct 22 2009
    Operating system:Windows 7 (build 7600) 64bit
    CPU model:Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz
    CPU flags:2653MHz MMX SSE SSE2 SSE3 SSSE3 SSE41 SSE42 HTT
    GPU model:NVIDIA GeForce GTX 260 8.16.11.9107 896Mb
    Settings

    Render:direct3d11
    Mode:1024x768 windowed
    Shaders:high
    Textures:high
    Filter:trilinear
    Anisotropy:4x
    Occlusion:enabled
    Refraction:enabled
    Volumetric:enabled

    I flashed my bios with the latest, I've updated my video drivers with the latest. and I've tried to disable that Physx thing and it still runs pretty bad. I also have frozen about 5 times while trying to test stuff out in TF2 (3 times on default settings)
      My Computer


  7. Posts : 46
    Windows 7 RC 7100 x64
       #57

    Try lowering your Anisotropy to x2 or even 0 for that matter.
    Can you post up all your Graphic settings for TF2?
      My Computer


  8. Posts : 34
    Windows 7 Home Premium Edition, 64-bit
       #58

    I also seem to be having issues with Team Fortress 2 under Windows 7. I can run the game just fine, until I connect to a server. After is sends all the information and whatnot, when it shows the the server's home page or whatever, the game will soon freeze up, and I'll have to shut it down using task manager. I've tried a lot of things people have said, and they all either confuse me or don't work. Here's some of my specs:

    Windows 7 (32-bit Home Premium)
    2 GB RAM
    NVIDIA GeForce 8400 GS (PCI)
    Intel Pentium 4 2.66 GHz

    If there's any other specs you guys need to help me, I'll be happy to give them to you.
      My Computer


  9. Posts : 46
    Windows 7 RC 7100 x64
       #59

    What graphic setting are you running in TF2??

    " I can run the game just fine, until I connect to a server." This would indicate you can run the game just fine...

    Your system seems to be kind of low spec for the game, its quite CPU and GPU intensive, a 2.6GHz Pentium 4 would struggle I would imagine..
      My Computer


  10. Posts : 34
    Windows 7 Home Premium Edition, 64-bit
       #60

    I'm not sure. I'll check later.

    I've played the game on an even worse CPU just fine, so I don't think that's the issue.
      My Computer


 
Page 6 of 7 FirstFirst ... 4567 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:22.
Find Us