Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: issues with both .net and dx10/9

05 Jun 2009   #1
Kehool

windows XP
 
 
issues with both .net and dx10/9

so whenever i try to start a game i get the message that some important dx9/10.dll is missing which leads me to think that all of it is missing... i thought dx10 was supposed to be included with windows 7? yet when i run dxdiag i am told i am actually running dx11^^

when i try to start lord of the rings online i get an error message because apparently dotnet is missing (that too was supposed to be included right?) when i try to install dotnet 2.0 i am being told it already is installed :/

does anyone know what's going on here?


My System SpecsSystem Spec
.
05 Jun 2009   #2
holo88

Windows 7 Ultimate x32
 
 

I'd suggest downloading directx, should fix the missing files.
Download details: DirectX End-User Runtime


* another way to check it *
hit start, type in dxdiag, and hit enter. it'll tell you what version you have, and if there are any conflicts.
My System SpecsSystem Spec
05 Jun 2009   #3
Kehool

windows XP
 
 

Quote:
yet when i run dxdiag i am told i am actually running dx11^^
already did that

but that link you gave me .. isn't that supposed to install dx9? or did i get that wrong :3
My System SpecsSystem Spec
.

05 Jun 2009   #4
holo88

Windows 7 Ultimate x32
 
 

it my bad i guess i skipped that part

that web installer downloads any updates to any version on your system.
usually fixes any prob i have with direct x.

I'm not too familiar with .net errors, maybe there's an update you need? try using Microsoft update.
My System SpecsSystem Spec
05 Jun 2009   #5
smarteyeball

 
 

Windows 7 has DX11 however no games support it it. DirectX is backwards compatible with 9/10.

However you still need to install the March 2009 DirectX End-User Runtime for support of some older titles. When games start for the first time, a lot tof them will start in DX9 mode until you change them to DX10.

Have you installed these games through Seven or are you trying to run them from your XP location?

If they weren't installed through Seven, that would account for the missing files and .net errors.
My System SpecsSystem Spec
08 Jun 2009   #6
Kehool

windows XP
 
 

well everything seems to work now after i used the directx end user runtime and let the lotro setup handle the installation of .net (no idea why the lotro setup could install it when i couldn't...) thanks for the replies
My System SpecsSystem Spec
Reply

 issues with both .net and dx10/9




Thread Tools




Similar help and support threads
Thread Forum
should i go for dx11 sli or stick to dx10 sli?
hey guys, quick question: dx10 sli setup is well within my budget if i buy used dx10 cards for gaming. i already have a gtx260 core216 gpu and it performs pretty well for a used card. would it make any difference in max setting performance if i build my rig in dx10 sli setup or should i keep...
Gaming
Flight Simulator X DX10 Issues
Hi, I am having graphical issues with FSX when playing in DX10 mode, some effects doesn't appear and there are some glitches. I have a GeForce GTX 260, with the last update, so if someone is having the same issue or knows any solution, please let me know.
Gaming
DX10 prob
Hello My problem is that wen i start my comp and trie to start a dx10 game is not working (Like BFBC2). Then i reinstall nvidia driver 197.13 the games work so long that i dont restart then its the same problem :mad: Plz some one help me
Gaming
Is there a way to use Dx10 in Windows 7?
My Windows 7 Prof x64 uses Dx9.0c(August) and Dx11. I can't find anything about Dx10. DXDIAG shows only Dx11. :confused:
General Discussion
5850 stated DDI:10.1?! DX10.1?
Hmm, I have a Diamond ATI 5850, just came today. Uninstalled drives (had 2x 4850). Then used Driver Sweeper 2.0.5, cleaned all ati drivers. Downloaded newest drivers for 58xx (10/13/09), then installed. Everythings installed fine. But: In DXDIAG, under DDI it stated 10.1 WTF? Im guessing...
Graphic Cards
forget DX10.1 here comes windows 7
Windows 7 Milestone 1 (M1) Ultimate Edition Build 6.1.6519.1 might not show it yet, but it is evolving to become the next generation gaming platform from Microsoft. Windows Vista brought to the table the jump from DirectX 9.x to DirectX 10, and Vista Service Pack 1 delivered the first update to the...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App