Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empires Compatability Issue - Graphics system

17 Nov 2010   #1
Martin D

Windows 7 Home Premium 64bit
Age of Empires Compatability Issue - Graphics system

Hey, i've come across Age of Empires 2 and AoC expansion and want to play them, however get a grahpics system error.

"Could not initialize graphics system. Make sure that your video card and driver are compatible with DirectDraw"

My specs are:
Dell Inspiron 545
Operating System: Windows 7 Home Premium 64bit,
Processor: Intel(R) Core(TM)2 Quad CPU Q8300 @2.50GHz
Memory: 6.00GB
Graphics Card: ATI Radeon HD 4350

Steps I've Taken already:
- I've tried to right click the shortcut and change the compatability to XP server pack 2, run as administrator, updated my graphics card drivers and downloaded the latest directX 11 from the Microsoft Website.

I have no further ideas left, can anybody help?

Many Thanks

My System SpecsSystem Spec
03 Aug 2011   #2

Windows 7 Ultimate SP1 x86

I realise that this is an ancient thread but I had this problem last night so thought I'd share what fixed it:

I had the above issue with AOEII:Age Of Kings. My brief spec is Windows 7 Ultimate (SP1 32bit) and an nVidia 8600 GT graphics card. I did the following (make sure you reboot after each install):

Make sure you're running the latest AOEII:AOK patch (2.0a):

Download Details - Microsoft Download Center - DirectX End-User Runtime

Download and install latest DirectX:

Download Details - Microsoft Download Center - Age of Empires II Update v2.0a

Download and install latest nVidia driver suite. I let the software autodetect my card and reset all of my settings to default. I also installed the full software suite:

Drivers - Download NVIDIA Drivers

Finally, right click the AOE shortcut and click properties. Click on the compatability tab and select the following:

- Run this program in compatabilty mode - Pick Windows XP Service Pack 2 (!!NOT 3!!)
- Disable Visual Themes
- Disable Desktop Composition
- Run this program as an Administrator

One of the above options may work on it's own but that's what I had to do to get it running and I tested it after each step.

Good luck!
My System SpecsSystem Spec

 Age of Empires Compatability Issue - Graphics system

Thread Tools

Similar help and support threads
Thread Forum
Graphics issue with Age of Empires II: The Conquerors
I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main...
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
Windows 7 Compatability Issue
I want to give my brother my older Lexmark X1185 Printer. He has an HP Model# P6243W. The Serial # is MXX93702TZ, and his OS is Windows 7 Home Premium. Will the Printer be compatible with his machine? I have the Driver to install it if it is compatable to his Hewlit Packard. Thanks,...
Hardware & Devices
PC/ TV compatability issue?
Apologies in advance if I don't use technical jargon, it's lost on me, having recently purchased a packard bell imedia d2525 i attempted to use it through my television which i have always been able to do with my previous cpu. I n all the time i've had it i'm yet to get it even to the desktop,...
Hardware & Devices
compatability issue?
for the past week I have been trying to get my network to work, with hp and netgear both, and nothing. today between disconnecting and reconnecting I found out that windows 7 is not compatible with my router Netgear super-g 802.11g 108mbps wireless router. it is only my computer of the four...
Age of Empires II: TC Graphics Issue
Whenever I play AOE II: The Conquerors Expansion, the colors get distorted. When I emulate it in Windows XP in Sun VirtualBox, its fine. Problem with that is it takes longer for it to load and it cannot be played on my network like that. Is there anything I can do? I've tried disabling themes and...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App