Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Age of Empires III, trouble initiallizing Direct3D

23 Nov 2010   #1

Windows 7 Home Premium 64-bit
Age of Empires III, trouble initiallizing Direct3D

Microsoft recently had a deal on Games for Windows Live where Age of empires 3 was only 10 cents. I bought it and played it for about an hour. Now when I try to play it again it says:

"Age of Empires III requires at least a 64 MB video card. This computer appears to have a 0 MB video card. If you wish to upgrade your computer, please contact your computer manufacturer for any necessary assistance.
System information: 2000 MHz, 4064 MB, 0 MB (vendorID 8086, deviceID 2a42)"

Odd, given the fact that I have a 1.7gb video card.

When I click attempt to run, this pops up:

"Initialization Failed
Direct3D initialization failed, Possible causes:
Old or corrupted grpahics driver.
Direct3D improperly installed.
Hardware acceleration disabled.
Starting the application with the workstation locked.

Please check the log file for more information."

What makes this even more strange is the fact that it worked last Sunday, but it won't run today.

My System SpecsSystem Spec
23 Nov 2010   #2

Windows 7 Ultimate x64 SP1

Seems like maybe an update might have happened in the interim. I would suggest you perform a System Restore to Sunday or Saturday when it did work to see if that resolves the issue.
My System SpecsSystem Spec
24 Nov 2010   #3

Windows 7 Home Premium 64-bit

I rebooted my machine and it seems to work again. I don't know why that would be the solution but it is.
My System SpecsSystem Spec


 Age of Empires III, trouble initiallizing Direct3D

Thread Tools

Similar help and support threads
Thread Forum
Direct3D not working with DX 11 installed
I recently formatted my computer and back to factory fresh install of Windows 7. I went to go play a game on my computer and when I tried launching it it gave this error here: I didn't have DirectX installed so I went and downloaded it and then went to try again and...
Direct3D error
Hi Im getting a error when im trying to start a game, doesn't matter what game it is, same error. the error: Could not load Direct3D I've searched for hours and tryed everything, updated DirectX, Drivers, also found something about Adobe flash player that it can bug so i should shut down...
Graphic Cards
Direct3d error
Hi, I was playing online mmorpg, 2 characters opened (2windows/2screens)... Then I got an error something like direct3d settings... forgot what exact error that is then then the 2nd screen closed and my first screen went too bright... How can I fix this? my mobo is asrock n68c- s ucc with...
Graphic Cards
Direct3D Acceleration
Hi, I need help with my Direct3D Acceleration. It says it's disabled and i can't figure out how to enable it. Can anyone help me?
Graphic Cards
direct3D problem
I just installed a game and when I tried to play it, it gave me that message: At first I thought I must have forgotten to turn them on (since the game can still be played fine in windows XP) so I open the DirectX Diagnostic Tool and turn...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:18.
Twitter Facebook Google+